]> git.pld-linux.org Git - packages/Glide_VG.git/blame - Glide_VG.spec
- added glide2_sdk bcond (off by default, glide2x will be built from Glide_V3.spec)
[packages/Glide_VG.git] / Glide_VG.spec
CommitLineData
ac1d23c1
JB
1#
2# Conditional build:
3%bcond_with glide2_sdk # build Glide2x_SDK here (normally built from Glide_V3.spec)
4#
4c49c243 5Summary: Glide runtime for 3Dfx Voodoo Graphics boards
61beb790 6Summary(pl.UTF-8): Środowisko Glide dla kart 3Dfx Voodoo Graphics
cf05b513 7Name: Glide_VG
8Version: 2.46
6eab994c 9Release: 10
4c49c243 10License: 3DFX GLIDE Source Code General Public License
edf0eec0 11Group: Libraries
07dc9c23 12Source0: Glide%{version}.tar.gz
0a60b64a 13# Source0-md5: be7762636b46cb04b238a16f45cfcfa8
07dc9c23 14Patch0: %{name}-asm.patch
63739d9f 15Patch1: %{name}-opt.patch
d98d2b0c 16Patch2: %{name}-morearchs.patch
4dc461ef 17Patch3: %{name}-ioctl.patch
fe94377d 18Patch4: %{name}-soname.patch
26652483 19Patch5: %{name}-C_brainos.patch
ca5929e7 20URL: http://glide.sourceforge.net/
4df864eb 21%ifarch %{ix86}
d5e33c76 22BuildRequires: /usr/bin/gasp
4df864eb 23%endif
ca5929e7
JB
24BuildRequires: xorg-lib-libX11-devel
25BuildRequires: xorg-lib-libXxf86dga-devel
26BuildRequires: xorg-lib-libXxf86vm-devel
e5c076fb 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53af08fa 28
29%description
4c49c243 30This library allows the user to use a 3Dfx Interactive Voodoo Graphics
edf0eec0 31card under Linux.
3d6c707d 32
a216d7c4
JR
33%description -l pl.UTF-8
34Ten pakiet pozwala na używanie kart 3Dfx Interactive Voodoo Graphics
4c49c243
JB
35pod Linuksem.
36
ac1d23c1
JB
37%package devel
38Summary: Development package for Glide 2.x built for Voodoo Graphics
39Summary(pl.UTF-8): Pakiet programistyczny dla Glide 2.x zbudowanego dla Voodoo Graphics
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: Glide2x_SDK >= %{version}
43Provides: Glide2x-devel
44
45%description devel
46Development package for Glide 2.x built for 3Dfx Interactive Voodoo
47Graphics adapters.
48
49%description devel -l pl.UTF-8
50Pakiet programistyczny dla Glide 2.x zbudowanego dla kart 3Dfx
51Interactive Voodoo Graphics.
52
53af08fa 53%package -n Glide2x_SDK
ac1d23c1 54Summary: Development files for Glide 2.x
61beb790 55Summary(pl.UTF-8): Część Glide 2.x przeznaczona dla programistów
cf05b513 56Group: Development/Libraries
d20f55c8 57Conflicts: Glide_SDK
53af08fa 58
59%description -n Glide2x_SDK
60This package includes the headers files, documentation, and test files
61necessary for developing applications that use the 3Dfx Interactive
62Voodoo Graphics, Voodoo Rush, or Voodoo2 card.
63
a216d7c4
JR
64%description -n Glide2x_SDK -l pl.UTF-8
65Ten pakiet zawiera pliki nagłówkowe, dokumentację i pliki testowe
66potrzebne do tworzenia aplikacji używających kart 3Dfx Interactive
4c49c243
JB
67Voodoo Graphics, Voodoo Rush lub Voodoo2.
68
53af08fa 69%prep
cf05b513 70%setup -q -c
63739d9f
JB
71%patch0 -p1
72%patch1 -p1
d98d2b0c 73%patch2 -p1
4dc461ef 74%patch3 -p1
fe94377d 75%patch4 -p1
26652483 76%patch5 -p1
53af08fa 77chmod +x swlibs/include/make/ostype
78
79%build
753c8420 80%{__make} -j1 -f makefile.unix \
c38e5d24 81 CC="%{__cc}" \
d98d2b0c 82 CNODEBUG="%{rpmcflags} -fPIC %{!?debug:-fomit-frame-pointer} \
ca5929e7 83 %{!?debug:-funroll-loops -fexpensive-optimizations -ffast-math}" \
d98d2b0c
JB
84%ifnarch %{ix86}
85 FX_GLIDE_CTRISETUP=1
86%endif
53af08fa 87
88%install
89rm -rf $RPM_BUILD_ROOT
46c6bc1f 90install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
53af08fa 91
92# Install the glibc 2.1 libraries normally
d8c27465
JB
93install sst1/lib/libglide.so.2.46 $RPM_BUILD_ROOT%{_libdir}
94ln -sf libglide.so.2.46 $RPM_BUILD_ROOT%{_libdir}/libglide.so.2
95ln -sf libglide.so.2 $RPM_BUILD_ROOT%{_libdir}/libglide2x.so
403fc473 96ln -sf libglide.so.2 $RPM_BUILD_ROOT%{_libdir}/libglide.so
d8c27465
JB
97install swlibs/lib/libtexus.so.1.1 $RPM_BUILD_ROOT%{_libdir}
98ln -sf libtexus.so.1.1 $RPM_BUILD_ROOT%{_libdir}/libtexus.so.1
99ln -sf libtexus.so.1 $RPM_BUILD_ROOT%{_libdir}/libtexus.so
53af08fa 100
101# Install the executables
07dc9c23
JB
102install swlibs/bin/texus $RPM_BUILD_ROOT%{_bindir}
103install sst1/glide/tests/test00 $RPM_BUILD_ROOT%{_bindir}/test3Dfx
53af08fa 104
ac1d23c1 105%if %{with glide2_sdk}
46c6bc1f
JB
106### SDK
107install -d $RPM_BUILD_ROOT%{_includedir}/glide \
108 $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/{tests,texus/examples}
109
53af08fa 110# Install the headers
cf05b513 111install swlibs/include/3dfx.h $RPM_BUILD_ROOT%{_includedir}/glide
112install sst1/include/glide.h $RPM_BUILD_ROOT%{_includedir}/glide
113install sst1/include/glidesys.h $RPM_BUILD_ROOT%{_includedir}/glide
114install sst1/include/glideutl.h $RPM_BUILD_ROOT%{_includedir}/glide
115install sst1/include/sst1vid.h $RPM_BUILD_ROOT%{_includedir}/glide
116install sst1/include/gump.h $RPM_BUILD_ROOT%{_includedir}/glide
117install swlibs/include/linutil.h $RPM_BUILD_ROOT%{_includedir}/glide
118install swlibs/include/texus.h $RPM_BUILD_ROOT%{_includedir}/glide
53af08fa 119
120# Install the examples and their source
bb15827d
JB
121install sst1/glide/tests/makefile.distrib $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests/makefile
122install sst1/glide/tests/*.3df $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
123install sst1/glide/tests/test??.c $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
124install sst1/glide/tests/tldata.inc $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
125install sst1/glide/tests/tlib.[ch] $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
126gzip -9nf $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests/*.3df
53af08fa 127
128# Install the texture tools source
bb15827d 129install swlibs/texus/examples/makefile.distrib $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/texus/examples/makefile
bb15827d 130install swlibs/texus/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/texus/examples
ac1d23c1 131%endif
edf0eec0 132
53af08fa 133%clean
134rm -rf $RPM_BUILD_ROOT
135
4c49c243
JB
136%post -p /sbin/ldconfig
137%postun -p /sbin/ldconfig
53af08fa 138
139%files
cf05b513 140%defattr(644,root,root,755)
ca5929e7 141%doc glide_license.txt readme.txt
cf05b513 142%attr(755,root,root) %{_bindir}/texus
edf0eec0 143%attr(755,root,root) %{_bindir}/test3Dfx
d8c27465
JB
144%attr(755,root,root) %{_libdir}/libglide.so.2.46
145%attr(755,root,root) %ghost %{_libdir}/libglide.so.2
edf0eec0 146%attr(755,root,root) %{_libdir}/libglide2x.so
d8c27465
JB
147%attr(755,root,root) %{_libdir}/libtexus.so.1.1
148%attr(755,root,root) %ghost %{_libdir}/libtexus.so.1
edf0eec0 149%attr(755,root,root) %{_libdir}/libtexus.so
53af08fa 150
ac1d23c1
JB
151%files devel
152%defattr(644,root,root,755)
153%attr(755,root,root) %{_libdir}/libglide.so
154
155%if %{with glide2_sdk}
53af08fa 156%files -n Glide2x_SDK
cf05b513 157%defattr(644,root,root,755)
edf0eec0 158%doc docs/*.pdf
cf05b513 159%{_includedir}/glide
ac1d23c1
JB
160%{_examplesdir}/glide2x-%{version}
161%endif
This page took 0.07568 seconds and 4 git commands to generate.