]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
- gcc4 fixes, mmx/sse enabled for x86-64, todo added.
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # TODO:
3 #       - fix x86-64 int32<->ptr64 casts.
4 #
5 #       tree.c:88: warning: cast from pointer to integer of different size
6 #       tree.c:102: warning: cast from pointer to integer of different size
7 #       fonts.c:144: warning: cast to pointer from integer of different size
8 #       fonts.c:211: warning: cast to pointer from integer of different size
9 #       gfxcard.c:1451: warning: cast to pointer from integer of different size
10 #       fbdev.c:459: warning: cast from pointer to integer of different size
11 #       fbdev.c:578: warning: cast from pointer to integer of different size
12 #       fbdev.c:708: warning: cast from pointer to integer of different size
13 #       idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
14 #       idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
15 #       idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
16 #
17 # Conditional build:
18 %bcond_with     multi           # build Multi-application core (requires working /dev/fusion*)
19 #
20 Summary:        DirectFB - Hardware graphics acceleration
21 Summary(pl):    DirectFB - Wspomaganie grafiki
22 Name:           DirectFB
23 Version:        0.9.24
24 Release:        1
25 Epoch:          1
26 License:        LGPL v2+
27 Group:          Libraries
28 Source0:        http://www.directfb.org/downloads/Core/%{name}-%{version}.tar.gz
29 # Source0-md5:  1f4b56b20d4e6f5c6ceb15c1c4fd2ecd
30 Source1:        http://www.directfb.org/downloads/Extras/DFBTutorials-0.5.0.tar.gz
31 # Source1-md5:  13e443a64bddd68835b574045d9025e9
32 Patch0:         %{name}-am.patch
33 Patch1:         %{name}-pmake.patch
34 Patch2:         %{name}-fix.patch
35 Patch3:         %{name}-sh.patch
36 Patch4:         %{name}-gcc4.patch
37 URL:            http://www.directfb.org/
38 BuildRequires:  SDL-devel
39 BuildRequires:  XFree86-devel
40 BuildRequires:  autoconf >= 2.52
41 BuildRequires:  automake
42 BuildRequires:  freetype-devel >= 2.0.2
43 BuildRequires:  libjpeg-devel >= 6b
44 BuildRequires:  libpng-devel >= 1.0
45 BuildRequires:  libtool
46 BuildRequires:  libvncserver-devel
47 %{?with_multi:BuildRequires:    linux-fusion-devel}
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sysfsutils-devel >= 1.3.0-3
50 BuildRequires:  zlib-devel >= 1.1.3
51 %{?with_multi:Provides: DirectFB(multi)}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         dfbdir  %{_libdir}/directfb-%{version}
55
56 %define         specflags       -fno-strict-aliasing
57
58 %ifarch %{ix86}
59 # gcc running out of registers with -O0 in generic_mmx.h
60 %define         debugcflags     -O1 -g
61 %endif
62
63 %description
64 DirectFB hardware graphics acceleration - libraries.
65
66 %description -l pl
67 Wspomaganie grafiki DirectFB - biblioteki.
68
69 %package devel
70 Summary:        DirectFB - development package
71 Summary(pl):    DirectFB - pliki nag³ówkowe
72 Group:          Development/Libraries
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74 Requires:       zlib-devel >= 1.1.3
75
76 %description devel
77 DirectFB header files.
78
79 %description devel -l pl
80 Pliki nag³ówkowe dla DirectFB.
81
82 %package static
83 Summary:        DirectFB static libraries
84 Summary(pl):    Statyczne biblioteki DirectFB
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
87
88 %description static
89 DirectFB static libraries.
90
91 %description static -l pl
92 Statyczne biblioteki DirectFB.
93
94 %package doc
95 Summary:        DirectFB - documentation
96 Summary(pl):    DirectFB - dokumentacja
97 Group:          Development/Libraries
98
99 %description doc
100 DirectFB documentation and tutorials.
101
102 %description doc -l pl
103 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
104
105 %package core-sdl
106 Summary:        SDL core system for DirectFB
107 Summary(pl):    System SDL dla DirectFB
108 Group:          Libraries
109 Requires:       %{name} = %{epoch}:%{version}-%{release}
110
111 %description core-sdl
112 This package contains SDL core system module for DirectFB.
113
114 %description core-sdl -l pl
115 Ten pakiet zawiera modu³ systemu SDL dla DirectFB.
116
117 %package core-vnc
118 Summary:        VNC core system for DirectFB
119 Summary(pl):    System VNC dla DirectFB
120 Group:          Libraries
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122
123 %description core-vnc
124 This package contains VNC core system module for DirectFB.
125
126 %description core-vnc -l pl
127 Ten pakiet zawiera modu³ systemu VNC dla DirectFB.
128
129 %package core-x11
130 Summary:        X11 core system for DirectFB
131 Summary(pl):    System X11 dla DirectFB
132 Group:          Libraries
133 Requires:       %{name} = %{epoch}:%{version}-%{release}
134
135 %description core-x11
136 This package contains X11 core system module for DirectFB.
137
138 %description core-x11 -l pl
139 Ten pakiet zawiera modu³ systemu X11 dla DirectFB.
140
141 %package font-ft2
142 Summary:        FreeType2 font provider for DirectFB
143 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
144 Group:          Libraries
145 Requires:       %{name} = %{epoch}:%{version}-%{release}
146
147 %description font-ft2
148 This package contains FreeType2 font provider for DirectFB.
149
150 %description font-ft2 -l pl
151 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
152 bibliotekê FreeType2.
153
154 %package image-jpeg
155 Summary:        JPEG image provider for DirectFB
156 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
157 Group:          Libraries
158 Requires:       %{name} = %{epoch}:%{version}-%{release}
159
160 %description image-jpeg
161 This package contains JPEG image provider for DirectFB.
162
163 %description image-jpeg -l pl
164 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
165
166 %package image-png
167 Summary:        PNG image provider for DirectFB
168 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
169 Group:          Libraries
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171
172 %description image-png
173 This package contains PNG image provider for DirectFB.
174
175 %description image-png -l pl
176 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
177
178 %package input-elo
179 Summary:        ELO touchscreen input driver for DirectFB
180 Summary(pl):    Sterownik wej¶ciowy do touchscreenów ELO dla DirectFB
181 Group:          Libraries
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183
184 %description input-elo
185 ELO touchscreen input driver for DirectFB.
186
187 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
188 unless you don't have ELO device connected to this port. It can mess
189 with other devices connected to this port (mouse, modem etc.).
190
191 %description input-elo -l pl
192 Sterownik wej¶ciowy do touchscreenów ELO dla DirectFB.
193
194 UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
195 nie nale¿y go instalowaæ, je¶li urz±dzenie ELO nie jest pod³±czone do
196 tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
197 pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
198
199 %package input-mutouch
200 Summary:        MuTouch touchscreen input driver for DirectFB
201 Summary(pl):    Sterownik wej¶ciowy do touchscreenów MuTouch dla DirectFB
202 Group:          Libraries
203 Requires:       %{name} = %{epoch}:%{version}-%{release}
204
205 %description input-mutouch
206 MuTouch touchscreen input driver for DirectFB.
207
208 NOTE: it needs "mut-device" setting in directfbrc in order to work.
209
210 %description input-mutouch -l pl
211 Sterownik wej¶ciowy do touchscreenów MuTouch dla DirectFB.
212
213 UWAGA: do dzia³ania potrzebuje ustawienia "mut-device" w directfbrc.
214
215 %prep
216 %setup -q -a1
217 %patch0 -p1
218 %patch1 -p1
219 %patch2 -p1
220 %patch3 -p1
221 %patch4 -p1
222
223 %build
224 %{__libtoolize}
225 %{__aclocal}
226 %{__autoconf}
227 %{__automake}
228 # MMX and SSE are detected at runtime, so it's safe to enable
229 %configure \
230         %{!?debug:--disable-debug} \
231         --disable-maintainer-mode \
232         --enable-elo-input \
233         --enable-fast-install \
234         --enable-linux-input \
235         %{?with_multi:--enable-multi} \
236         --enable-mutouch \
237         --enable-sdl \
238         --enable-shared \
239         --enable-static \
240         --enable-unique \
241         --enable-video4linux2 \
242         --enable-voodoo \
243         --enable-x11 \
244         --enable-zlib \
245 %ifarch %{ix86} %{x8664}
246 %ifnarch i386 i486
247         --enable-mmx \
248 %endif
249 %ifnarch i386 i486 i586
250         --enable-sse
251 %endif
252 %endif
253
254 %{__make} \
255         X11_LIBS=%{_prefix}/X11R6/%{_lib}
256
257 %install
258 rm -rf $RPM_BUILD_ROOT
259 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_sysconfdir}}
260
261 %{__make} install \
262         DESTDIR=$RPM_BUILD_ROOT
263
264 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
265
266 touch $RPM_BUILD_ROOT%{_sysconfdir}/directfbrc
267
268 %clean
269 rm -rf $RPM_BUILD_ROOT
270
271 %post   -p /sbin/ldconfig
272 %postun -p /sbin/ldconfig
273
274 %files
275 %defattr(644,root,root,755)
276 %doc AUTHORS ChangeLog NEWS README TODO
277 %attr(755,root,root) %{_bindir}/dfbdump
278 %attr(755,root,root) %{_bindir}/dfbg
279 %attr(755,root,root) %{_bindir}/dfbinfo
280 %attr(755,root,root) %{_bindir}/dfblayer
281 %attr(755,root,root) %{_bindir}/dfbproxy
282 %attr(755,root,root) %{_bindir}/dfbscreen
283 %attr(755,root,root) %{_bindir}/dfbsummon
284 %attr(755,root,root) %{_bindir}/uwmdump
285 %attr(755,root,root) %{_libdir}/libdirect-*.so.*.*.*
286 %attr(755,root,root) %{_libdir}/libdirectfb-*.so.*.*.*
287 %attr(755,root,root) %{_libdir}/libfusion-*.so.*.*.*
288 %attr(755,root,root) %{_libdir}/libuniquewm-*.so.*.*.*
289 %attr(755,root,root) %{_libdir}/libvoodoo-*.so.*.*.*
290 %dir %{dfbdir}
291 %dir %{dfbdir}/gfxdrivers
292 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
293 %dir %{dfbdir}/inputdrivers
294 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
295 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
296 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_linux_input.so
297 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
298 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
299 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
300 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
301 %dir %{dfbdir}/interfaces
302 %dir %{dfbdir}/interfaces/IDirectFB
303 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFB/lib*.so
304 %dir %{dfbdir}/interfaces/IDirectFBDataBuffer
305 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDataBuffer/lib*.so
306 %dir %{dfbdir}/interfaces/IDirectFBDisplayLayer
307 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDisplayLayer/lib*.so
308 %dir %{dfbdir}/interfaces/IDirectFBEventBuffer
309 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBEventBuffer/lib*.so
310 %dir %{dfbdir}/interfaces/IDirectFBFont
311 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
312 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dispatcher.so
313 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_requestor.so
314 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
315 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dispatcher.so
316 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
317 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
318 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_requestor.so
319 %dir %{dfbdir}/interfaces/IDirectFBInputDevice
320 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBInputDevice/lib*.so
321 %dir %{dfbdir}/interfaces/IDirectFBPalette
322 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBPalette/lib*.so
323 %dir %{dfbdir}/interfaces/IDirectFBScreen
324 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBScreen/lib*.so
325 %dir %{dfbdir}/interfaces/IDirectFBSurface
326 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBSurface/lib*.so
327 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
328 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
329 %dir %{dfbdir}/interfaces/IDirectFBWindow
330 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBWindow/lib*.so
331 %dir %{dfbdir}/systems
332 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
333 %dir %{dfbdir}/wm
334 %attr(755,root,root) %{dfbdir}/wm/*.so
335 %{_datadir}/directfb-%{version}
336 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/directfbrc
337 %{_mandir}/man1/dfbg.1*
338 %{_mandir}/man5/*
339
340 %files devel
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_bindir}/directfb-config
343 %attr(755,root,root) %{_bindir}/directfb-csource
344 %attr(755,root,root) %{_libdir}/libdirect.so
345 %attr(755,root,root) %{_libdir}/libdirectfb.so
346 %attr(755,root,root) %{_libdir}/libfusion.so
347 %attr(755,root,root) %{_libdir}/libuniquewm.so
348 %attr(755,root,root) %{_libdir}/libvoodoo.so
349 %{_libdir}/libdirect.la
350 %{_libdir}/libdirectfb.la
351 %{_libdir}/libfusion.la
352 %{_libdir}/libuniquewm.la
353 %{_libdir}/libvoodoo.la
354 %{_includedir}/directfb
355 %{_includedir}/directfb-internal
356 %{_pkgconfigdir}/*.pc
357 %{_mandir}/man1/directfb-csource.1*
358
359 %files static
360 %defattr(644,root,root,755)
361 %{_libdir}/lib*.a
362 %{dfbdir}/gfxdrivers/*.*[ao]
363 %{dfbdir}/inputdrivers/*.*[ao]
364 %{dfbdir}/interfaces/*/*.*[ao]
365 %{dfbdir}/systems/*.*[ao]
366 %{dfbdir}/wm/*.*[ao]
367
368 %files doc
369 %defattr(644,root,root,755)
370 %doc docs/html/*.{html,png}
371 %{_examplesdir}/%{name}-%{version}
372
373 %files core-sdl
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
376 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
377
378 %files core-vnc
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_vncinput.so
381 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_vnc.so
382
383 %files core-x11
384 %defattr(644,root,root,755)
385 %doc systems/x11/README
386 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_x11input.so
387 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_x11.so
388
389 %files font-ft2
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
392
393 %files image-jpeg
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
396
397 %files image-png
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
400
401 %files input-elo
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_elo.so
404
405 %files input-mutouch
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_mutouch.so
This page took 0.126974 seconds and 3 git commands to generate.