]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
- gcc4 fixes, mmx/sse enabled for x86-64, todo added.
authorPaweł Sikora <pluto@pld-linux.org>
Thu, 26 Jan 2006 21:29:36 +0000 (21:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    DirectFB.spec -> 1.66

DirectFB.spec

index ea6c7227ab3bc87fd31dd7805ce301b2eaa8b161..5aa86e93639eae76378d6294ac8f1342fefb9388 100644 (file)
@@ -1,4 +1,19 @@
 #
+# TODO:
+#      - fix x86-64 int32<->ptr64 casts.
+#
+#      tree.c:88: warning: cast from pointer to integer of different size
+#      tree.c:102: warning: cast from pointer to integer of different size
+#      fonts.c:144: warning: cast to pointer from integer of different size
+#      fonts.c:211: warning: cast to pointer from integer of different size
+#      gfxcard.c:1451: warning: cast to pointer from integer of different size
+#      fbdev.c:459: warning: cast from pointer to integer of different size
+#      fbdev.c:578: warning: cast from pointer to integer of different size
+#      fbdev.c:708: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
+#
 # Conditional build:
 %bcond_with    multi           # build Multi-application core (requires working /dev/fusion*)
 #
@@ -18,6 +33,7 @@ Patch0:               %{name}-am.patch
 Patch1:                %{name}-pmake.patch
 Patch2:                %{name}-fix.patch
 Patch3:                %{name}-sh.patch
+Patch4:                %{name}-gcc4.patch
 URL:           http://www.directfb.org/
 BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
@@ -37,6 +53,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dfbdir  %{_libdir}/directfb-%{version}
 
+%define                specflags       -fno-strict-aliasing
+
 %ifarch %{ix86}
 # gcc running out of registers with -O0 in generic_mmx.h
 %define                debugcflags     -O1 -g
@@ -200,6 +218,7 @@ UWAGA: do dzia
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -223,7 +242,7 @@ UWAGA: do dzia
        --enable-voodoo \
        --enable-x11 \
        --enable-zlib \
-%ifarch %{ix86}
+%ifarch %{ix86} %{x8664}
 %ifnarch i386 i486
        --enable-mmx \
 %endif
@@ -232,7 +251,8 @@ UWAGA: do dzia
 %endif
 %endif
 
-%{__make}
+%{__make} \
+       X11_LIBS=%{_prefix}/X11R6/%{_lib}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.089702 seconds and 4 git commands to generate.