]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- workaround for building with boost 1.59
[packages/CEGUI.git] / CEGUI.spec
1 #
2 # Conditional build:
3 %bcond_without  xercesc         # build XercesParser
4 %bcond_without  ogre            # build without Ogre renderer
5 %bcond_without  opengl          # build without OpenGL renderer
6 %bcond_with     directb         # unsupported by upstream
7 %bcond_with     samples         # build samples
8 #
9 Summary:        CEGUI - a free library providing windowing and widgets
10 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
11 Name:           CEGUI
12 Version:        0.8.4
13 Release:        5
14 License:        LGPL v2.1+ (with MIT parts)
15 Group:          Libraries
16 Source0:        http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
17 # Source0-md5:  344917301b5ed867a07575ee6a828667
18 Source1:        http://downloads.sourceforge.net/crayzedsgui/cegui-docs-%{version}.tar.bz2
19 # Source1-md5:  1096bf8c84bf6a22e8892ab9258c22f6
20 Patch0:         pthread.patch
21 Patch1:         %{name}-glfw3.patch
22 Patch2:         %{name}-python.patch
23 Patch3:         x32.patch
24 Patch4:         boost-1.59.patch
25 URL:            http://www.cegui.org.uk/
26 BuildRequires:  DevIL-devel
27 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.2.0}
28 BuildRequires:  FreeImage-devel
29 BuildRequires:  GLM
30 BuildRequires:  OpenGL-devel
31 BuildRequires:  SILLY-devel >= 0.1.0
32 BuildRequires:  boost-devel >= 1.36.0
33 BuildRequires:  boost-python-devel >= 1.36.0
34 BuildRequires:  cmake >= 2.8
35 BuildRequires:  corona-devel
36 BuildRequires:  doxygen
37 BuildRequires:  expat-devel
38 BuildRequires:  fribidi-devel
39 BuildRequires:  freetype-devel >= 2.0
40 BuildRequires:  glew-devel
41 # for SampleFramework
42 BuildRequires:  glfw-devel
43 BuildRequires:  gtk+2-devel >= 2:2.4
44 BuildRequires:  irrlicht-devel >= 1.4
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool >= 2:1.5
47 BuildRequires:  libxml2-devel >= 1:2.6
48 BuildRequires:  lua51-devel >= 5.1
49 BuildRequires:  minizip-devel
50 %if %{with ogre}
51 BuildRequires:  ogre-devel >= 1.6.0
52 BuildRequires:  ois-devel >= 1.0.0
53 %endif
54 BuildRequires:  pcre-devel >= 5.0
55 BuildRequires:  pkgconfig
56 BuildRequires:  python-devel >= 2
57 BuildRequires:  rapidxml
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  tinyxml-devel
60 BuildRequires:  tolua++-devel
61 %{?with_xercesc:BuildRequires:  xerces-c-devel}
62 # for irrlicht renderer
63 BuildRequires:  xorg-lib-libXxf86vm-devel
64 %if %{with opengl}
65 BuildRequires:  GLM
66 BuildRequires:  OpenGL-GLU-devel
67 BuildRequires:  glew-devel
68 BuildRequires:  glfw-devel
69 %endif
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 CEGUI stands for Crazy Eddie's Gui System; a free library providing
74 windowing and widgets for graphics APIs / engines where such
75 functionality is not natively available, or severely lacking. The
76 library is object orientated, written in C++, and targeted at games
77 developers who should be spending their time creating great games, not
78 building GUI sub-systems!
79
80 %description -l pl.UTF-8
81 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
82 zapewniającą okienka i widgety dla graficznych API i silników tam,
83 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
84 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
85 skierowana dla programistów gier, którzy powinni spędzać czas na
86 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
87
88 %package devel
89 Summary:        Development files for CEGUI
90 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       freetype-devel >= 2.0
94 Requires:       libstdc++-devel
95 Requires:       pcre-devel >= 5.0
96
97 %description devel
98 CEGUI headers.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe CEGUI.
102
103 %package docs
104 Summary:        Documentation files for CEGUI
105 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
106 Group:          Documentation
107 Requires:       %{name} = %{version}-%{release}
108
109 %description docs
110 CEGUI documentation.
111
112 %description docs -l pl.UTF-8
113 Dokumentacja CEGUI.
114
115 %package ImageCodec-Corona
116 Summary:        CoronaImageCodec library for CEGUI
117 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description ImageCodec-Corona
122 CoronaImageCodec library for CEGUI.
123
124 %description ImageCodec-Corona -l pl.UTF-8
125 Biblioteka CoronaImageCodec dla CEGUI
126
127 %package ImageCodec-Corona-devel
128 Summary:        Header files for CEGUI CoronaImageCodec library
129 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
130 Group:          Development/Libraries
131 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
132 Requires:       %{name}-devel = %{version}-%{release}
133 Requires:       corona-devel
134
135 %description ImageCodec-Corona-devel
136 Header files for CEGUI CoronaImageCodec library.
137
138 %description ImageCodec-Corona-devel -l pl.UTF-8
139 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
140
141 %package ImageCodec-DevIL
142 Summary:        DevILImageCodec library for CEGUI
143 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
144 Group:          Libraries
145 Requires:       %{name} = %{version}-%{release}
146
147 %description ImageCodec-DevIL
148 DevILImageCodec library for CEGUI.
149
150 %description ImageCodec-DevIL -l pl.UTF-8
151 Biblioteka DevILImageCodec dla CEGUI
152
153 %package ImageCodec-DevIL-devel
154 Summary:        Header files for CEGUI DevILImageCodec library
155 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
156 Group:          Development/Libraries
157 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
158 Requires:       %{name}-devel = %{version}-%{release}
159 Requires:       DevIL-devel
160
161 %description ImageCodec-DevIL-devel
162 Header files for CEGUI DevILImageCodec library.
163
164 %description ImageCodec-DevIL-devel -l pl.UTF-8
165 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
166
167 %package ImageCodec-FreeImage
168 Summary:        FreeImageImageCodec library for CEGUI
169 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
170 Group:          Libraries
171 Requires:       %{name} = %{version}-%{release}
172
173 %description ImageCodec-FreeImage
174 FreeImageImageCodec library for CEGUI.
175
176 %description ImageCodec-FreeImage -l pl.UTF-8
177 Biblioteka FreeImageImageCodec dla CEGUI
178
179 %package ImageCodec-FreeImage-devel
180 Summary:        Header files for CEGUI FreeImageImageCodec library
181 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
182 Group:          Development/Libraries
183 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
184 Requires:       %{name}-devel = %{version}-%{release}
185 Requires:       FreeImage-devel
186
187 %description ImageCodec-FreeImage-devel
188 Header files for CEGUI FreeImageImageCodec library.
189
190 %description ImageCodec-FreeImage-devel -l pl.UTF-8
191 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
192
193 %package ImageCodec-SILLY
194 Summary:        SILLYImageCodec library for CEGUI
195 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
196 Group:          Libraries
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       SILLY >= 0.1.0
199
200 %description ImageCodec-SILLY
201 SILLYImageCodec library for CEGUI.
202
203 %description ImageCodec-SILLY -l pl.UTF-8
204 Biblioteka SILLYImageCodec dla CEGUI
205
206 %package ImageCodec-SILLY-devel
207 Summary:        Header files for CEGUI SILLYImageCodec library
208 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
209 Group:          Development/Libraries
210 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       SILLY-devel >= 0.1.0
213
214 %description ImageCodec-SILLY-devel
215 Header files for CEGUI SILLYImageCodec library.
216
217 %description ImageCodec-SILLY-devel -l pl.UTF-8
218 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
219
220 %package Parser-Expat
221 Summary:        Expat-based XML parser module
222 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Expat
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225
226 %description Parser-Expat
227 Expat-based XML parser module.
228
229 %description Parser-Expat -l pl.UTF-8
230 Moduł analizatora XML oparty na bibliotece Expat.
231
232 %package Parser-LibXML
233 Summary:        LibXML-based XML parser module
234 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece LibXML
235 Group:          Libraries
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       libxml2 >= 1:2.6
238
239 %description Parser-LibXML
240 LibXML-based XML parser module.
241
242 %description Parser-LibXML -l pl.UTF-8
243 Moduł analizatora XML oparty na bibliotece LibXML.
244
245 %package Parser-RapidXML
246 Summary:        RapidXML-based XML parser module
247 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece RapidXML
248 Group:          Libraries
249 Requires:       %{name} = %{version}-%{release}
250
251 %description Parser-RapidXML
252 RapidXML-based XML parser module.
253
254 %description Parser-RapidXML -l pl.UTF-8
255 Moduł analizatora XML oparty na bibliotece RapidXML.
256
257 %package Parser-TinyXML
258 Summary:        TinyXML-based XML parser module
259 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece TinyXML
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262
263 %description Parser-TinyXML
264 TinyXML-based XML parser module.
265
266 %description Parser-TinyXML -l pl.UTF-8
267 Moduł analizatora XML oparty na bibliotece TinyXML.
268
269 %package Parser-Xerces
270 Summary:        Xerces-based XML parser module
271 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Xerces
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274
275 %description Parser-Xerces
276 Xerces-based XML parser module.
277
278 %description Parser-Xerces -l pl.UTF-8
279 Moduł analizatora XML oparty na bibliotece Xerces.
280
281 %package Renderer-DirectFB
282 Summary:        DirectFBRenderer library for CEGUI
283 Summary(pl.UTF-8):      Biblioteka DirectFBRenderer dla CEGUI
284 Group:          Libraries
285 Requires:       %{name} = %{version}-%{release}
286 Requires:       DirectFB >= 1.2.0
287
288 %description Renderer-DirectFB
289 DirectFBRenderer library for CEGUI.
290
291 %description Renderer-DirectFB -l pl.UTF-8
292 Biblioteka DirectFBRenderer dla CEGUI
293
294 %package Renderer-DirectFB-devel
295 Summary:        Header files for CEGUI DirectFBRenderer library
296 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer
297 Group:          Development/Libraries
298 Requires:       %{name}-Renderer-DirectFB = %{version}-%{release}
299 Requires:       %{name}-devel = %{version}-%{release}
300 Requires:       DirectFB-devel >= 1.2.0
301
302 %description Renderer-DirectFB-devel
303 Header files for CEGUI DirectFBRenderer library.
304
305 %description Renderer-DirectFB-devel -l pl.UTF-8
306 Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer.
307
308 %package Renderer-Irrlicht
309 Summary:        IrrlichtRenderer library for CEGUI
310 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
311 Group:          Libraries
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       irrlicht >= 1.4
314
315 %description Renderer-Irrlicht
316 IrrlichtRenderer library for CEGUI.
317
318 %description Renderer-Irrlicht -l pl.UTF-8
319 Biblioteka IrrlichtRenderer dla CEGUI
320
321 %package Renderer-Irrlicht-devel
322 Summary:        Header files for CEGUI IrrlichtRenderer library
323 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
324 Group:          Development/Libraries
325 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
326 Requires:       %{name}-devel = %{version}-%{release}
327 Requires:       irrlicht-devel >= 1.4
328
329 %description Renderer-Irrlicht-devel
330 Header files for CEGUI IrrlichtRenderer library.
331
332 %description Renderer-Irrlicht-devel -l pl.UTF-8
333 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
334
335 %package Renderer-Ogre
336 Summary:        OgreRenderer library for CEGUI
337 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
338 Group:          Libraries
339 Requires:       %{name} = %{version}-%{release}
340 Obsoletes:      CEGUI-Ogre
341
342 %description Renderer-Ogre
343 OgreRenderer library for CEGUI.
344
345 %description Renderer-Ogre -l pl.UTF-8
346 Biblioteka OgreRenderer dla CEGUI
347
348 %package Renderer-Ogre-devel
349 Summary:        Header files for CEGUI OgreRenderer library
350 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
351 Group:          Development/Libraries
352 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
353 Requires:       %{name}-devel = %{version}-%{release}
354 Requires:       ogre-devel >= 1.6.0
355 Obsoletes:      CEGUI-Ogre-devel
356
357 %description Renderer-Ogre-devel
358 Header files for CEGUI OgreRenderer library.
359
360 %description Renderer-Ogre-devel -l pl.UTF-8
361 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
362
363 %package Renderer-OpenGL
364 Summary:        OpenGLRenderer library for CEGUI
365 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
366 Group:          Libraries
367 Requires:       %{name} = %{version}-%{release}
368 Obsoletes:      CEGUI-OpenGL
369
370 %description Renderer-OpenGL
371 OpenGLRenderer library for CEGUI.
372
373 %description Renderer-OpenGL -l pl.UTF-8
374 Biblioteka OpenGLRenderer dla CEGUI.
375
376 %package Renderer-OpenGL-devel
377 Summary:        Header files for CEGUI OpenGLRenderer library
378 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
379 Group:          Development/Libraries
380 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
381 Requires:       %{name}-devel = %{version}-%{release}
382 Requires:       OpenGL-GLU-devel
383 Requires:       OpenGL-glut-devel
384 Requires:       glew-devel
385 Obsoletes:      CEGUI-OpenGL-devel
386
387 %description Renderer-OpenGL-devel
388 Header files for CEGUI OpenGLRenderer library.
389
390 %description Renderer-OpenGL-devel -l pl.UTF-8
391 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
392
393 %package -n python-CEGUI
394 Summary:        Python binding for CEGUI
395 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
396 Group:          Libraries/Python
397 Requires:       %{name} = %{version}-%{release}
398
399 %description -n python-CEGUI
400 Python binding for CEGUI.
401
402 %description -n python-CEGUI -l pl.UTF-8
403 Wiązania Pythona do CEGUI.
404
405 %package -n python-CEGUI-Renderer-Ogre
406 Summary:        Python binding for CEGUI OgreRenderer library
407 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
408 Group:          Libraries/Python
409 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
410 Requires:       python-CEGUI = %{version}-%{release}
411
412 %description -n python-CEGUI-Renderer-Ogre
413 Python binding for CEGUI OgreRenderer library.
414
415 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
416 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
417
418 %package -n python-CEGUI-Renderer-OpenGL
419 Summary:        Python binding for CEGUI OpenGLRenderer library
420 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
421 Group:          Libraries/Python
422 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
423 Requires:       python-CEGUI = %{version}-%{release}
424
425 %description -n python-CEGUI-Renderer-OpenGL
426 Python binding for CEGUI OpenGLRenderer library.
427
428 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
429 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
430
431 %prep
432 %setup -q -a 1 -n cegui-%{version}
433 %patch0 -p1
434 %patch1 -p1
435 %patch2 -p1
436 %patch3 -p1
437 %patch4 -p1
438
439 %build
440 install -d build
441 cd build
442 %cmake .. \
443         -DCEGUI_SAMPLES_ENABLED:BOOL=%{?with_samples:ON}%{!?with_samples:OFF} \
444         -DCEGUI_BUILD_RENDERER_DIRECTFB:BOOL=%{?with_directfb:ON}%{!?with_directfb:OFF} \
445         -DCEGUI_BUILD_RENDERER_OPENGL:BOOL=%{?with_opengl:ON}%{!?with_opengl:OFF} \
446         -DCEGUI_BUILD_RENDERER_OGRE:BOOL=%{?with_ogre:ON}%{!?with_ogre:OFF} \
447         -DCEGUI_BUILD_XMLPARSER_XERCES:BOOL=%{?with_xercesc:ON}%{!?with_xercesc:OFF} \
448         -DCEGUI_OPTION_DEFAULT_IMAGECODEC:STRING=FreeImageImageCodec \
449         -DCEGUI_OPTION_DEFAULT_XMLPARSER:STRING=LibxmlParser \
450         -DCEGUI_PYTHON_INSTALL_DIR=%{py_sitedir}
451
452 %{__make} -j1
453
454 %install
455 rm -rf $RPM_BUILD_ROOT
456
457 %{__make} -C build install/fast \
458         DESTDIR=$RPM_BUILD_ROOT
459
460 %if %{without samples}
461 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cegui-0/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
462 %endif
463
464 %clean
465 rm -rf $RPM_BUILD_ROOT
466
467 %post   -p /sbin/ldconfig
468 %postun -p /sbin/ldconfig
469
470 %post   Renderer-Irrlicht -p /sbin/ldconfig
471 %postun Renderer-Irrlicht -p /sbin/ldconfig
472 %post   Renderer-Ogre -p /sbin/ldconfig
473 %postun Renderer-Ogre -p /sbin/ldconfig
474 %post   Renderer-OpenGL -p /sbin/ldconfig
475 %postun Renderer-OpenGL -p /sbin/ldconfig
476
477 %files
478 %defattr(644,root,root,755)
479 %doc doc/README.orig
480 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
482 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libCEGUICommonDialogs-0.so.2
484 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule-0.so.2
486 # plugins
487 %dir %{_libdir}/cegui-0.8
488 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoreWindowRendererSet.so
489
490 %files docs
491 %defattr(644,root,root,755)
492 %doc cegui-docs-%{version}/*
493
494 %files devel
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_bindir}/toluappcegui-0.8
497 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so
498 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so
499 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so
500 %dir %{_includedir}/cegui-0
501 %dir %{_includedir}/cegui-0/%{name}
502 %{_includedir}/cegui-0/%{name}/*.h
503 %{_includedir}/cegui-0/%{name}/CommonDialogs
504 %dir %{_includedir}/cegui-0/%{name}/ImageCodecModules
505 %dir %{_includedir}/cegui-0/%{name}/RendererModules
506 %{_includedir}/cegui-0/%{name}/ScriptModules
507 %{_includedir}/cegui-0/%{name}/WindowRendererSets
508 %{_includedir}/cegui-0/%{name}/XMLParserModules
509 %{_includedir}/cegui-0/%{name}/falagard
510 %{_includedir}/cegui-0/%{name}/widgets
511 %{_pkgconfigdir}/CEGUI-0.pc
512 %{_pkgconfigdir}/CEGUI-0-LUA.pc
513
514 %files ImageCodec-Corona
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoronaImageCodec.so
517
518 %files ImageCodec-Corona-devel
519 %defattr(644,root,root,755)
520 %{_includedir}/cegui-0/%{name}/ImageCodecModules/Corona
521
522 %files ImageCodec-DevIL
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIDevILImageCodec.so
525
526 %files ImageCodec-DevIL-devel
527 %defattr(644,root,root,755)
528 %{_includedir}/cegui-0/%{name}/ImageCodecModules/DevIL
529
530 %files ImageCodec-FreeImage
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIFreeImageImageCodec.so
533
534 %files ImageCodec-FreeImage-devel
535 %defattr(644,root,root,755)
536 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
537
538 %files ImageCodec-SILLY
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
541
542 %files ImageCodec-SILLY-devel
543 %defattr(644,root,root,755)
544 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SILLY
545
546 %files Parser-Expat
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIExpatParser.so
549
550 %files Parser-LibXML
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUILibXMLParser.so
553
554 %files Parser-RapidXML
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIRapidXMLParser.so
557
558 %files Parser-TinyXML
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITinyXMLParser.so
561
562 %files Parser-Xerces
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIXercesParser.so
565
566 %if %{with directfb}
567 %files Renderer-DirectFB
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDirectFBRenderer-0.so.2
571
572 %files Renderer-DirectFB-devel
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so
575 %{_includedir}/cegui-0/%{name}/RendererModules/DirectFB
576 %endif
577
578 %files Renderer-Irrlicht
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer-0.so.2
582
583 %files Renderer-Irrlicht-devel
584 %defattr(644,root,root,755)
585 %{_includedir}/cegui-0/%{name}/RendererModules/Irrlicht
586 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so
587 %{_pkgconfigdir}/CEGUI-0-IRRLICHT.pc
588
589 %if %{with ogre}
590 %files Renderer-Ogre
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOgreRenderer-0.so.2
594
595 %files Renderer-Ogre-devel
596 %defattr(644,root,root,755)
597 %{_includedir}/cegui-0/%{name}/RendererModules/Ogre
598 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so
599 %{_pkgconfigdir}/CEGUI-0-OGRE.pc
600 %endif
601
602 %if %{with opengl}
603 %files Renderer-OpenGL
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so.*.*.*
606 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer-0.so.2
607
608 %files Renderer-OpenGL-devel
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so
611 %{_includedir}/cegui-0/%{name}/RendererModules/OpenGL
612 %{_pkgconfigdir}/CEGUI-0-OPENGL.pc
613 %{_pkgconfigdir}/CEGUI-0-OPENGL3.pc
614 %endif
615
616 %files -n python-CEGUI
617 %defattr(644,root,root,755)
618 %dir %{py_sitedir}/cegui-0.8
619 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUI.so
620
621 %if %{with ogre}
622 %files -n python-CEGUI-Renderer-Ogre
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOgreRenderer.so
625 %endif
626
627 %if %{with opengl}
628 %files -n python-CEGUI-Renderer-OpenGL
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOpenGLRenderer.so
631 %endif
This page took 0.127201 seconds and 3 git commands to generate.