]> git.pld-linux.org Git - packages/CEGUI.git/commitdiff
- workaround for building with boost 1.59
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Nov 2015 15:45:04 +0000 (16:45 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Nov 2015 15:45:04 +0000 (16:45 +0100)
CEGUI.spec
boost-1.59.patch [new file with mode: 0644]

index b53754a00317b74cb332c3cf9349f05d71cd9c2d..64774a3c3ba2e383db80cb7ed4ce73cfe152e93d 100644 (file)
@@ -21,6 +21,7 @@ Patch0:               pthread.patch
 Patch1:                %{name}-glfw3.patch
 Patch2:                %{name}-python.patch
 Patch3:                x32.patch
+Patch4:                boost-1.59.patch
 URL:           http://www.cegui.org.uk/
 BuildRequires: DevIL-devel
 %{?with_directfb:BuildRequires:        DirectFB-devel >= 1.2.0}
@@ -433,6 +434,7 @@ Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 install -d build
diff --git a/boost-1.59.patch b/boost-1.59.patch
new file mode 100644 (file)
index 0000000..2d8e716
--- /dev/null
@@ -0,0 +1,68 @@
+--- cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/ResourceEventArgs.pypp.cpp.orig   2013-05-26 17:58:46.000000000 +0200
++++ cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/ResourceEventArgs.pypp.cpp        2015-11-21 16:33:29.302275302 +0100
+@@ -4,6 +4,14 @@
+ #include "generators/include/python_CEGUI.h"
+ #include "ResourceEventArgs.pypp.hpp"
++namespace boost { namespace python {
++template <class D>
++inline object make_setter(D const& x)
++{
++    return detail::make_setter(x, default_call_policies(), is_member_pointer<D>(), 0);
++}
++}}
++
+ namespace bp = boost::python;
+ void register_ResourceEventArgs_class(){
+--- cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/Scheme.pypp.cpp.orig      2013-05-26 17:58:46.000000000 +0200
++++ cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/Scheme.pypp.cpp   2015-11-21 16:26:43.769253262 +0100
+@@ -4,6 +4,14 @@
+ #include "generators/include/python_CEGUI.h"
+ #include "Scheme.pypp.hpp"
++namespace boost { namespace python {
++template <class D>
++inline object make_setter(D const& x)
++{
++    return detail::make_setter(x, default_call_policies(), is_member_pointer<D>(), 0);
++}
++}}
++
+ namespace bp = boost::python;
+ void register_Scheme_class(){
+--- cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/StdPairCEGUIStringString.pypp.cpp.orig    2013-05-26 17:58:46.000000000 +0200
++++ cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/StdPairCEGUIStringString.pypp.cpp 2015-11-21 16:24:44.334020922 +0100
+@@ -4,6 +4,14 @@
+ #include "generators/include/python_CEGUI.h"
+ #include "StdPairCEGUIStringString.pypp.hpp"
++namespace boost { namespace python {
++template <class D>
++inline object make_setter(D const& x)
++{
++    return detail::make_setter(x, default_call_policies(), is_member_pointer<D>(), 0);
++}
++}}
++
+ namespace bp = boost::python;
+ void register_StdPairCEGUIStringString_class(){
+--- cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/WindowFactoryManager.pypp.cpp.orig        2013-05-26 17:58:46.000000000 +0200
++++ cegui-0.8.4/cegui/src/ScriptModules/Python/bindings/output/CEGUI/WindowFactoryManager.pypp.cpp     2015-11-21 16:35:45.367135886 +0100
+@@ -4,6 +4,14 @@
+ #include "generators/include/python_CEGUI.h"
+ #include "WindowFactoryManager.pypp.hpp"
++namespace boost { namespace python {
++template <class D>
++inline object make_setter(D const& x)
++{
++    return detail::make_setter(x, default_call_policies(), is_member_pointer<D>(), 0);
++}
++}}
++
+ namespace bp = boost::python;
+ void register_WindowFactoryManager_class(){
This page took 0.075648 seconds and 4 git commands to generate.