]> git.pld-linux.org Git - packages/0ad.git/blob - 0ad.spec
- start update to r10803
[packages/0ad.git] / 0ad.spec
1 #
2 # TODO: - use arch dependend compilers
3 #       - check licenses
4 #       - try to make it runnable by non-privileged users (sth wrong with boost?)
5 #       - fix problem with font finding
6 #
7 %define         svn_ver r10803
8 Summary:        Free, Open-Source, cross-platform RTS game of ancient warfare
9 Name:           0ad
10 Version:        %{svn_ver}
11 Release:        0.%{svn_ver}.1
12 License:        GPL v2+
13 Group:          X11/Applications/Games
14 Source0:        http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.tar.xz
15 # Source0-md5:  92ac750c433a8aea4db602019b27a274
16 URL:            http://wildfiregames.com/0ad/
17 BuildRequires:  DevIL-devel
18 BuildRequires:  OpenAL-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  boost-devel
22 BuildRequires:  cmake
23 BuildRequires:  curl-devel
24 BuildRequires:  enet-devel >= 1.2.0
25 BuildRequires:  fam-devel
26 BuildRequires:  libogg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libvorbis-devel
29 BuildRequires:  libxml2-devel
30 BuildRequires:  nasm
31 BuildRequires:  perl-base
32 BuildRequires:  pkgconfig
33 BuildRequires:  python
34 BuildRequires:  python-modules
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  wxGTK2-unicode-gl-devel
37 BuildRequires:  zip
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 0 A.D. (pronounced "zero ey-dee") is a free, open-source,
43 cross-platform real-time strategy (RTS) game of ancient warfare. In
44 short, it is a historically-based war/economy game that allows players
45 to relive or rewrite the history of Western civilizations, focusing on
46 the years between 500 B.C. and 500 A.D. The project is highly
47 ambitious, involving state-of-the-art 3D graphics, detailed artwork,
48 sound, and a flexible and powerful custom-built game engine.
49
50 %prep
51 %setup -q -n %{name}-%{version}-alpha
52
53 # force link with libboost_*.so not libboost_*-mt.so
54 #%%{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
55
56 # use wx-gtk2-unicode-config instead of wx-config
57 #%%{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
58
59 %build
60 export CFLAGS="%{rpmcflags}"
61 export CPPFLAGS="%{rpmcxxflags}"
62 cd build/workspaces
63 ./update-workspaces.sh \
64         --verbose \
65         --bindir %{_bindir} \
66         --datadir %{_datadir}/%{name} \
67         --libdir %{_libdir}/%{name}
68
69 cd gcc
70 %{__make} \
71         CONFIG=Release
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
76
77 # binaries
78 cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
79 cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
80
81 # libraries
82 cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
83 cp -a binaries/system/*release.so.*.* $RPM_BUILD_ROOT%{_libdir}/%{name}
84
85 # menu icon
86 cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
87 cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.txt
95 %attr(755,root,root) %{_bindir}/0ad
96 %attr(755,root,root) %{_bindir}/pyrogenesis
97 %dir %{_libdir}/0ad
98 %{_libdir}/0ad/*.so
99 %{_libdir}/0ad/*.so.*.*
100 %{_desktopdir}/0ad.desktop
101 %{_pixmapsdir}/0ad.png
This page took 0.272362 seconds and 3 git commands to generate.