]> git.pld-linux.org Git - packages/0ad.git/blame - 0ad.spec
- start update to r10803
[packages/0ad.git] / 0ad.spec
CommitLineData
7b21aad0 1#
2# TODO: - use arch dependend compilers
3# - check licenses
d49dee95 4# - try to make it runnable by non-privileged users (sth wrong with boost?)
5# - fix problem with font finding
7b21aad0 6#
6e4e3b12 7%define svn_ver r10803
7b21aad0 8Summary: Free, Open-Source, cross-platform RTS game of ancient warfare
9Name: 0ad
10Version: %{svn_ver}
11Release: 0.%{svn_ver}.1
12License: GPL v2+
13Group: X11/Applications/Games
7245afcd 14Source0: http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.tar.xz
6e4e3b12 15# Source0-md5: 92ac750c433a8aea4db602019b27a274
7b21aad0 16URL: http://wildfiregames.com/0ad/
bfedb3d9 17BuildRequires: DevIL-devel
18BuildRequires: OpenAL-devel
19BuildRequires: OpenGL-devel
20BuildRequires: SDL-devel
7b21aad0 21BuildRequires: boost-devel
bfedb3d9 22BuildRequires: cmake
7d822f0e 23BuildRequires: curl-devel
1cae58d8 24BuildRequires: enet-devel >= 1.2.0
7d822f0e 25BuildRequires: fam-devel
bfedb3d9 26BuildRequires: libogg-devel
27BuildRequires: libpng-devel
28BuildRequires: libvorbis-devel
29BuildRequires: libxml2-devel
7d822f0e 30BuildRequires: nasm
7245afcd 31BuildRequires: perl-base
32BuildRequires: pkgconfig
33BuildRequires: python
34BuildRequires: python-modules
7b21aad0 35BuildRequires: sed >= 4.0
2ef47886 36BuildRequires: wxGTK2-unicode-gl-devel
7245afcd 37BuildRequires: zip
bfedb3d9 38BuildRequires: zlib-devel
7b21aad0 39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
420 A.D. (pronounced "zero ey-dee") is a free, open-source,
43cross-platform real-time strategy (RTS) game of ancient warfare. In
44short, it is a historically-based war/economy game that allows players
45to relive or rewrite the history of Western civilizations, focusing on
46the years between 500 B.C. and 500 A.D. The project is highly
47ambitious, involving state-of-the-art 3D graphics, detailed artwork,
48sound, and a flexible and powerful custom-built game engine.
49
50%prep
7245afcd 51%setup -q -n %{name}-%{version}-alpha
7b21aad0 52
53# force link with libboost_*.so not libboost_*-mt.so
6e4e3b12 54#%%{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
7b21aad0 55
56# use wx-gtk2-unicode-config instead of wx-config
6e4e3b12 57#%%{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
7b21aad0 58
59%build
60export CFLAGS="%{rpmcflags}"
61export CPPFLAGS="%{rpmcxxflags}"
62cd build/workspaces
63./update-workspaces.sh \
64 --verbose \
65 --bindir %{_bindir} \
66 --datadir %{_datadir}/%{name} \
67 --libdir %{_libdir}/%{name}
68
69cd gcc
70%{__make} \
71 CONFIG=Release
72
73%install
74rm -rf $RPM_BUILD_ROOT
75install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
76
77# binaries
78cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
79cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
80
81# libraries
82cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
e36ec85e 83cp -a binaries/system/*release.so.*.* $RPM_BUILD_ROOT%{_libdir}/%{name}
7b21aad0 84
85# menu icon
86cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
87cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
94%doc README.txt
95%attr(755,root,root) %{_bindir}/0ad
96%attr(755,root,root) %{_bindir}/pyrogenesis
97%dir %{_libdir}/0ad
98%{_libdir}/0ad/*.so
e36ec85e 99%{_libdir}/0ad/*.so.*.*
7b21aad0 100%{_desktopdir}/0ad.desktop
101%{_pixmapsdir}/0ad.png
This page took 0.067046 seconds and 4 git commands to generate.