]> git.pld-linux.org Git - packages/0ad.git/blame - 0ad.spec
- more TODO
[packages/0ad.git] / 0ad.spec
CommitLineData
7b21aad0 1#
2# TODO: - use arch dependend compilers
3# - check licenses
d49dee95 4# - try to make it runnable by non-privileged users (sth wrong with boost?)
5# - fix problem with font finding
7b21aad0 6#
7%define svn_ver r8832
8Summary: Free, Open-Source, cross-platform RTS game of ancient warfare
9Name: 0ad
10Version: %{svn_ver}
11Release: 0.%{svn_ver}.1
12License: GPL v2+
13Group: X11/Applications/Games
14Source0: %{name}-%{version}-alpha-unix-build.tar.gz
15# Source0-md5: f38d660d039a37edebb2ea2f0eb6aa6d
16URL: http://wildfiregames.com/0ad/
bfedb3d9 17BuildRequires: DevIL-devel
18BuildRequires: OpenAL-devel
19BuildRequires: OpenGL-devel
20BuildRequires: SDL-devel
7b21aad0 21BuildRequires: boost-devel
bfedb3d9 22BuildRequires: cmake
23BuildRequires: enet < 1.3.0
24BuildRequires: enet >= 1.2.0
25BuildRequires: libogg-devel
26BuildRequires: libpng-devel
27BuildRequires: libvorbis-devel
28BuildRequires: libxml2-devel
7b21aad0 29BuildRequires: sed >= 4.0
30BuildRequires: wxGTK2-unicode-devel
bfedb3d9 31BuildRequires: zlib-devel
7b21aad0 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
350 A.D. (pronounced "zero ey-dee") is a free, open-source,
36cross-platform real-time strategy (RTS) game of ancient warfare. In
37short, it is a historically-based war/economy game that allows players
38to relive or rewrite the history of Western civilizations, focusing on
39the years between 500 B.C. and 500 A.D. The project is highly
40ambitious, involving state-of-the-art 3D graphics, detailed artwork,
41sound, and a flexible and powerful custom-built game engine.
42
43%prep
44%setup -q -n %{name}
45
46# force link with libboost_*.so not libboost_*-mt.so
47%{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
48
49# use wx-gtk2-unicode-config instead of wx-config
50%{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
51
52%build
53export CFLAGS="%{rpmcflags}"
54export CPPFLAGS="%{rpmcxxflags}"
55cd build/workspaces
56./update-workspaces.sh \
57 --verbose \
58 --bindir %{_bindir} \
59 --datadir %{_datadir}/%{name} \
60 --libdir %{_libdir}/%{name}
61
62cd gcc
63%{__make} \
64 CONFIG=Release
65
66%install
67rm -rf $RPM_BUILD_ROOT
68install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
69
70# binaries
71cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
72cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
73
74# libraries
75cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
76
77# menu icon
78cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
79cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
86%doc README.txt
87%attr(755,root,root) %{_bindir}/0ad
88%attr(755,root,root) %{_bindir}/pyrogenesis
89%dir %{_libdir}/0ad
90%{_libdir}/0ad/*.so
91%{_desktopdir}/0ad.desktop
92%{_pixmapsdir}/0ad.png
This page took 0.044657 seconds and 4 git commands to generate.