]> git.pld-linux.org Git - packages/0ad.git/blob - 0ad.spec
- use tarball without all binaries
[packages/0ad.git] / 0ad.spec
1 #
2 # TODO: - use arch dependend compilers
3 #       - check licenses
4 #       - try to make it runnable by non-privileged users (sth wrong with boost?)
5 #       - fix problem with font finding
6 #
7 %define         svn_ver r08832
8 Summary:        Free, Open-Source, cross-platform RTS game of ancient warfare
9 Name:           0ad
10 Version:        %{svn_ver}
11 Release:        0.%{svn_ver}.1
12 License:        GPL v2+
13 Group:          X11/Applications/Games
14 Source0:        http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.tar.xz
15 # Source0-md5:  b9df52751596633d9aab4cc3b253cb82
16 URL:            http://wildfiregames.com/0ad/
17 BuildRequires:  DevIL-devel
18 BuildRequires:  OpenAL-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  boost-devel
22 BuildRequires:  cmake
23 BuildRequires:  enet-devel < 1.3.0
24 BuildRequires:  enet-devel >= 1.2.0
25 BuildRequires:  libogg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libvorbis-devel
28 BuildRequires:  libxml2-devel
29 BuildRequires:  perl-base
30 BuildRequires:  pkgconfig
31 BuildRequires:  python
32 BuildRequires:  python-modules
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  wxGTK2-unicode-devel
35 BuildRequires:  zip
36 BuildRequires:  zlib-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 0 A.D. (pronounced "zero ey-dee") is a free, open-source,
41 cross-platform real-time strategy (RTS) game of ancient warfare. In
42 short, it is a historically-based war/economy game that allows players
43 to relive or rewrite the history of Western civilizations, focusing on
44 the years between 500 B.C. and 500 A.D. The project is highly
45 ambitious, involving state-of-the-art 3D graphics, detailed artwork,
46 sound, and a flexible and powerful custom-built game engine.
47
48 %prep
49 %setup -q -n %{name}-%{version}-alpha
50
51 # force link with libboost_*.so not libboost_*-mt.so
52 %{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
53
54 # use wx-gtk2-unicode-config instead of wx-config
55 %{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
56
57 %build
58 export CFLAGS="%{rpmcflags}"
59 export CPPFLAGS="%{rpmcxxflags}"
60 cd build/workspaces
61 ./update-workspaces.sh \
62         --verbose \
63         --bindir %{_bindir} \
64         --datadir %{_datadir}/%{name} \
65         --libdir %{_libdir}/%{name}
66
67 cd gcc
68 %{__make} \
69         CONFIG=Release
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
74
75 # binaries
76 cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
77 cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
78
79 # libraries
80 cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
81
82 # menu icon
83 cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
84 cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.txt
92 %attr(755,root,root) %{_bindir}/0ad
93 %attr(755,root,root) %{_bindir}/pyrogenesis
94 %dir %{_libdir}/0ad
95 %{_libdir}/0ad/*.so
96 %{_desktopdir}/0ad.desktop
97 %{_pixmapsdir}/0ad.png
This page took 0.08084 seconds and 3 git commands to generate.