]> git.pld-linux.org Git - packages/0ad.git/blame - 0ad.spec
- use tarball without all binaries
[packages/0ad.git] / 0ad.spec
CommitLineData
7b21aad0 1#
2# TODO: - use arch dependend compilers
3# - check licenses
d49dee95 4# - try to make it runnable by non-privileged users (sth wrong with boost?)
5# - fix problem with font finding
7b21aad0 6#
7245afcd 7%define svn_ver r08832
7b21aad0 8Summary: Free, Open-Source, cross-platform RTS game of ancient warfare
9Name: 0ad
10Version: %{svn_ver}
11Release: 0.%{svn_ver}.1
12License: GPL v2+
13Group: X11/Applications/Games
7245afcd 14Source0: http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.tar.xz
15# Source0-md5: b9df52751596633d9aab4cc3b253cb82
7b21aad0 16URL: http://wildfiregames.com/0ad/
bfedb3d9 17BuildRequires: DevIL-devel
18BuildRequires: OpenAL-devel
19BuildRequires: OpenGL-devel
20BuildRequires: SDL-devel
7b21aad0 21BuildRequires: boost-devel
bfedb3d9 22BuildRequires: cmake
1cae58d8 23BuildRequires: enet-devel < 1.3.0
24BuildRequires: enet-devel >= 1.2.0
bfedb3d9 25BuildRequires: libogg-devel
26BuildRequires: libpng-devel
27BuildRequires: libvorbis-devel
28BuildRequires: libxml2-devel
7245afcd 29BuildRequires: perl-base
30BuildRequires: pkgconfig
31BuildRequires: python
32BuildRequires: python-modules
7b21aad0 33BuildRequires: sed >= 4.0
34BuildRequires: wxGTK2-unicode-devel
7245afcd 35BuildRequires: zip
bfedb3d9 36BuildRequires: zlib-devel
7b21aad0 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
400 A.D. (pronounced "zero ey-dee") is a free, open-source,
41cross-platform real-time strategy (RTS) game of ancient warfare. In
42short, it is a historically-based war/economy game that allows players
43to relive or rewrite the history of Western civilizations, focusing on
44the years between 500 B.C. and 500 A.D. The project is highly
45ambitious, involving state-of-the-art 3D graphics, detailed artwork,
46sound, and a flexible and powerful custom-built game engine.
47
48%prep
7245afcd 49%setup -q -n %{name}-%{version}-alpha
7b21aad0 50
51# force link with libboost_*.so not libboost_*-mt.so
52%{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
53
54# use wx-gtk2-unicode-config instead of wx-config
55%{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
56
57%build
58export CFLAGS="%{rpmcflags}"
59export CPPFLAGS="%{rpmcxxflags}"
60cd build/workspaces
61./update-workspaces.sh \
62 --verbose \
63 --bindir %{_bindir} \
64 --datadir %{_datadir}/%{name} \
65 --libdir %{_libdir}/%{name}
66
67cd gcc
68%{__make} \
69 CONFIG=Release
70
71%install
72rm -rf $RPM_BUILD_ROOT
73install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
74
75# binaries
76cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
77cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
78
79# libraries
80cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
81
82# menu icon
83cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
84cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
91%doc README.txt
92%attr(755,root,root) %{_bindir}/0ad
93%attr(755,root,root) %{_bindir}/pyrogenesis
94%dir %{_libdir}/0ad
95%{_libdir}/0ad/*.so
96%{_desktopdir}/0ad.desktop
97%{_pixmapsdir}/0ad.png
This page took 0.463855 seconds and 4 git commands to generate.