]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
- up to 1.13.6; rtmp up to 1.2.0
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
ee4f2132 4#
362f5ab2 5# Conditional build for nginx:
d2732616
ER
6# Features
7%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
d54a9642 8%bcond_without threads # thread pool support
d2732616
ER
9# Modules
10%bcond_without addition # http addition module
11%bcond_without auth_request # auth_request module
12%bcond_without dav # WebDAV
13%bcond_without flv # http FLV module
278483d6 14%bcond_without gd # without http image filter module
82f38dc6 15%bcond_without geoip # without http geoip module and stream geoip module
d2732616 16%bcond_without http2 # HTTP/2 module
056acc18 17%bcond_without mail # don't build imap/mail proxy
18%bcond_without perl # don't build with perl module
d2732616 19%bcond_without poll # poll module
d0c0492d 20%bcond_without realip # real ip (behind proxy)
d2732616
ER
21%bcond_without select # select module
22%bcond_without ssl # ssl support and http ssl module
23%bcond_without stream # TCP/UDP proxy module
24%bcond_without stub_status # http stub status module
25%bcond_without sub # ngx_http_sub_module
278483d6 26%bcond_without xslt # without http xslt module
d2732616 27%bcond_with http_browser # http browser module (header "User-agent" parser)
ba5570e8 28%bcond_with modsecurity # modsecurity module
d2732616 29%bcond_with rtmp # rtmp support
fb649fe5 30
8cf64677
WF
31%ifarch x32
32%undefine with_rtsig
33%endif
34
27ce902f 35%define ssl_version 1.0.2
dd14d511 36%define rtmp_version 1.2.0
f291e0db 37%define modsecurity_version 2.9.2
8e1389c7 38Summary: High perfomance HTTP and reverse proxy server
185313bb 39Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
40# nginx lines:
41# - stable: production quality with stable API
42# - mainline: production quality but API can change
f9e65082 43Name: nginx
dd14d511
AM
44Version: 1.13.6
45Release: 1
51ef519b 46License: BSD-like
cbf76340 47Group: Networking/Daemons/HTTP
06e274b9 48Source0: http://nginx.org/download/%{name}-%{version}.tar.gz
dd14d511 49# Source0-md5: f84d3f782c168bfdfb734700e51a929f
06e274b9 50Source1: http://nginx.net/favicon.ico
87404bf2 51# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
06e274b9 52Source2: proxy.conf
226bcc40 53Source3: %{name}.logrotate
54Source4: %{name}.mime
7f97359c 55Source6: %{name}.monitrc
2cb3d9b2 56Source7: %{name}.init
5d9f0850 57Source14: %{name}.conf
7d80c773 58Source17: %{name}-mime.types.sh
8d0ed4b0 59Source18: %{name}.service
ba5570e8 60Source22: http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
f291e0db 61# Source22-md5: 4d9454efb19269c4288ae408ea438b76
278483d6 62Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
dd14d511 63# Source101-md5: 1a47951b64f3f726a9d4620774643759
5ca9795d 64Patch0: %{name}-no-Werror.patch
7ce2935c 65Patch1: %{name}-modsecurity-xheaders.patch
b7a97f81 66URL: http://nginx.org/
dfef7372 67BuildRequires: mailcap
f1fc9780 68BuildRequires: pcre-devel
d323480a 69BuildRequires: rpmbuild(macros) >= 1.644
f9e65082 70BuildRequires: zlib-devel
278483d6
ER
71%if %{with geoip}
72BuildRequires: GeoIP-devel
73%endif
74%if %{with gd}
75BuildRequires: gd-devel
76%endif
77%if %{with modsecurity}
78BuildRequires: lua-devel
79%endif
80%if %{with perl}
81BuildRequires: perl-CGI
82BuildRequires: perl-devel
83BuildRequires: python
84BuildRequires: rpm-perlprov
85%endif
86%if %{with ssl}
87BuildRequires: openssl-devel >= %{ssl_version}
88Requires: openssl >= %{ssl_version}
89%endif
90%if %{with xslt}
91BuildRequires: libxslt-devel
92%endif
1a973791
JK
93Provides: group(http)
94Provides: group(nginx)
95Provides: user(nginx)
4ac1d45f 96Provides: webserver
9b47506f
AM
97Provides: webserver(access)
98Provides: webserver(alias)
81d5057a
JK
99Provides: webserver(auth)
100Provides: webserver(expires)
101Provides: webserver(headers)
1e42c256 102Provides: webserver(indexfile)
81d5057a
JK
103Provides: webserver(log)
104Provides: webserver(mime)
105Provides: webserver(reqtimeout)
106Provides: webserver(rewrite)
107Provides: webserver(setenv)
1a973791 108Conflicts: logrotate < 3.8.0
85600569 109Requires(post,preun): /sbin/chkconfig
1a973791 110Requires(post,preun,postun): systemd-units >= 38
4ac1d45f
ER
111Requires(postun): /usr/sbin/groupdel
112Requires(postun): /usr/sbin/userdel
113Requires(pre): /bin/id
114Requires(pre): /usr/bin/getgid
115Requires(pre): /usr/sbin/groupadd
116Requires(pre): /usr/sbin/useradd
117Requires: rc-scripts >= 0.2.0
118Requires: systemd-units >= 38
119Suggests: vim-syntax-nginx
6d00ffc3 120Conflicts: rpm < 4.4.2-0.2
4ac1d45f 121BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1a973791 122
4ac1d45f
ER
123%define _sysconfdir /etc/%{name}
124%define _nginxdir /home/services/%{name}
1a973791 125
6d00ffc3
ER
126# minimizing restarts logics. we restart webserver:
127#
128# 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
129# 2. first install of module (post: $1 = 1)
130# 2. uninstall of module (postun: $1 == 0)
131#
132# the strict internal deps between modules and
133# main package are very important for all this to work.
85600569 134
6d00ffc3
ER
135# restart webserver at the end of transaction
136
137%define restart_webserver \
138 %systemd_post %{name}.service \
139 %service %{name} force-reload \
140 %{nil}
141
142# macro called at module post scriptlet
143%define module_post \
144if [ "$1" = "1" ]; then \
145 %restart_webserver \
146fi
147
148# macro called at module postun scriptlet
149%define module_postun \
150if [ "$1" = "0" ]; then \
151 %restart_webserver \
152fi
153
154# it's sooo annoying to write them
155%define module_scripts() \
156%post %1 \
157%module_post \
158\
159%postun %1 \
160%module_postun
2ee780b1 161
4ac1d45f 162%description
1a973791
JK
163nginx ("engine x") is a high-performance HTTP server and reverse
164proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
165Sysoev for Rambler.ru, Russia's second-most visited website, where it
166has been running in production for over two and a half years. Igor has
167released the source code under a BSD-like license. Although still in
168beta, nginx is known for its stability, rich feature set, simple
169configuration, and low resource consumption.
170
4ac1d45f 171%description -l pl.UTF-8
1a973791 172nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
173a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
174potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 175odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
176opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
177fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
178prostej konfiguracji oraz małej "zasobożerności".
179
278483d6
ER
180%package mod_http_geoip
181Summary: Nginx HTTP geoip module
182Group: Daemons
183Requires: %{name} = %{version}-%{release}
184Requires: GeoIP
2ee780b1 185
278483d6
ER
186%description mod_http_geoip
187Nginx HTTP geoip module.
2ee780b1 188
82f38dc6
ER
189%package mod_stream_geoip
190Summary: Nginx stream geoip module
191Group: Daemons
192Requires: %{name} = %{version}-%{release}
57aa9c0a 193Requires: %{name}-mod_stream = %{version}-%{release}
82f38dc6 194Requires: GeoIP
1a973791 195
82f38dc6
ER
196%description mod_stream_geoip
197Nginx stream geoip module.
2ee780b1 198
278483d6
ER
199%package mod_http_image_filter
200Summary: Nginx HTTP image filter module
201Group: Daemons
202Requires: %{name} = %{version}-%{release}
1a973791 203
278483d6
ER
204%description mod_http_image_filter
205Nginx HTTP image filter module.
2ee780b1 206
f5d76ba0
ER
207%package mod_http_perl
208Summary: Nginx HTTP Perl module
cbf76340 209Group: Networking/Daemons/HTTP
4ac1d45f 210Requires: %{name} = %{version}-%{release}
2ee780b1 211
f5d76ba0
ER
212%description mod_http_perl
213Nginx HTTP Perl module.
1a973791 214
278483d6
ER
215%package mod_http_xslt_filter
216Summary: Nginx XSLT module
217Group: Daemons
218Requires: %{name} = %{version}-%{release}
2ee780b1 219
278483d6
ER
220%description mod_http_xslt_filter
221Nginx XSLT module.
2ee780b1 222
f5d76ba0
ER
223%package mod_mail
224Summary: Nginx mail module
cbf76340 225Group: Networking/Daemons/HTTP
4ac1d45f 226Requires: %{name} = %{version}-%{release}
28a25161 227
f5d76ba0
ER
228%description mod_mail
229Nginx mail module.
1a973791 230
278483d6
ER
231%package mod_stream
232Summary: Nginx stream modules
233Group: Daemons
234Requires: %{name} = %{version}-%{release}
fccff804 235
278483d6
ER
236%description mod_stream
237Nginx stream modules.
85600569 238
dd7459ac 239%package -n monit-rc-nginx
57f21172 240Summary: nginx support for monit
241Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 242Group: Applications/System
4ac1d45f 243Requires: %{name} = %{version}-%{release}
1cf92547 244Requires: monit
dd7459ac 245
246%description -n monit-rc-nginx
57f21172 247monitrc file for monitoring nginx webserver.
dd7459ac 248
249%description -n monit-rc-nginx -l pl.UTF-8
57f21172 250Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 251
f9e65082 252%prep
ba5570e8 253%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
717159c4 254%patch0 -p0
7ce2935c 255%{?with_modsecurity:%patch1 -p0}
f9e65082 256
fb649fe5
ER
257%if %{with rtmp}
258mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
259%endif
260
a8eaad11 261# build mime.types.conf
7d80c773 262#sh %{SOURCE17} /etc/mime.types
a8eaad11 263
f9e65082
ER
264%build
265# NB: not autoconf generated configure
056acc18 266cp -f configure auto/
5d0d957d 267
056acc18 268./configure \
269 --prefix=%{_prefix} \
483adace 270 --modules-path=%{_libdir}/%{name}/modules \
efc6207e
ER
271 --sbin-path=%{_sbindir}/%{name} \
272 --conf-path=%{_sysconfdir}/%{name}.conf \
273 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
274 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
275 --pid-path=%{_localstatedir}/run/%{name}.pid \
276 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
277 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
278 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
279 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
0bd5043b 280 --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
bfad744d 281 --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
2fb62cf2
ER
282 --user=nginx \
283 --group=nginx \
021e3ce8
ER
284 %{?with_select:--with-select_module} \
285 %{?with_poll:--with-poll_module} \
286 %{?with_rtsig:--with-rtsig_module} \
278483d6 287 %{?with_perl:--with-http_perl_module=dynamic} \
278483d6
ER
288 %{?with_gd:--with-http_image_filter_module=dynamic} \
289 %{?with_xslt:--with-http_xslt_module=dynamic} \
82f38dc6
ER
290 %{?with_geoip:--with-http_geoip_module=dynamic} \
291 %{?with_geoip:--with-stream_geoip_module=dynamic} \
008e09c3
ER
292%if %{with mail}
293 --with-mail=dynamic \
294 --with-mail_ssl_module \
278483d6
ER
295%endif
296%if %{with stream}
297 --with-stream=dynamic \
298 --with-stream_ssl_module \
008e09c3 299%endif
2fb62cf2
ER
300 --with-cc="%{__cc}" \
301 --with-cc-opt="%{rpmcflags}" \
302 --with-ld-opt="%{rpmldflags}" \
0aa7dc69 303 %{?with_debug:--with-debug} \
056acc18 304 %{?with_addition:--with-http_addition_module} \
305 %{?with_dav:--with-http_dav_module} \
306 %{?with_flv:--with-http_flv_module} \
d6fc4b09 307 %{?with_sub:--with-http_sub_module} \
056acc18 308 %{?with_realip:--with-http_realip_module} \
d2732616 309 %{?with_stub_status:--with-http_stub_status_module} \
056acc18 310 %{?with_ssl:--with-http_ssl_module} \
311 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 312 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 313 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 314 %{?with_threads:--with-threads} \
6f05a009 315 %{?with_http2:--with-http_v2_module} \
ba5570e8 316 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
ca3f3f03 317 --with-http_secure_link_module \
2fb62cf2
ER
318 %{nil}
319
53215d5e 320%{__make}
f9e65082 321
53215d5e
ER
322%if %{with modsecurity}
323cd modsecurity-%{modsecurity_version}
324./autogen.sh
325%configure \
326 --enable-standalone-module \
327 --disable-mlogc \
328 --enable-alp2 \
329 --with-lua=/usr
330%{__make}
331cd ..
332%endif
056acc18 333
f9e65082
ER
334%install
335rm -rf $RPM_BUILD_ROOT
362f5ab2 336install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
337 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 338 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
c63e9e18
ER
339 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
340 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
97ac281a 341 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
d323480a 342 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 343 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 344
483adace
ER
345%{__make} install \
346 INSTALLDIRS=vendor \
347 DESTDIR=$RPM_BUILD_ROOT
348
349%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
350
7f97359c
ER
351cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
352cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
353cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
c63e9e18
ER
354install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
355
483adace
ER
356cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
357cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
3c75ce8a 358cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
483adace 359rm -r $RPM_BUILD_ROOT%{_prefix}/html
5ca9795d
ER
360cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
361cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
362cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
c9aa991c 363
a88a446d
ER
364load_module() {
365 local module=ngx_${1}_module.so conffile=mod_$1.conf
9453c586 366 printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
97ac281a 367 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
c9aa991c
ER
368}
369
85600569 370%if %{with perl}
483adace
ER
371%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
372%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
a88a446d 373load_module http_perl
85600569 374%endif
f9e65082 375
a88a446d
ER
376%if %{with geoip}
377load_module http_geoip
763de572 378load_module stream_geoip
a88a446d
ER
379%endif
380%if %{with gd}
381load_module http_image_filter
382%endif
383%if %{with xslt}
384load_module http_xslt_filter
385%endif
c9aa991c 386%if %{with mail}
a88a446d
ER
387load_module mail
388%endif
389%if %{with stream}
390load_module stream
c9aa991c 391%endif
32c47bd6 392
f9e65082
ER
393%clean
394rm -rf $RPM_BUILD_ROOT
395
c63e9e18 396%pre
a37373c3 397%groupadd -r -g 213 %{name}
362f5ab2 398%groupadd -g 51 http
a37373c3 399%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 400%addusertogroup %{name} http
f1fc9780 401
c63e9e18 402%post
738166d2 403for a in access.log error.log; do
c63e9e18 404 if [ ! -f /var/log/%{name}/$a ]; then
98376457 405 umask 022
c63e9e18
ER
406 touch /var/log/%{name}/$a
407 chown nginx:nginx /var/log/%{name}/$a
408 chmod 644 /var/log/%{name}/$a
738166d2 409 fi
410done
c63e9e18 411/sbin/chkconfig --add %{name}
738166d2 412
6d00ffc3
ER
413%posttrans
414%restart_webserver
738166d2 415
c63e9e18 416%preun
7d80c773 417if [ "$1" = "0" ];then
c63e9e18
ER
418 %service %{name} stop
419 /sbin/chkconfig --del %{name}
f9e65082 420fi
c63e9e18 421%systemd_preun %{name}.service
f9e65082 422
c63e9e18 423%postun
f1fc9780 424if [ "$1" = "0" ]; then
7d9b86c7
ER
425 %userremove %{name}
426 %groupremove %{name}
f1fc9780 427fi
d323480a
JK
428%systemd_reload
429
6d00ffc3
ER
430%module_scripts mod_http_geoip
431%module_scripts mod_http_image_filter
432%module_scripts mod_http_perl
433%module_scripts mod_http_xslt_filter
434%module_scripts mod_mail
435%module_scripts mod_stream
436%module_scripts mod_stream_geoip
d323480a 437
c63e9e18 438%files
f9e65082 439%defattr(644,root,root,755)
6f8318ed 440%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 441%doc %lang(ru) CHANGES.ru
28a25161 442%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
7f6266e4
ER
443%attr(754,root,root) /etc/rc.d/init.d/%{name}
444%dir %attr(750,root,nginx) %{_sysconfdir}
943e8c63 445%dir %{_sysconfdir}/conf.d
97ac281a 446%dir %{_sysconfdir}/modules.d
7f6266e4
ER
447%dir %{_sysconfdir}/vhosts.d
448%dir %{_sysconfdir}/webapps.d
f1fc9780 449%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 450%attr(640,root,root) %{_sysconfdir}/koi-utf
451%attr(640,root,root) %{_sysconfdir}/koi-win
452%attr(640,root,root) %{_sysconfdir}/win-utf
ba3249a3 453%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
7f6266e4
ER
454%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
455%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
456%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
457%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
458%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
483adace 459%attr(755,root,root) %{_sbindir}/%{name}
278483d6
ER
460%dir %{_libdir}/%{name}
461%dir %{_libdir}/%{name}/modules
c63e9e18 462%{systemdunitdir}/%{name}.service
b0fa7cc6 463
debe6eba
JR
464%attr(750,nginx,logs) %dir /var/log/archive/%{name}
465%attr(750,nginx,logs) /var/log/%{name}
7f6266e4
ER
466%attr(770,root,nginx) /var/cache/%{name}
467
468%dir %{_nginxdir}
469%dir %{_nginxdir}/cgi-bin
470%dir %{_nginxdir}/html
471%dir %{_nginxdir}/errors
475fecd1 472%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 473%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 474
278483d6
ER
475%if %{with geoip}
476%files mod_http_geoip
b0fa7cc6 477%defattr(644,root,root,755)
97ac281a 478%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
278483d6 479%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
b0fa7cc6 480
82f38dc6 481%files mod_stream_geoip
85600569 482%defattr(644,root,root,755)
97ac281a 483%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
82f38dc6 484%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
85600569 485%endif
486
278483d6
ER
487%if %{with gd}
488%files mod_http_image_filter
85600569 489%defattr(644,root,root,755)
97ac281a 490%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
278483d6 491%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
85600569 492%endif
493
494%if %{with perl}
f5d76ba0 495%files mod_http_perl
85600569 496%defattr(644,root,root,755)
97ac281a 497%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
008e09c3 498%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
85600569 499%dir %{perl_vendorarch}/auto/%{name}
500%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 501%{perl_vendorarch}/%{name}.pm
483adace 502%{_mandir}/man3/nginx.3pm*
dd7459ac 503%endif
504
278483d6
ER
505%if %{with xslt}
506%files mod_http_xslt_filter
dd7459ac 507%defattr(644,root,root,755)
97ac281a 508%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
278483d6 509%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
dd7459ac 510%endif
278483d6 511
dd7459ac 512%if %{with mail}
278483d6
ER
513%files mod_mail
514%defattr(644,root,root,755)
97ac281a 515%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
278483d6 516%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
dd7459ac 517%endif
278483d6
ER
518
519%if %{with stream}
520%files mod_stream
521%defattr(644,root,root,755)
97ac281a 522%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
278483d6
ER
523%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
524%endif
525
dd7459ac 526%files -n monit-rc-nginx
527%defattr(644,root,root,755)
c63e9e18 528%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.140899 seconds and 4 git commands to generate.