]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
- sufficient optflags come from rpm, no need for -with-cpu-opt
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
98376457 2# - fix sysconfdir duplicates
ee4f2132 3# - /etc/sysconfig/nginx file
1c438d78 4# - missing perl build/install requires
6de999a5 5# - nginx should have own group (and work with it) or use http group ?
ee4f2132 6#
362f5ab2 7# Conditional build for nginx:
056acc18 8%bcond_without light # don't build light version
9%bcond_without mail # don't build imap/mail proxy
10%bcond_without perl # don't build with perl module
d0c0492d 11%bcond_without addition # adds module
12%bcond_without dav # WebDAV
13%bcond_without flv # FLV stream
d6fc4b09 14%bcond_without sub # ngx_http_sub_module
d0c0492d 15%bcond_without poll # poll
16%bcond_without realip # real ip (behind proxy)
17%bcond_without rtsig # rtsig
18%bcond_without select # select
19%bcond_without status # stats module
20%bcond_without ssl # ssl support
056acc18 21%bcond_with http_browser # header "User-agent" parser
362f5ab2 22#
8e1389c7 23Summary: High perfomance HTTP and reverse proxy server
185313bb 24Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
f9e65082 25Name: nginx
1a62642d 26Version: 0.5.33
7d80c773 27Release: 0.8
51ef519b 28License: BSD-like
7d9b86c7 29Group: Networking/Daemons
f1fc9780 30Source0: http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
1a62642d 31# Source0-md5: a78be74b4fd8e009545ef02488fcac86
226bcc40 32Source1: http://www.nginx.eu/favicon.ico
33# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
34Source2: http://www.nginx.eu/download/proxy.conf
35# Source2-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
36Source3: %{name}.logrotate
37Source4: %{name}.mime
38Source5: %{name}-light.conf
39Source6: %{name}-light.monitrc
0da077af 40Source7: %{name}-light.init
41Source8: %{name}-mail.conf
42Source9: %{name}-mail.monitrc
43Source10: %{name}-mail.init
44Source11: %{name}-perl.conf
45Source12: %{name}-perl.monitrc
46Source13: %{name}-perl.init
47Source14: %{name}-standard.conf
48Source15: %{name}-standard.monitrc
7d80c773 49Source16: %{name}-standard.init
50Source17: %{name}-mime.types.sh
f1fc9780 51Patch0: %{name}-config.patch
51ef519b 52URL: http://nginx.net/
dfef7372 53BuildRequires: mailcap
f9e65082 54BuildRequires: openssl-devel
f1fc9780 55BuildRequires: pcre-devel
1c438d78 56%{?with_perl:BuildRequires: perl-CGI}
d0c0492d 57%{?with_perl:BuildRequires: perl-devel}
1c438d78 58%{?with_perl:BuildRequires: rpm-perlprov}
7d9b86c7 59BuildRequires: rpmbuild(macros) >= 1.268
f9e65082 60BuildRequires: zlib-devel
7d9b86c7
ER
61Requires(post,preun): /sbin/chkconfig
62Requires(postun): /usr/sbin/groupdel
63Requires(postun): /usr/sbin/userdel
64Requires(pre): /bin/id
65Requires(pre): /usr/bin/getgid
66Requires(pre): /usr/sbin/groupadd
67Requires(pre): /usr/sbin/useradd
119e2f19 68Requires: nginx-daemon
d0c0492d 69Requires: openssl
70Requires: pcre
aba2d783 71Requires: rc-scripts >= 0.2.0
d0c0492d 72Requires: zlib
1cf92547 73Suggests: nginx-standard
ee547c00 74Provides: group(http)
75Provides: group(nginx)
76Provides: user(nginx)
7ffe7917 77Provides: webserver
226bcc40 78Conflicts: logrotate < 3.7-4
f9e65082
ER
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
362f5ab2 81%define _sysconfdir /etc/%{name}
82%define _nginxdir /home/services/%{name}
f9e65082
ER
83
84%description
894ff1f7
ER
85Nginx ("engine x") is a high-performance HTTP server and reverse
86proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
87Sysoev for Rambler.ru, Russia's second-most visited website, where it
88has been running in production for over two and a half years. Igor has
89released the source code under a BSD-like license. Although still in
90beta, Nginx is known for its stability, rich feature set, simple
91configuration, and low resource consumption.
8e1389c7 92
b0fa7cc6 93Common files for Nginx daemon.
85600569 94
390f5b88 95%description -l pl.UTF-8
056acc18 96Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
98376457 97a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoeva
056acc18 98na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
99odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
100opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
98376457 101w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1dc54c84 102prostej konfiguracji oraz małej "zasobożerności".
2ee780b1 103
1dc54c84 104Niezbędne pliki dla Nginx.
85600569 105
2ee780b1 106%package light
107Summary: High perfomance HTTP and reverse proxy server
7ad53968 108Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
85600569 109Group: Networking/Daemons
85600569 110Requires(post,preun): /sbin/chkconfig
111Requires(postun): /usr/sbin/groupdel
112Requires(postun): /usr/sbin/userdel
b0fa7cc6 113Requires: %{name} = %{version}-%{release}
85600569 114Requires: openssl
115Requires: pcre
116Requires: zlib
2ee780b1 117Provides: group(http)
118Provides: group(nginx)
119e2f19 119Provides: nginx-daemon
2ee780b1 120Provides: user(nginx)
121Provides: webserver
122
123%description light
7ad53968 124The smallest, but also the fastest Nginx edition. No additional
125modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
2ee780b1 126
127%description light -l pl.UTF-8
1cf92547 128Najmniejsza i najszybsza wersja Nginx. Bez wsparcia dla Perla, DAV,
129FLV oraz IMAP, POP3, SMTP proxy.
2ee780b1 130
131%package perl
132Summary: High perfomance HTTP and reverse proxy server
7ad53968 133Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
85600569 134Group: Networking/Daemons
85600569 135Requires(post,preun): /sbin/chkconfig
136Requires(postun): /usr/sbin/groupdel
137Requires(postun): /usr/sbin/userdel
b0fa7cc6 138Requires: %{name} = %{version}-%{release}
85600569 139Requires: openssl
2ee780b1 140Provides: group(http)
141Provides: group(nginx)
1cf92547 142Provides: nginx-daemon
2ee780b1 143Provides: user(nginx)
144Provides: webserver
145
146%description perl
7ad53968 147Nginx with Perl support. Mail modules not included.
2ee780b1 148
149%description perl -l pl.UTF-8
7ad53968 150Nignx z obsługą Perla. Bez wsparcia dla modułów poczty.
2ee780b1 151
152%package mail
153Summary: High perfomance HTTP and reverse proxy server
7ad53968 154Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
85600569 155Group: Networking/Daemons
85600569 156Requires(post,preun): /sbin/chkconfig
157Requires(postun): /usr/sbin/groupdel
158Requires(postun): /usr/sbin/userdel
b0fa7cc6 159Requires: %{name} = %{version}-%{release}
85600569 160Requires: openssl
161Requires: pcre
162Requires: zlib
2ee780b1 163Provides: group(http)
164Provides: group(nginx)
1cf92547 165Provides: nginx-daemon
2ee780b1 166Provides: user(nginx)
167Provides: webserver
168
169%description mail
170Nginx with mail support. Only mail modules included.
171
172%description mail -l pl.UTF-8
7ad53968 173Nginx ze wsparciem tylko dla modułów poczty.
2ee780b1 174
b0fa7cc6 175%package standard
2ee780b1 176Summary: Configuration files and documentation for Nginx
177Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla Nginx
178Group: Networking/Daemons
d6fc4b09 179Requires(post,preun): /sbin/chkconfig
180Requires(postun): /usr/sbin/groupdel
181Requires(postun): /usr/sbin/userdel
b0fa7cc6 182Requires: %{name} = %{version}-%{release}
6de999a5 183Requires: openssl
184Provides: group(http)
185Provides: group(nginx)
1cf92547 186Provides: nginx-daemon
d6fc4b09 187Conflicts: logrotate < 3.7-4
28a25161 188
b0fa7cc6 189%description standard
85600569 190Nginx ("engine x") is a high-performance HTTP server and reverse
191proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
192Sysoev for Rambler.ru, Russia's second-most visited website, where it
193has been running in production for over two and a half years. Igor has
194released the source code under a BSD-like license. Although still in
195beta, Nginx is known for its stability, rich feature set, simple
196configuration, and low resource consumption.
197
1dc54c84 198This is standard Nginx version, without Perl support and IMAP, POP3,
199SMTP proxy.
fccff804 200
b0fa7cc6 201%description standard -l pl.UTF-8
85600569 202Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
98376457 203a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoeva
7ad53968 204na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
205odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
206opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
98376457 207w fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1dc54c84 208prostej konfiguracji oraz małej "zasobożerności".
85600569 209
1dc54c84 210To jest standardowa wersja Nginx, bez obsługi Perla oraz proxy dla
211IMAP, POP3, SMTP.
85600569 212
dd7459ac 213%package -n monit-rc-nginx
60b8f836 214Summary: Nginx support for monit
215Summary(pl.UTF-8): Wsparcie Nginx dla monit
60b8f836 216Group: Applications/System
217URL: http://nginx.eu/
60b8f836 218Requires: %{name} = %{version}-%{release}
1cf92547 219Requires: monit
dd7459ac 220
221%description -n monit-rc-nginx
1dc54c84 222monitrc file for monitoring Nginx webserver server.
dd7459ac 223
224%description -n monit-rc-nginx -l pl.UTF-8
1dc54c84 225Plik monitrc do monitorowania serwera WWW Nginx.
dd7459ac 226
f9e65082
ER
227%prep
228%setup -q
f1fc9780 229%patch0 -p0
f9e65082 230
a8eaad11 231# build mime.types.conf
7d80c773 232#sh %{SOURCE17} /etc/mime.types
a8eaad11 233
f9e65082
ER
234%build
235# NB: not autoconf generated configure
056acc18 236cp -f configure auto/
237#
238%if %{with perl}
239./configure \
240 --prefix=%{_prefix} \
4e61eac8 241 --sbin-path=%{_sbindir}/%{name}-perl \
242 --conf-path=%{_sysconfdir}/%{name}-perl.conf \
243 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_error.log \
244 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-perl_access.log \
245 --pid-path=%{_localstatedir}/run/%{name}-perl.pid \
246 --lock-path=%{_localstatedir}/lock/subsys/%{name}-perl \
056acc18 247 --user=nginx \
248 --group=nginx \
249 --with-http_perl_module \
2ee780b1 250 --without-mail_pop3_module \
251 --without-mail_imap_module \
252 --without-mail_smtp_module \
056acc18 253 %{?with_addition:--with-http_addition_module} \
254 %{?with_dav:--with-http_dav_module} \
255 %{?with_flv:--with-http_flv_module} \
d6fc4b09 256 %{?with_sub:--with-http_sub_module} \
056acc18 257 %{?with_poll:--with-poll_module} \
258 %{?with_realip:--with-http_realip_module} \
259 %{?with_rtsig:--with-rtsig_module} \
260 %{?with_select:--with-select_module} \
261 %{?with_status:--with-http_stub_status_module} \
262 %{?with_ssl:--with-http_ssl_module} \
263 %{!?with_http_browser:--without-http_browser_module} \
4e61eac8 264 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-perl/client_body_temp \
265 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-perl/proxy_temp \
266 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-perl/fastcgi_temp \
056acc18 267 --with-cc="%{__cc}" \
268 --with-cc-opt="%{rpmcflags}" \
269 --with-ld-opt="%{rpmldflags}"
270%{__make}
4e61eac8 271mv -f objs/nginx contrib/nginx-perl
d6fc4b09 272mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.bs contrib/nginx.bs
273mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so contrib/nginx.so
274mv -f objs/src/http/modules/perl/nginx.pm contrib/nginx.pm
056acc18 275%endif
276
277%if %{with mail}
056acc18 278./configure \
279 --prefix=%{_prefix} \
4e61eac8 280 --sbin-path=%{_sbindir}/%{name}-mail \
281 --conf-path=%{_sysconfdir}/%{name}-mail.conf \
282 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_error.log \
283 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-mail_access.log \
284 --pid-path=%{_localstatedir}/run/%{name}-mail.pid \
285 --lock-path=%{_localstatedir}/lock/subsys/%{name}-mail \
056acc18 286 --user=nginx \
287 --group=nginx \
288 --with-imap \
289 --with-mail \
290 --with-mail_ssl_module \
d6fc4b09 291 --without-http \
056acc18 292 %{?with_poll:--with-poll_module} \
056acc18 293 %{?with_rtsig:--with-rtsig_module} \
294 %{?with_select:--with-select_module} \
4e61eac8 295 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-mail/client_body_temp \
296 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-mail/proxy_temp \
297 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-mail/fastcgi_temp \
056acc18 298 --with-cc="%{__cc}" \
299 --with-cc-opt="%{rpmcflags}" \
300 --with-ld-opt="%{rpmldflags}" \
301 %{?debug:--with-debug}
302%{__make}
4e61eac8 303mv -f objs/nginx contrib/nginx-mail
056acc18 304%endif
305
306%if %{with light}
056acc18 307./configure \
308 --prefix=%{_prefix} \
4e61eac8 309 --sbin-path=%{_sbindir}/%{name}-light \
310 --conf-path=%{_sysconfdir}/%{name}-light.conf \
311 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-light_error.log \
312 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-light_access.log \
313 --pid-path=%{_localstatedir}/run/%{name}-light.pid \
314 --lock-path=%{_localstatedir}/lock/subsys/%{name}-light \
056acc18 315 --user=nginx \
316 --group=nginx \
317 %{?with_poll:--with-poll_module} \
318 %{?with_realip:--with-http_realip_module} \
319 %{?with_rtsig:--with-rtsig_module} \
320 %{?with_select:--with-select_module} \
321 %{?with_status:--with-http_stub_status_module} \
322 %{?with_ssl:--with-http_ssl_module} \
323 --without-http_browser_module \
1a62642d 324 --without-mail_pop3_module \
325 --without-mail_imap_module \
326 --without-mail_smtp_module \
4e61eac8 327 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-light/client_body_temp \
328 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-light/proxy_temp \
329 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-light/fastcgi_temp \
056acc18 330 --with-cc="%{__cc}" \
331 --with-cc-opt="%{rpmcflags}" \
332 --with-ld-opt="%{rpmldflags}" \
333 %{?debug:--with-debug}
334%{__make}
4e61eac8 335mv -f objs/nginx contrib/nginx-light
056acc18 336%endif
337
f9e65082
ER
338./configure \
339 --prefix=%{_prefix} \
226bcc40 340 --sbin-path=%{_sbindir}/%{name}-standard \
f1686a52 341 --conf-path=%{_sysconfdir}/%{name}-standard.conf \
226bcc40 342 --error-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_error.log \
343 --http-log-path=%{_localstatedir}/log/%{name}/%{name}-standard_access.log \
344 --pid-path=%{_localstatedir}/run/%{name}-standard.pid \
345 --lock-path=%{_localstatedir}/lock/subsys/%{name}-standard \
dfef7372
ER
346 --user=nginx \
347 --group=nginx \
d0c0492d 348 %{?with_addition:--with-http_addition_module} \
349 %{?with_dav:--with-http_dav_module} \
350 %{?with_flv:--with-http_flv_module} \
d6fc4b09 351 %{?with_sub:--with-http_sub_module} \
d0c0492d 352 %{?with_poll:--with-poll_module} \
353 %{?with_realip:--with-http_realip_module} \
362f5ab2 354 %{?with_rtsig:--with-rtsig_module} \
355 %{?with_select:--with-select_module} \
d0c0492d 356 %{?with_status:--with-http_stub_status_module} \
362f5ab2 357 %{?with_ssl:--with-http_ssl_module} \
ee4f2132 358 %{!?with_http_browser:--without-http_browser_module} \
226bcc40 359 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}-standard/client_body_temp \
360 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}-standard/proxy_temp \
361 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}-standard/fastcgi_temp \
f9e65082
ER
362 --with-cc="%{__cc}" \
363 --with-cc-opt="%{rpmcflags}" \
364 --with-ld-opt="%{rpmldflags}" \
365 %{?debug:--with-debug}
f9e65082
ER
366%{__make}
367
056acc18 368
f9e65082
ER
369%install
370rm -rf $RPM_BUILD_ROOT
362f5ab2 371install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
372 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 373 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
226bcc40 374 $RPM_BUILD_ROOT%{_localstatedir}/cache/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
375 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/{%{name}-standard,%{name}-perl,%{name}-mail,%{name}-light} \
28a25161 376 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
377 $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
f9e65082 378
7d80c773 379install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
380install conf/fastcgi_params $RPM_BUILD_ROOT%{_sysconfdir}/fastcgi.params
cd728db7 381install html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
382install html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
226bcc40 383install %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
384install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
385install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
386install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
0da077af 387install %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-standard.conf
388install %{SOURCE15} $RPM_BUILD_ROOT/etc/monit/%{name}-standard.monitrc
389install %{SOURCE16} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-standard
de0bfb9b 390install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}-standard
85600569 391
392%if %{with light}
226bcc40 393install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-light.conf
394install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit/%{name}-light.monitrc
0da077af 395install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-light
4e61eac8 396install contrib/nginx-light $RPM_BUILD_ROOT%{_sbindir}/%{name}-light
85600569 397%endif
398
399%if %{with mail}
0da077af 400install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-mail.conf
401install %{SOURCE9} $RPM_BUILD_ROOT/etc/monit/%{name}-mail.monitrc
402install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-mail
4e61eac8 403install contrib/nginx-mail $RPM_BUILD_ROOT%{_sbindir}/%{name}-mail
85600569 404%endif
405
406%if %{with perl}
407install -d $RPM_BUILD_ROOT{%{perl_vendorarch},%{perl_vendorarch}/auto/%{name}}
0da077af 408install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-perl.conf
409install %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}-perl.monitrc
410install %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-perl
d6fc4b09 411install contrib/nginx.pm $RPM_BUILD_ROOT%{perl_vendorarch}/%{name}.pm
412install contrib/nginx.so $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.so
413install contrib/nginx.bs $RPM_BUILD_ROOT%{perl_vendorarch}/auto/%{name}/%{name}.bs
4e61eac8 414install contrib/nginx-perl $RPM_BUILD_ROOT%{_sbindir}/%{name}-perl
85600569 415%endif
f9e65082
ER
416
417rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
418rm -rf $RPM_BUILD_ROOT%{_prefix}/html
419
420%clean
421rm -rf $RPM_BUILD_ROOT
422
b0fa7cc6 423%pre
a37373c3 424%groupadd -r -g 213 %{name}
362f5ab2 425%groupadd -g 51 http
a37373c3 426%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 427%addusertogroup %{name} http
f1fc9780 428
738166d2 429%post standard
430for a in access.log error.log; do
431 if [ ! -f /var/log/%{name}/nginx-standard_$a ]; then
98376457 432 umask 022
738166d2 433 touch /var/log/%{name}/nginx-standard_$a
1cf92547 434 chown nginx:nginx /var/log/%{name}/nginx-standard_$a
738166d2 435 chmod 644 /var/log/%{name}/nginx-standard_$a
436 fi
437done
3d760264
ER
438/sbin/chkconfig --add %{name}-standard
439%service %{name}-standard restart
440echo 'NOTE: daemon is now using "/etc/nginx/nginx-standard.conf" as config.'
738166d2 441
442%post light
443for a in access.log error.log; do
444 if [ ! -f /var/log/%{name}/nginx-light_$a ]; then
98376457 445 umask 022
738166d2 446 touch /var/log/%{name}/nginx-light_$a
447 chown nginx:nginx /var/log/%{name}/nginx-light_$a
448 chmod 644 /var/log/%{name}/nginx-light_$a
449 fi
450done
3d760264
ER
451/sbin/chkconfig --add %{name}-light
452%service %{name}-light restart
453echo 'NOTE: daemon is now using "/etc/nginx/nginx-light.conf" file'
738166d2 454
455%post perl
456for a in access.log error.log; do
457 if [ ! -f /var/log/%{name}/nginx-perl_$a ]; then
98376457 458 umask 022
738166d2 459 touch /var/log/%{name}/nginx-perl_$a
460 chown nginx:nginx /var/log/%{name}/nginx-perl_$a
461 chmod 644 /var/log/%{name}/nginx-perl_$a
462 fi
463done
3d760264
ER
464/sbin/chkconfig --add %{name}-perl
465%service %{name}-perl restart
466echo 'NOTE: daemon is now using "/etc/nginx/nginx-perl.conf" file'
738166d2 467
468%post mail
362f5ab2 469for a in access.log error.log; do
738166d2 470 if [ ! -f /var/log/%{name}/nginx-mail_$a ]; then
98376457 471 umask 022
738166d2 472 touch /var/log/%{name}/nginx-mail_$a
473 chown nginx:nginx /var/log/%{name}/nginx-mail_$a
474 chmod 644 /var/log/%{name}/nginx-mail_$a
362f5ab2 475 fi
476done
3d760264
ER
477/sbin/chkconfig --add %{name}-mail
478%service %{name}-mail restart
479echo 'NOTE: daemon is now using "/etc/nginx/nginx-mail.conf" file'
f9e65082 480
b0fa7cc6 481%preun standard
7d80c773 482if [ "$1" = "0" ];then
6eef4074 483 %service %{name}-standard stop
226bcc40 484 /sbin/chkconfig --del %{name}-standard
f9e65082 485fi
f9e65082 486
0663f9da 487%preun light
488if [ "$1" = "0" ]; then
6eef4074 489 %service %{name}-light stop
226bcc40 490 /sbin/chkconfig --del %{name}-light
0663f9da 491fi
492
493%preun perl
494if [ "$1" = "0" ]; then
6eef4074 495 %service %{name}-perl stop
226bcc40 496 /sbin/chkconfig --del %{name}-perl
0663f9da 497fi
498
499%preun mail
500if [ "$1" = "0" ]; then
6eef4074 501 %service %{name}-mail stop
226bcc40 502 /sbin/chkconfig --del %{name}-mail
0663f9da 503fi
504
b0fa7cc6 505%postun
f1fc9780 506if [ "$1" = "0" ]; then
7d9b86c7
ER
507 %userremove %{name}
508 %groupremove %{name}
f1fc9780 509fi
510
f9e65082
ER
511%files
512%defattr(644,root,root,755)
6f8318ed 513%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 514%doc %lang(ru) CHANGES.ru
f1fc9780 515%dir %attr(754,root,root) %{_sysconfdir}
164ab75d 516%dir %{_nginxdir}
517%dir %{_nginxdir}/cgi-bin
518%dir %{_nginxdir}/html
519%dir %{_nginxdir}/errors
28a25161 520%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
98376457 521# XXX: duplicates, don't use such glob here
f1fc9780 522%attr(640,root,root) %{_sysconfdir}/*[_-]*
98376457 523%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
f1fc9780 524%attr(640,root,root) %{_sysconfdir}/mime.types
fb1687bb 525%attr(750,root,root) %dir /var/log/archive/%{name}
f1fc9780 526%attr(750,%{name},logs) /var/log/%{name}
475fecd1 527%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 528%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 529
b0fa7cc6 530%files standard
531%defattr(644,root,root,755)
de0bfb9b 532%attr(755,root,root) %{_sbindir}/%{name}-standard
1846cd14 533%attr(770,root,%{name}) /var/cache/%{name}-standard
0da077af 534%attr(754,root,root) /etc/rc.d/init.d/%{name}-standard
4ddbebd7 535%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-standard.conf
b0fa7cc6 536
85600569 537%if %{with mail}
538%files mail
539%defattr(644,root,root,755)
4e61eac8 540%attr(755,root,root) %{_sbindir}/%{name}-mail
1846cd14 541%attr(770,root,%{name}) /var/cache/%{name}-mail
0da077af 542%attr(754,root,root) /etc/rc.d/init.d/%{name}-mail
4ddbebd7 543%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-mail.conf
85600569 544%endif
545
546%if %{with light}
547%files light
548%defattr(644,root,root,755)
4e61eac8 549%attr(755,root,root) %{_sbindir}/%{name}-light
1846cd14 550%attr(770,root,%{name}) /var/cache/%{name}-light
0da077af 551%attr(754,root,root) /etc/rc.d/init.d/%{name}-light
4ddbebd7 552%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-light.conf
85600569 553%endif
554
555%if %{with perl}
556%files perl
557%defattr(644,root,root,755)
4e61eac8 558%attr(755,root,root) %{_sbindir}/%{name}-perl
0da077af 559%attr(754,root,root) /etc/rc.d/init.d/%{name}-perl
f7b57295 560%attr(770,root,%{name}) /var/cache/%{name}-perl
1846cd14 561%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}-perl.conf
85600569 562%dir %{perl_vendorarch}/auto/%{name}
563%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457
JB
564%{perl_vendorarch}/auto/%{name}/%{name}.bs
565%{perl_vendorarch}/%{name}.pm
dd7459ac 566%endif
567
568%files -n monit-rc-nginx
569%defattr(644,root,root,755)
570%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-standard.monitrc
571%if %{with perl}
1846cd14 572%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-perl.monitrc
85600569 573%endif
dd7459ac 574%if %{with light}
575%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-light.monitrc
576%endif
577%if %{with mail}
578%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}-mail.monitrc
579%endif
This page took 0.17079 seconds and 4 git commands to generate.