]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
drop unneeded triggers
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
ee4f2132 4#
362f5ab2 5# Conditional build for nginx:
efc6207e 6%bcond_with light # don't build light version
008e09c3 7%bcond_without mail # don't build imap/mail proxy
483adace 8%bcond_without perl # don't build with perl module
d0c0492d 9%bcond_without addition # adds module
10%bcond_without dav # WebDAV
11%bcond_without flv # FLV stream
3d4bad81 12%bcond_without ipv6 # build without ipv6 support
d6fc4b09 13%bcond_without sub # ngx_http_sub_module
d0c0492d 14%bcond_without poll # poll
15%bcond_without realip # real ip (behind proxy)
d0c0492d 16%bcond_without select # select
6f05a009 17%bcond_without http2 # HTTP/2 module
f2d29d05 18%bcond_without status # status module
d0c0492d 19%bcond_without ssl # ssl support
d54a9642 20%bcond_without threads # thread pool support
056acc18 21%bcond_with http_browser # header "User-agent" parser
3b14ae78 22%bcond_with rtmp # rtmp support
f2d29d05 23%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
e9a11359 24%bcond_without auth_request # auth_request module
ba5570e8 25%bcond_with modsecurity # modsecurity module
fb649fe5 26
8cf64677
WF
27%ifarch x32
28%undefine with_rtsig
29%endif
30
27ce902f 31%define ssl_version 1.0.2
5d0d957d 32%define rtmp_version 1.1.7
aa6a1e55 33%define modsecurity_version 2.9.1
8e1389c7 34Summary: High perfomance HTTP and reverse proxy server
185313bb 35Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
36# nginx lines:
37# - stable: production quality with stable API
38# - mainline: production quality but API can change
f9e65082 39Name: nginx
69afa2ca 40Version: 1.11.5
efc6207e 41Release: 0.1
51ef519b 42License: BSD-like
cbf76340 43Group: Networking/Daemons/HTTP
06e274b9 44Source0: http://nginx.org/download/%{name}-%{version}.tar.gz
69afa2ca 45# Source0-md5: db43f2b19746f6f47401c3afc3924dc6
06e274b9 46Source1: http://nginx.net/favicon.ico
87404bf2 47# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
06e274b9 48Source2: proxy.conf
226bcc40 49Source3: %{name}.logrotate
50Source4: %{name}.mime
7f97359c 51Source6: %{name}.monitrc
2cb3d9b2 52Source7: %{name}.init
5d9f0850 53Source14: %{name}.conf
7d80c773 54Source17: %{name}-mime.types.sh
8d0ed4b0 55Source18: %{name}.service
ba5570e8 56Source22: http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
aa6a1e55 57# Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
5d0d957d
ER
58Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
59# Source101-md5: 8006de2560db3e55bb15d110220076ac
5ca9795d 60Patch0: %{name}-no-Werror.patch
7ce2935c 61Patch1: %{name}-modsecurity-xheaders.patch
51ef519b 62URL: http://nginx.net/
ba5570e8 63%{?with_modsecurity:BuildRequires: lua-devel}
dfef7372 64BuildRequires: mailcap
27ce902f 65%{?with_ssl:BuildRequires: openssl-devel >= %{ssl_version}}
f1fc9780 66BuildRequires: pcre-devel
1c438d78 67%{?with_perl:BuildRequires: perl-CGI}
d0c0492d 68%{?with_perl:BuildRequires: perl-devel}
dd2388c2 69%{?with_perl:BuildRequires: python}
1c438d78 70%{?with_perl:BuildRequires: rpm-perlprov}
d323480a 71BuildRequires: rpmbuild(macros) >= 1.644
f9e65082 72BuildRequires: zlib-devel
4ac1d45f 73%{?with_ssl:Requires: openssl >= %{ssl_version}}
1a973791
JK
74Provides: group(http)
75Provides: group(nginx)
76Provides: user(nginx)
4ac1d45f 77Provides: webserver
9b47506f
AM
78Provides: webserver(access)
79Provides: webserver(alias)
81d5057a
JK
80Provides: webserver(auth)
81Provides: webserver(expires)
82Provides: webserver(headers)
1e42c256 83Provides: webserver(indexfile)
81d5057a
JK
84Provides: webserver(log)
85Provides: webserver(mime)
86Provides: webserver(reqtimeout)
87Provides: webserver(rewrite)
88Provides: webserver(setenv)
1a973791 89Conflicts: logrotate < 3.8.0
85600569 90Requires(post,preun): /sbin/chkconfig
1a973791 91Requires(post,preun,postun): systemd-units >= 38
4ac1d45f
ER
92Requires(postun): /usr/sbin/groupdel
93Requires(postun): /usr/sbin/userdel
94Requires(pre): /bin/id
95Requires(pre): /usr/bin/getgid
96Requires(pre): /usr/sbin/groupadd
97Requires(pre): /usr/sbin/useradd
98Requires: rc-scripts >= 0.2.0
99Requires: systemd-units >= 38
100Suggests: vim-syntax-nginx
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2ee780b1 102
4ac1d45f
ER
103%define _sysconfdir /etc/%{name}
104%define _nginxdir /home/services/%{name}
105
106%description
1a973791
JK
107nginx ("engine x") is a high-performance HTTP server and reverse
108proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
109Sysoev for Rambler.ru, Russia's second-most visited website, where it
110has been running in production for over two and a half years. Igor has
111released the source code under a BSD-like license. Although still in
112beta, nginx is known for its stability, rich feature set, simple
113configuration, and low resource consumption.
114
4ac1d45f 115%description -l pl.UTF-8
1a973791 116nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
117a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
118potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 119odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
120opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
121fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
122prostej konfiguracji oraz małej "zasobożerności".
123
2ee780b1 124%package perl
125Summary: High perfomance HTTP and reverse proxy server
7ad53968 126Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 127Group: Networking/Daemons/HTTP
4ac1d45f 128Requires: %{name} = %{version}-%{release}
2ee780b1 129
130%description perl
1a973791
JK
131nginx ("engine x") is a high-performance HTTP server and reverse
132proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
133Sysoev for Rambler.ru, Russia's second-most visited website, where it
134has been running in production for over two and a half years. Igor has
135released the source code under a BSD-like license. Although still in
136beta, nginx is known for its stability, rich feature set, simple
137configuration, and low resource consumption.
138
57f21172 139nginx with Perl support. Mail modules not included.
2ee780b1 140
141%description perl -l pl.UTF-8
1a973791 142nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
143a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
144potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 145odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
146opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
147fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
148prostej konfiguracji oraz małej "zasobożerności".
149
57f21172 150nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
2ee780b1 151
152%package mail
57f21172 153Summary: High perfomance IMAP, POP3, SMTP proxy server
154Summary(pl.UTF-8): IMAP, POP3, SMTP proxy o wysokiej wydajności
cbf76340 155Group: Networking/Daemons/HTTP
4ac1d45f 156Requires: %{name} = %{version}-%{release}
2ee780b1 157
158%description mail
1a973791
JK
159nginx ("engine x") is a high-performance HTTP server and reverse
160proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
161Sysoev for Rambler.ru, Russia's second-most visited website, where it
162has been running in production for over two and a half years. Igor has
163released the source code under a BSD-like license. Although still in
164beta, nginx is known for its stability, rich feature set, simple
165configuration, and low resource consumption.
166
57f21172 167nginx with mail support. Only mail modules included.
2ee780b1 168
169%description mail -l pl.UTF-8
1a973791 170nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
171a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
172potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 173odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
174opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
175fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
176prostej konfiguracji oraz małej "zasobożerności".
177
57f21172 178nginx ze wsparciem tylko dla modułów poczty.
2ee780b1 179
dd7459ac 180%package -n monit-rc-nginx
57f21172 181Summary: nginx support for monit
182Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 183Group: Applications/System
4ac1d45f 184Requires: %{name} = %{version}-%{release}
1cf92547 185Requires: monit
dd7459ac 186
187%description -n monit-rc-nginx
57f21172 188monitrc file for monitoring nginx webserver.
dd7459ac 189
190%description -n monit-rc-nginx -l pl.UTF-8
57f21172 191Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 192
f9e65082 193%prep
ba5570e8 194%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
717159c4 195%patch0 -p0
7ce2935c 196%{?with_modsecurity:%patch1 -p0}
f9e65082 197
fb649fe5
ER
198%if %{with rtmp}
199mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
200%endif
201
a8eaad11 202# build mime.types.conf
7d80c773 203#sh %{SOURCE17} /etc/mime.types
a8eaad11 204
f9e65082
ER
205%build
206# NB: not autoconf generated configure
056acc18 207cp -f configure auto/
5d0d957d 208
2fb62cf2
ER
209install -d bin
210
021e3ce8 211# build with default options
2fb62cf2 212build() {
78ac4e4e 213 local type=$1; shift
056acc18 214./configure \
215 --prefix=%{_prefix} \
483adace 216 --modules-path=%{_libdir}/%{name}/modules \
efc6207e
ER
217 --sbin-path=%{_sbindir}/%{name} \
218 --conf-path=%{_sysconfdir}/%{name}.conf \
219 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
220 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
221 --pid-path=%{_localstatedir}/run/%{name}.pid \
222 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
223 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
224 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
225 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
2fb62cf2
ER
226 --user=nginx \
227 --group=nginx \
021e3ce8
ER
228 %{?with_ipv6:--with-ipv6} \
229 %{?with_select:--with-select_module} \
230 %{?with_poll:--with-poll_module} \
231 %{?with_rtsig:--with-rtsig_module} \
008e09c3 232%if %{with perl}
483adace 233 --with-http_perl_module=dynamic \
008e09c3
ER
234%endif
235%if %{with mail}
236 --with-mail=dynamic \
237 --with-mail_ssl_module \
238%endif
2fb62cf2
ER
239 --with-cc="%{__cc}" \
240 --with-cc-opt="%{rpmcflags}" \
241 --with-ld-opt="%{rpmldflags}" \
0aa7dc69 242 %{?with_debug:--with-debug} \
2fb62cf2
ER
243 "$@"
244%{__make}
245}
246
ba5570e8
AO
247%if %{with modsecurity}
248cd modsecurity-%{modsecurity_version}
249./autogen.sh
250%configure \
251 --enable-standalone-module \
252 --disable-mlogc \
253 --enable-alp2 \
254 --with-lua=/usr
255%{__make}
256cd ..
257%endif
258
483adace 259%if %{with perl} && 0
78ac4e4e 260build perl \
056acc18 261 --with-http_perl_module \
262 %{?with_addition:--with-http_addition_module} \
263 %{?with_dav:--with-http_dav_module} \
264 %{?with_flv:--with-http_flv_module} \
d6fc4b09 265 %{?with_sub:--with-http_sub_module} \
056acc18 266 %{?with_realip:--with-http_realip_module} \
056acc18 267 %{?with_status:--with-http_stub_status_module} \
268 %{?with_ssl:--with-http_ssl_module} \
269 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 270 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 271 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 272 %{?with_threads:--with-threads} \
6f05a009 273 %{?with_http2:--with-http_v2_module} \
ca3f3f03 274 --with-http_secure_link_module \
2fb62cf2
ER
275 %{nil}
276
277mv -f objs/nginx bin/nginx-perl
278mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so bin/nginx.so
279mv -f objs/src/http/modules/perl/nginx.pm bin/nginx.pm
056acc18 280%endif
281
008e09c3 282%if %{with mail} && 0
78ac4e4e 283build mail \
f2d29d05 284 --without-http \
056acc18 285 --with-imap \
286 --with-mail \
287 --with-mail_ssl_module \
2fb62cf2
ER
288 %{nil}
289
290mv -f objs/nginx bin/nginx-mail
056acc18 291%endif
292
293%if %{with light}
78ac4e4e 294build light \
056acc18 295 %{?with_realip:--with-http_realip_module} \
056acc18 296 %{?with_status:--with-http_stub_status_module} \
297 %{?with_ssl:--with-http_ssl_module} \
fb649fe5 298 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 299 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 300 %{?with_threads:--with-threads} \
6f05a009 301 %{?with_http2:--with-http_v2_module} \
ba5570e8 302 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
056acc18 303 --without-http_browser_module \
ca3f3f03 304 --with-http_secure_link_module \
2fb62cf2
ER
305 %{nil}
306
307mv -f objs/nginx bin/nginx-light
056acc18 308%endif
309
78ac4e4e 310build standard \
d0c0492d 311 %{?with_addition:--with-http_addition_module} \
312 %{?with_dav:--with-http_dav_module} \
313 %{?with_flv:--with-http_flv_module} \
d6fc4b09 314 %{?with_sub:--with-http_sub_module} \
d0c0492d 315 %{?with_realip:--with-http_realip_module} \
d0c0492d 316 %{?with_status:--with-http_stub_status_module} \
362f5ab2 317 %{?with_ssl:--with-http_ssl_module} \
ee4f2132 318 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 319 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 320 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 321 %{?with_threads:--with-threads} \
619c1aee 322 %{?with_http2:--with-http_v2_module} \
ba5570e8 323 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
ca3f3f03 324 --with-http_secure_link_module \
2fb62cf2 325 %{nil}
f9e65082
ER
326
327%install
328rm -rf $RPM_BUILD_ROOT
362f5ab2 329install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
330 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 331 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
c63e9e18
ER
332 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
333 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
36b3be34 334 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
d323480a 335 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 336 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 337
483adace
ER
338%{__make} install \
339 INSTALLDIRS=vendor \
340 DESTDIR=$RPM_BUILD_ROOT
341
342%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
343
7f97359c
ER
344cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
345cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
346cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
c63e9e18
ER
347install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
348
483adace
ER
349cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
350cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
3c75ce8a 351cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
483adace
ER
352rm -r $RPM_BUILD_ROOT%{_prefix}/html
353cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
354cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
5ca9795d 355cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
85600569 356
357%if %{with perl}
483adace
ER
358%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
359%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
483adace
ER
360%endif
361
32c47bd6
ER
362# only touch these for ghost packaging
363touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
364
f9e65082
ER
365%clean
366rm -rf $RPM_BUILD_ROOT
367
c63e9e18 368%pre
a37373c3 369%groupadd -r -g 213 %{name}
362f5ab2 370%groupadd -g 51 http
a37373c3 371%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 372%addusertogroup %{name} http
f1fc9780 373
c63e9e18 374%post
738166d2 375for a in access.log error.log; do
c63e9e18 376 if [ ! -f /var/log/%{name}/$a ]; then
98376457 377 umask 022
c63e9e18
ER
378 touch /var/log/%{name}/$a
379 chown nginx:nginx /var/log/%{name}/$a
380 chmod 644 /var/log/%{name}/$a
738166d2 381 fi
382done
c63e9e18
ER
383/sbin/chkconfig --add %{name}
384%systemd_post %{name}.service
385%service %{name} force-reload
738166d2 386
c63e9e18 387%preun
7d80c773 388if [ "$1" = "0" ];then
c63e9e18
ER
389 %service %{name} stop
390 /sbin/chkconfig --del %{name}
0663f9da 391fi
c63e9e18 392%systemd_preun %{name}.service
0663f9da 393
c63e9e18 394%postun
f1fc9780 395if [ "$1" = "0" ]; then
7d9b86c7
ER
396 %userremove %{name}
397 %groupremove %{name}
f1fc9780 398fi
d323480a
JK
399%systemd_reload
400
4ac1d45f 401%triggerpostun -- %{name} < 1.8.0-2
32c47bd6
ER
402# skip *this* trigger on downgrade
403[ $1 -le 1 ] && exit 0
404ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
405ln -sf scgi_params %{_sysconfdir}/scgi.params
406ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
407exit 0
408
c63e9e18 409%files
f9e65082 410%defattr(644,root,root,755)
6f8318ed 411%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 412%doc %lang(ru) CHANGES.ru
37ddc577 413%dir %attr(750,root,nginx) %{_sysconfdir}
164ab75d 414%dir %{_nginxdir}
415%dir %{_nginxdir}/cgi-bin
416%dir %{_nginxdir}/html
417%dir %{_nginxdir}/errors
28a25161 418%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
98376457 419%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
32c47bd6
ER
420%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
421%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
422%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
423%ghost %{_sysconfdir}/fastcgi.params
424%ghost %{_sysconfdir}/scgi.params
425%ghost %{_sysconfdir}/uwsgi.params
f1fc9780 426%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 427%attr(640,root,root) %{_sysconfdir}/koi-utf
428%attr(640,root,root) %{_sysconfdir}/koi-win
429%attr(640,root,root) %{_sysconfdir}/win-utf
36b3be34
JK
430%dir %{_sysconfdir}/webapps.d
431%dir %{_sysconfdir}/vhosts.d
debe6eba
JR
432%attr(750,nginx,logs) %dir /var/log/archive/%{name}
433%attr(750,nginx,logs) /var/log/%{name}
475fecd1 434%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 435%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 436
b0fa7cc6 437%defattr(644,root,root,755)
483adace 438%attr(755,root,root) %{_sbindir}/%{name}
c63e9e18
ER
439%attr(770,root,%{name}) /var/cache/%{name}
440%attr(754,root,root) /etc/rc.d/init.d/%{name}
441%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
442%{systemdunitdir}/%{name}.service
b0fa7cc6 443
85600569 444%if %{with mail}
445%files mail
446%defattr(644,root,root,755)
008e09c3
ER
447%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
448%endif
85600569 449
85600569 450%if %{with perl}
451%files perl
452%defattr(644,root,root,755)
008e09c3 453%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
85600569 454%dir %{perl_vendorarch}/auto/%{name}
455%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 456%{perl_vendorarch}/%{name}.pm
483adace 457%{_mandir}/man3/nginx.3pm*
483adace 458%endif
dd7459ac 459
460%files -n monit-rc-nginx
461%defattr(644,root,root,755)
c63e9e18 462%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.186655 seconds and 4 git commands to generate.