]> git.pld-linux.org Git - packages/nginx.git/blame - nginx.spec
install just one set of package files
[packages/nginx.git] / nginx.spec
CommitLineData
f9e65082 1# TODO
ee4f2132 2# - /etc/sysconfig/nginx file
1c438d78 3# - missing perl build/install requires
ee4f2132 4#
362f5ab2 5# Conditional build for nginx:
efc6207e 6%bcond_with light # don't build light version
008e09c3 7%bcond_without mail # don't build imap/mail proxy
483adace 8%bcond_without perl # don't build with perl module
d0c0492d 9%bcond_without addition # adds module
10%bcond_without dav # WebDAV
11%bcond_without flv # FLV stream
3d4bad81 12%bcond_without ipv6 # build without ipv6 support
d6fc4b09 13%bcond_without sub # ngx_http_sub_module
d0c0492d 14%bcond_without poll # poll
15%bcond_without realip # real ip (behind proxy)
d0c0492d 16%bcond_without select # select
6f05a009 17%bcond_without http2 # HTTP/2 module
f2d29d05 18%bcond_without status # status module
d0c0492d 19%bcond_without ssl # ssl support
d54a9642 20%bcond_without threads # thread pool support
056acc18 21%bcond_with http_browser # header "User-agent" parser
3b14ae78 22%bcond_with rtmp # rtmp support
f2d29d05 23%bcond_with debug # enable debug logging: http://nginx.org/en/docs/debugging_log.html
e9a11359 24%bcond_without auth_request # auth_request module
ba5570e8 25%bcond_with modsecurity # modsecurity module
fb649fe5 26
8cf64677
WF
27%ifarch x32
28%undefine with_rtsig
29%endif
30
27ce902f 31%define ssl_version 1.0.2
5d0d957d 32%define rtmp_version 1.1.7
aa6a1e55 33%define modsecurity_version 2.9.1
8e1389c7 34Summary: High perfomance HTTP and reverse proxy server
185313bb 35Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
3dfa1ca2
AM
36# nginx lines:
37# - stable: production quality with stable API
38# - mainline: production quality but API can change
f9e65082 39Name: nginx
69afa2ca 40Version: 1.11.5
efc6207e 41Release: 0.1
51ef519b 42License: BSD-like
cbf76340 43Group: Networking/Daemons/HTTP
06e274b9 44Source0: http://nginx.org/download/%{name}-%{version}.tar.gz
69afa2ca 45# Source0-md5: db43f2b19746f6f47401c3afc3924dc6
06e274b9 46Source1: http://nginx.net/favicon.ico
87404bf2 47# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
06e274b9 48Source2: proxy.conf
226bcc40 49Source3: %{name}.logrotate
50Source4: %{name}.mime
226bcc40 51Source6: %{name}-light.monitrc
2cb3d9b2 52Source7: %{name}.init
0da077af 53Source8: %{name}-mail.conf
54Source9: %{name}-mail.monitrc
0da077af 55Source12: %{name}-perl.monitrc
5d9f0850 56Source14: %{name}.conf
0da077af 57Source15: %{name}-standard.monitrc
7d80c773 58Source17: %{name}-mime.types.sh
d323480a
JK
59Source18: %{name}-standard.service
60Source19: %{name}-light.service
61Source20: %{name}-perl.service
62Source21: %{name}-mail.service
ba5570e8 63Source22: http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
aa6a1e55 64# Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
5d0d957d
ER
65Source101: https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/nginx-rtmp-module-%{rtmp_version}.tar.gz
66# Source101-md5: 8006de2560db3e55bb15d110220076ac
5ca9795d 67Patch0: %{name}-no-Werror.patch
7ce2935c 68Patch1: %{name}-modsecurity-xheaders.patch
51ef519b 69URL: http://nginx.net/
ba5570e8 70%{?with_modsecurity:BuildRequires: lua-devel}
dfef7372 71BuildRequires: mailcap
27ce902f 72%{?with_ssl:BuildRequires: openssl-devel >= %{ssl_version}}
f1fc9780 73BuildRequires: pcre-devel
1c438d78 74%{?with_perl:BuildRequires: perl-CGI}
d0c0492d 75%{?with_perl:BuildRequires: perl-devel}
dd2388c2 76%{?with_perl:BuildRequires: python}
1c438d78 77%{?with_perl:BuildRequires: rpm-perlprov}
d323480a 78BuildRequires: rpmbuild(macros) >= 1.644
f9e65082
ER
79BuildRequires: zlib-devel
80BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
362f5ab2 82%define _sysconfdir /etc/%{name}
83%define _nginxdir /home/services/%{name}
f9e65082
ER
84
85%description
57f21172 86nginx ("engine x") is a high-performance HTTP server and reverse
87proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
894ff1f7
ER
88Sysoev for Rambler.ru, Russia's second-most visited website, where it
89has been running in production for over two and a half years. Igor has
90released the source code under a BSD-like license. Although still in
57f21172 91beta, nginx is known for its stability, rich feature set, simple
894ff1f7 92configuration, and low resource consumption.
8e1389c7 93
390f5b88 94%description -l pl.UTF-8
57f21172 95nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
96a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
97potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
056acc18 98odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
99opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
100fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1dc54c84 101prostej konfiguracji oraz małej "zasobożerności".
2ee780b1 102
1a973791
JK
103%package common
104Summary: nginx - common files
105Summary(pl.UTF-8): nginx - pliki wspólne
106Group: Networking/Daemons/HTTP
107Requires(postun): /usr/sbin/groupdel
108Requires(postun): /usr/sbin/userdel
109Requires(pre): /bin/id
110Requires(pre): /usr/bin/getgid
111Requires(pre): /usr/sbin/groupadd
112Requires(pre): /usr/sbin/useradd
1a973791
JK
113Requires: rc-scripts >= 0.2.0
114Requires: systemd-units >= 38
1f74ff7c 115Suggests: vim-syntax-nginx
1a973791
JK
116Provides: group(http)
117Provides: group(nginx)
118Provides: user(nginx)
9b47506f
AM
119Provides: webserver(access)
120Provides: webserver(alias)
81d5057a
JK
121Provides: webserver(auth)
122Provides: webserver(expires)
123Provides: webserver(headers)
1e42c256 124Provides: webserver(indexfile)
81d5057a
JK
125Provides: webserver(log)
126Provides: webserver(mime)
127Provides: webserver(reqtimeout)
128Provides: webserver(rewrite)
129Provides: webserver(setenv)
5ca9795d 130Obsoletes: nginx < 1.4.1-4.1
1a973791 131Conflicts: logrotate < 3.8.0
1a973791
JK
132
133%description common
134Common files for the nginx daemon.
135
136%description common -l pl.UTF-8
57f21172 137Niezbędne pliki dla nginx.
85600569 138
2ee780b1 139%package light
140Summary: High perfomance HTTP and reverse proxy server
7ad53968 141Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 142Group: Networking/Daemons/HTTP
85600569 143Requires(post,preun): /sbin/chkconfig
1a973791
JK
144Requires(post,preun,postun): systemd-units >= 38
145Requires: %{name}-common = %{version}-%{release}
27ce902f 146%{?with_ssl:Requires: openssl >= %{ssl_version}}
119e2f19 147Provides: nginx-daemon
2ee780b1 148Provides: webserver
149
150%description light
1a973791
JK
151nginx ("engine x") is a high-performance HTTP server and reverse
152proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
153Sysoev for Rambler.ru, Russia's second-most visited website, where it
154has been running in production for over two and a half years. Igor has
155released the source code under a BSD-like license. Although still in
156beta, nginx is known for its stability, rich feature set, simple
157configuration, and low resource consumption.
158
57f21172 159The smallest, but also the fastest nginx edition. No additional
7ad53968 160modules, no Perl, no DAV, no FLV, no IMAP, POP3, SMTP proxy.
2ee780b1 161
162%description light -l pl.UTF-8
1a973791 163nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
164a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
165potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 166odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
167opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
168fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
169prostej konfiguracji oraz małej "zasobożerności".
170
57f21172 171Najmniejsza i najszybsza wersja nginx. Bez wsparcia dla Perla, DAV,
1cf92547 172FLV oraz IMAP, POP3, SMTP proxy.
2ee780b1 173
174%package perl
175Summary: High perfomance HTTP and reverse proxy server
7ad53968 176Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 177Group: Networking/Daemons/HTTP
85600569 178Requires(post,preun): /sbin/chkconfig
1a973791
JK
179Requires(post,preun,postun): systemd-units >= 38
180Requires: %{name}-common = %{version}-%{release}
27ce902f 181%{?with_ssl:Requires: openssl >= %{ssl_version}}
1cf92547 182Provides: nginx-daemon
2ee780b1 183Provides: webserver
184
185%description perl
1a973791
JK
186nginx ("engine x") is a high-performance HTTP server and reverse
187proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
188Sysoev for Rambler.ru, Russia's second-most visited website, where it
189has been running in production for over two and a half years. Igor has
190released the source code under a BSD-like license. Although still in
191beta, nginx is known for its stability, rich feature set, simple
192configuration, and low resource consumption.
193
57f21172 194nginx with Perl support. Mail modules not included.
2ee780b1 195
196%description perl -l pl.UTF-8
1a973791 197nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
198a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
199potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 200odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
201opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
202fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
203prostej konfiguracji oraz małej "zasobożerności".
204
57f21172 205nginx z obsługą Perla. Bez wsparcia dla modułów poczty.
2ee780b1 206
207%package mail
57f21172 208Summary: High perfomance IMAP, POP3, SMTP proxy server
209Summary(pl.UTF-8): IMAP, POP3, SMTP proxy o wysokiej wydajności
cbf76340 210Group: Networking/Daemons/HTTP
85600569 211Requires(post,preun): /sbin/chkconfig
1a973791
JK
212Requires(post,preun,postun): systemd-units >= 38
213Requires: %{name}-common = %{version}-%{release}
1cf92547 214Provides: nginx-daemon
2ee780b1 215
216%description mail
1a973791
JK
217nginx ("engine x") is a high-performance HTTP server and reverse
218proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
219Sysoev for Rambler.ru, Russia's second-most visited website, where it
220has been running in production for over two and a half years. Igor has
221released the source code under a BSD-like license. Although still in
222beta, nginx is known for its stability, rich feature set, simple
223configuration, and low resource consumption.
224
57f21172 225nginx with mail support. Only mail modules included.
2ee780b1 226
227%description mail -l pl.UTF-8
1a973791 228nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
229a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
230potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 231odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
232opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
233fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
1a973791
JK
234prostej konfiguracji oraz małej "zasobożerności".
235
57f21172 236nginx ze wsparciem tylko dla modułów poczty.
2ee780b1 237
b0fa7cc6 238%package standard
57f21172 239Summary: High perfomance HTTP and reverse proxy server
4ca0234e 240Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
cbf76340 241Group: Networking/Daemons/HTTP
d6fc4b09 242Requires(post,preun): /sbin/chkconfig
1a973791
JK
243Requires(post,preun,postun): systemd-units >= 38
244Requires: %{name}-common = %{version}-%{release}
27ce902f 245%{?with_ssl:Requires: openssl >= %{ssl_version}}
1a973791 246Provides: nginx
1cf92547 247Provides: nginx-daemon
577e51d2 248Provides: webserver
d6fc4b09 249Conflicts: logrotate < 3.7-4
28a25161 250
b0fa7cc6 251%description standard
1a973791
JK
252nginx ("engine x") is a high-performance HTTP server and reverse
253proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
254Sysoev for Rambler.ru, Russia's second-most visited website, where it
255has been running in production for over two and a half years. Igor has
256released the source code under a BSD-like license. Although still in
257beta, nginx is known for its stability, rich feature set, simple
258configuration, and low resource consumption.
259
57f21172 260This is standard nginx version, without Perl support and IMAP, POP3,
5ca9795d 261SMTP proxy.
fccff804 262
b0fa7cc6 263%description standard -l pl.UTF-8
1a973791 264nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
5ca9795d
ER
265a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
266potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
1a973791 267odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
5ca9795d
ER
268opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
269fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
270prostej konfiguracji oraz małej "zasobożerności". ginx ("engine x")
271jest wysokowydajnym serwerem HTTP, odwrotnym proxy a także IMAP/POP3
272proxy. nginx został napisany przez Igora Sysoeva na potrzeby serwisu
273Rambler.ru. Jest to drugi pod względem ilości odwiedzin serwis w Rosji
274i działa od ponad dwóch i pół roku. Igor opublikował źródła na
275licencji BSD. Mimo, że projekt jest ciągle w fazie beta, już zasłynął
276dzięki stabilności, bogactwu dodatków, prostej konfiguracji oraz małej
277"zasobożerności".
1a973791 278
57f21172 279To jest standardowa wersja nginx, bez obsługi Perla oraz proxy dla
1dc54c84 280IMAP, POP3, SMTP.
85600569 281
dd7459ac 282%package -n monit-rc-nginx
57f21172 283Summary: nginx support for monit
284Summary(pl.UTF-8): Wsparcie nginx dla monit
60b8f836 285Group: Applications/System
286URL: http://nginx.eu/
1a973791 287Requires: %{name}-common = %{version}-%{release}
1cf92547 288Requires: monit
dd7459ac 289
290%description -n monit-rc-nginx
57f21172 291monitrc file for monitoring nginx webserver.
dd7459ac 292
293%description -n monit-rc-nginx -l pl.UTF-8
57f21172 294Plik monitrc do monitorowania serwera WWW nginx.
dd7459ac 295
f9e65082 296%prep
ba5570e8 297%setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
717159c4 298%patch0 -p0
7ce2935c 299%{?with_modsecurity:%patch1 -p0}
f9e65082 300
fb649fe5
ER
301%if %{with rtmp}
302mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
303%endif
304
a8eaad11 305# build mime.types.conf
7d80c773 306#sh %{SOURCE17} /etc/mime.types
a8eaad11 307
f9e65082
ER
308%build
309# NB: not autoconf generated configure
056acc18 310cp -f configure auto/
5d0d957d 311
2fb62cf2
ER
312install -d bin
313
021e3ce8 314# build with default options
2fb62cf2 315build() {
78ac4e4e 316 local type=$1; shift
056acc18 317./configure \
318 --prefix=%{_prefix} \
483adace 319 --modules-path=%{_libdir}/%{name}/modules \
efc6207e
ER
320 --sbin-path=%{_sbindir}/%{name} \
321 --conf-path=%{_sysconfdir}/%{name}.conf \
322 --error-log-path=%{_localstatedir}/log/%{name}/error.log \
323 --http-log-path=%{_localstatedir}/log/%{name}/access.log \
324 --pid-path=%{_localstatedir}/run/%{name}.pid \
325 --lock-path=%{_localstatedir}/lock/subsys/%{name} \
326 --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
327 --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
328 --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
2fb62cf2
ER
329 --user=nginx \
330 --group=nginx \
021e3ce8
ER
331 %{?with_ipv6:--with-ipv6} \
332 %{?with_select:--with-select_module} \
333 %{?with_poll:--with-poll_module} \
334 %{?with_rtsig:--with-rtsig_module} \
008e09c3 335%if %{with perl}
483adace 336 --with-http_perl_module=dynamic \
008e09c3
ER
337%endif
338%if %{with mail}
339 --with-mail=dynamic \
340 --with-mail_ssl_module \
341%endif
2fb62cf2
ER
342 --with-cc="%{__cc}" \
343 --with-cc-opt="%{rpmcflags}" \
344 --with-ld-opt="%{rpmldflags}" \
0aa7dc69 345 %{?with_debug:--with-debug} \
2fb62cf2
ER
346 "$@"
347%{__make}
348}
349
ba5570e8
AO
350%if %{with modsecurity}
351cd modsecurity-%{modsecurity_version}
352./autogen.sh
353%configure \
354 --enable-standalone-module \
355 --disable-mlogc \
356 --enable-alp2 \
357 --with-lua=/usr
358%{__make}
359cd ..
360%endif
361
483adace 362%if %{with perl} && 0
78ac4e4e 363build perl \
056acc18 364 --with-http_perl_module \
365 %{?with_addition:--with-http_addition_module} \
366 %{?with_dav:--with-http_dav_module} \
367 %{?with_flv:--with-http_flv_module} \
d6fc4b09 368 %{?with_sub:--with-http_sub_module} \
056acc18 369 %{?with_realip:--with-http_realip_module} \
056acc18 370 %{?with_status:--with-http_stub_status_module} \
371 %{?with_ssl:--with-http_ssl_module} \
372 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 373 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 374 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 375 %{?with_threads:--with-threads} \
6f05a009 376 %{?with_http2:--with-http_v2_module} \
ca3f3f03 377 --with-http_secure_link_module \
2fb62cf2
ER
378 %{nil}
379
380mv -f objs/nginx bin/nginx-perl
381mv -f objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so bin/nginx.so
382mv -f objs/src/http/modules/perl/nginx.pm bin/nginx.pm
056acc18 383%endif
384
008e09c3 385%if %{with mail} && 0
78ac4e4e 386build mail \
f2d29d05 387 --without-http \
056acc18 388 --with-imap \
389 --with-mail \
390 --with-mail_ssl_module \
2fb62cf2
ER
391 %{nil}
392
393mv -f objs/nginx bin/nginx-mail
056acc18 394%endif
395
396%if %{with light}
78ac4e4e 397build light \
056acc18 398 %{?with_realip:--with-http_realip_module} \
056acc18 399 %{?with_status:--with-http_stub_status_module} \
400 %{?with_ssl:--with-http_ssl_module} \
fb649fe5 401 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 402 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 403 %{?with_threads:--with-threads} \
6f05a009 404 %{?with_http2:--with-http_v2_module} \
ba5570e8 405 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
056acc18 406 --without-http_browser_module \
ca3f3f03 407 --with-http_secure_link_module \
2fb62cf2
ER
408 %{nil}
409
410mv -f objs/nginx bin/nginx-light
056acc18 411%endif
412
78ac4e4e 413build standard \
d0c0492d 414 %{?with_addition:--with-http_addition_module} \
415 %{?with_dav:--with-http_dav_module} \
416 %{?with_flv:--with-http_flv_module} \
d6fc4b09 417 %{?with_sub:--with-http_sub_module} \
d0c0492d 418 %{?with_realip:--with-http_realip_module} \
d0c0492d 419 %{?with_status:--with-http_stub_status_module} \
362f5ab2 420 %{?with_ssl:--with-http_ssl_module} \
ee4f2132 421 %{!?with_http_browser:--without-http_browser_module} \
fb649fe5 422 %{?with_rtmp:--add-module=./nginx-rtmp-module} \
e9a11359 423 %{?with_auth_request:--with-http_auth_request_module} \
8cf64677 424 %{?with_threads:--with-threads} \
619c1aee 425 %{?with_http2:--with-http_v2_module} \
ba5570e8 426 %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
ca3f3f03 427 --with-http_secure_link_module \
2fb62cf2 428 %{nil}
f9e65082
ER
429
430%install
431rm -rf $RPM_BUILD_ROOT
362f5ab2 432install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
433 $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
4e61eac8 434 $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
c63e9e18
ER
435 $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
436 $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
36b3be34 437 $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
d323480a 438 $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
599f35f0 439 $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
f9e65082 440
483adace
ER
441%{__make} install \
442 INSTALLDIRS=vendor \
443 DESTDIR=$RPM_BUILD_ROOT
444
445%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
446
c63e9e18
ER
447cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
448cp -p %{_sourcedir}/%{name}-standard.service $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
449cp -p %{_sourcedir}/%{name}-standard.monitrc $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
450install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
451
483adace
ER
452cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
453cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
3c75ce8a 454cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
483adace
ER
455rm -r $RPM_BUILD_ROOT%{_prefix}/html
456cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
457cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
5ca9795d 458cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
85600569 459
460%if %{with perl}
483adace
ER
461%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
462%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
483adace
ER
463%endif
464
32c47bd6
ER
465# only touch these for ghost packaging
466touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
467
f9e65082
ER
468%clean
469rm -rf $RPM_BUILD_ROOT
470
c63e9e18 471%pre
a37373c3 472%groupadd -r -g 213 %{name}
362f5ab2 473%groupadd -g 51 http
a37373c3 474%useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
362f5ab2 475%addusertogroup %{name} http
f1fc9780 476
c63e9e18 477%post
738166d2 478for a in access.log error.log; do
c63e9e18 479 if [ ! -f /var/log/%{name}/$a ]; then
98376457 480 umask 022
c63e9e18
ER
481 touch /var/log/%{name}/$a
482 chown nginx:nginx /var/log/%{name}/$a
483 chmod 644 /var/log/%{name}/$a
738166d2 484 fi
485done
c63e9e18
ER
486/sbin/chkconfig --add %{name}
487%systemd_post %{name}.service
488%service %{name} force-reload
738166d2 489
c63e9e18 490%preun
7d80c773 491if [ "$1" = "0" ];then
c63e9e18
ER
492 %service %{name} stop
493 /sbin/chkconfig --del %{name}
0663f9da 494fi
c63e9e18 495%systemd_preun %{name}.service
0663f9da 496
c63e9e18 497%postun
f1fc9780 498if [ "$1" = "0" ]; then
7d9b86c7
ER
499 %userremove %{name}
500 %groupremove %{name}
f1fc9780 501fi
d323480a
JK
502%systemd_reload
503
504%triggerpostun -- %{name}-standard < 1.4.1-4
505%systemd_trigger %{name}-standard.service
506
507%triggerpostun -- %{name}-light < 1.4.1-4
508%systemd_trigger %{name}-light.service
509
510%triggerpostun -- %{name}-perl < 1.4.1-4
511%systemd_trigger %{name}-perl.service
512
513%triggerpostun -- %{name}-mail < 1.4.1-4
514%systemd_trigger %{name}-mail.service
515
32c47bd6
ER
516%triggerpostun common -- %{name}-common < 1.8.0-2
517# skip *this* trigger on downgrade
518[ $1 -le 1 ] && exit 0
519ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
520ln -sf scgi_params %{_sysconfdir}/scgi.params
521ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
522exit 0
523
c63e9e18 524%files
f9e65082 525%defattr(644,root,root,755)
6f8318ed 526%doc CHANGES LICENSE README html/index.html conf/nginx.conf
f9e65082 527%doc %lang(ru) CHANGES.ru
37ddc577 528%dir %attr(750,root,nginx) %{_sysconfdir}
164ab75d 529%dir %{_nginxdir}
530%dir %{_nginxdir}/cgi-bin
531%dir %{_nginxdir}/html
532%dir %{_nginxdir}/errors
28a25161 533%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
98376457 534%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
32c47bd6
ER
535%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
536%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
537%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
538%ghost %{_sysconfdir}/fastcgi.params
539%ghost %{_sysconfdir}/scgi.params
540%ghost %{_sysconfdir}/uwsgi.params
f1fc9780 541%attr(640,root,root) %{_sysconfdir}/mime.types
57f21172 542%attr(640,root,root) %{_sysconfdir}/koi-utf
543%attr(640,root,root) %{_sysconfdir}/koi-win
544%attr(640,root,root) %{_sysconfdir}/win-utf
36b3be34
JK
545%dir %{_sysconfdir}/webapps.d
546%dir %{_sysconfdir}/vhosts.d
debe6eba
JR
547%attr(750,nginx,logs) %dir /var/log/archive/%{name}
548%attr(750,nginx,logs) /var/log/%{name}
475fecd1 549%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
cd728db7 550%config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
28a25161 551
b0fa7cc6 552%defattr(644,root,root,755)
483adace 553%attr(755,root,root) %{_sbindir}/%{name}
c63e9e18
ER
554%attr(770,root,%{name}) /var/cache/%{name}
555%attr(754,root,root) /etc/rc.d/init.d/%{name}
556%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
557%{systemdunitdir}/%{name}.service
b0fa7cc6 558
85600569 559%if %{with mail}
560%files mail
561%defattr(644,root,root,755)
008e09c3
ER
562%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
563%endif
85600569 564
565%if %{with light}
566%files light
567%defattr(644,root,root,755)
85600569 568%endif
569
570%if %{with perl}
571%files perl
572%defattr(644,root,root,755)
008e09c3 573%attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
85600569 574%dir %{perl_vendorarch}/auto/%{name}
575%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
98376457 576%{perl_vendorarch}/%{name}.pm
483adace 577%{_mandir}/man3/nginx.3pm*
483adace 578%endif
dd7459ac 579
580%files -n monit-rc-nginx
581%defattr(644,root,root,755)
c63e9e18 582%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.142511 seconds and 4 git commands to generate.