]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- nscd data in /var/lib/nscd (FHS 2.x)
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
e03cf19f
JB
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
757f96eb 14%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 15%bcond_with tests # perform "make test"
4cceaf33 16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
0a85848c 17%bcond_without localedb # don't build localedb-all (is time consuming)
472e31ee 18%bcond_with cross # build using crossgcc (without libgcc_eh)
b287d865 19#
37cd6ebc 20# TODO:
72549d49 21# - look at locale fixes/updates in bugzilla
8af69c64
JB
22# - usable persitent storage in nscd:
23# - change persistent storage paths to /var/lib/nscd (to be FHS 2.3 compliant)
24# (see glibc/nscd/nscd.h)
25# - create nscd user, use it in nscd.conf (see -pld.patch)
72549d49 26# [OLD]
37cd6ebc 27# - localedb-gen man pages(?)
4acad1ec 28# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
29# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
30# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
31# - problem compiling with --enable-bounded (must be reported to libc-alpha)
32# (is this comment still valid???)
76f01b70 33#
61918272 34
3900e225 35%{!?min_kernel:%global min_kernel 2.4.6}
76131947 36%if "%{min_kernel}" < "2.6.0"
40240acb
JB
37%global nptl_min_kernel 2.6.0
38%else
39%global nptl_min_kernel %{min_kernel}
76131947 40%endif
40240acb 41
e03cf19f 42%if %{with tls}
c14df6fe 43# sparc temporarily removed (broken)
472e31ee 44%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
e03cf19f
JB
45%undefine with_tls
46%endif
47%endif
48
40240acb 49%if %{with nptl}
472e31ee
JB
50# on x86 uses cmpxchgl (available since i486)
51# on sparc only sparcv9 is supported
4bcd7e8c 52%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
40240acb 53%undefine with_nptl
e03cf19f
JB
54%else
55%if %{without tls}
56%undefine with_nptl
3900e225 57%endif
61918272 58%endif
f3f771b7
AM
59%endif
60
e24149ab
PS
61%ifarch sparc64
62%undefine with_memusage
63%endif
64
40240acb
JB
65%if %{with linuxthreads} && %{with nptl}
66%define with_dual 1
67%endif
68
121eb47e 69%define llh_version 7:2.6.6.0
e8c60795 70
236a5027 71Summary: GNU libc
72Summary(de): GNU libc
4a04bb32 73Summary(es): GNU libc
236a5027 74Summary(fr): GNU libc
c5387ad5 75