]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- disable tls for ppc (available for gcc >= 3.4 which is not in Ac)
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
e03cf19f
JB
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
757f96eb 14%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 15%bcond_with tests # perform "make test"
4cceaf33 16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
0a85848c 17%bcond_without localedb # don't build localedb-all (is time consuming)
61918272 18
aabbc252
JB
19%bcond_without comdat # without (unfinished) comdat hacks [for Ac]
20
b287d865 21#
37cd6ebc 22# TODO:
72549d49
JB
23# - look at locale fixes/updates in bugzilla
24# [OLD]
37cd6ebc 25# - localedb-gen man pages(?)
4acad1ec 26# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
27# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
28# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
29# - problem compiling with --enable-bounded (must be reported to libc-alpha)
30# (is this comment still valid???)
76f01b70 31#
61918272 32
3900e225 33%{!?min_kernel:%global min_kernel 2.4.6}
76131947 34%if "%{min_kernel}" < "2.6.0"
40240acb
JB
35%global nptl_min_kernel 2.6.0
36%else
37%global nptl_min_kernel %{min_kernel}
76131947 38%endif
40240acb 39
e03cf19f 40%if %{with tls}
31437bb3
AM
41# - sparc temporarily removed (broken)
42# - TLS support for PPC is only available when using gcc >= 3.4
43%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc64 sparcv9
e03cf19f
JB
44%undefine with_tls
45%endif
46%endif
47
40240acb
JB
48%if %{with nptl}
49# nptl on x86 uses cmpxchgl (available since i486)
4bcd7e8c 50%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
40240acb 51%undefine with_nptl
e03cf19f
JB
52%else
53%if %{without tls}
54%undefine with_nptl
3900e225 55%endif
61918272 56%endif
f3f771b7
AM
57%endif
58
e24149ab
PS
59%ifarch sparc64
60%undefine with_memusage
61%endif
62
40240acb
JB
63%if %{with linuxthreads} && %{with nptl}
64%define with_dual 1
65%endif
66
121eb47e 67%define llh_version 7:2.6.6.0
e8c60795 68
236a5027 69Summary: GNU libc
70Summary(de): GNU libc
4a04bb32 71Summary(es): GNU libc
236a5027 72Summary(fr): GNU libc
c5387ad5 73