]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- opencv bcond, added comment about ffmpeg/opencv build dependency loop
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
94447fde 1# TODO
cbdd2688 2# - is bug803 patch still needed? the code changed somehow
197f4211 3#
192f9f57 4# Workaround ffmpeg.spec & opencv.spec updating:
5#
6# 1. make-request -r --without opencv ffmpeg.spec
7# 2. make-request -r opencv.spec
8# 3. bump release of ffmpeg.spec
9# 4. make-request -r ffmpeg.spec
10#
2b3b2117 11# Conditional build:
38cefaee 12%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 13%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
294c9b1e 14%bcond_without autoreqdep # don't care about package name deps generated by rpm
d7a39558 15%bcond_without frei0r # build without frei0r video filtering
192f9f57 16%bcond_without opencv # build without opencv video filtering
ea09f25d 17%bcond_without x264 # build without x264 encoder
1ef27ea1
JB
18%bcond_without va # VAAPI (Video Acceleration API)
19%bcond_without vpx # VP8, a high-quality video codec
20%bcond_without doc # don't build docs
314ef0df 21
cbdd2688
JB
22Summary: FFmpeg - a very fast video and audio converter
23Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 24Name: ffmpeg
660918c5 25Version: 0.9
192f9f57 26Release: 2
9cf4d8a4 27# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
28# (postprocessing, some filters, x264, xavs, xvid, x11grab)
29# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 30License: GPL v3+ with LGPL v3+ parts
fde29260 31Group: Applications/Multimedia
1ef27ea1 32Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
660918c5 33# Source0-md5: 795058de6fc432aa11271408273a0535
fde29260
ER
34Source1: ffserver.init
35Source2: ffserver.sysconfig
38cf6de3 36Source3: ffserver.conf
0b43f655 37Patch0: %{name}-bug-803.patch
3a7b84be 38Patch1: %{name}-gsm.patch
85f7cea1 39URL: http://www.ffmpeg.org/
2a60eebe 40BuildRequires: SDL-devel
cbdd2688 41BuildRequires: alsa-lib-devel
38cefaee 42BuildRequires: bzip2-devel
9f9ba8ac 43BuildRequires: celt-devel >= 0.11.0
7ca51e4c 44BuildRequires: dirac-devel >= 1.0.0
38cefaee 45%{?with_nonfree:BuildRequires: faac-devel}
2a60eebe 46BuildRequires: freetype-devel
d7a39558 47%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
48%ifarch ppc
49# require version with altivec support fixed
50BuildRequires: gcc >= 5:3.3.2-3
51%endif
cbdd2688
JB
52BuildRequires: jack-audio-connection-kit-devel
53BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 54%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
6382c99d 55BuildRequires: libdc1394-devel
f1669449 56BuildRequires: libgsm-devel
4a927f9d 57BuildRequires: libnut-devel
7571bfa0 58BuildRequires: libraw1394-devel >= 2
cbdd2688 59BuildRequires: librtmp-devel
9042663c 60BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 61BuildRequires: libtool >= 2:1.4d-3
64f8f109 62%{?with_va:BuildRequires: libva-devel >= 1.0.3}
0b43f655 63BuildRequires: libvdpau-devel
e380e18a 64BuildRequires: libvorbis-devel
065be88e 65%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
66# X264_BUILD >= 118
67%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
0b43f655 68BuildRequires: opencore-amr-devel
192f9f57 69%{?with_opencv:BuildRequires: opencv-devel}
0b43f655 70BuildRequires: openjpeg-devel >= 1.3-2
17a2d1a8 71BuildRequires: speex-devel >= 1:1.2-rc1
e1fe03f7 72%ifarch %{ix86}
73%ifnarch i386 i486
76243dbd
JB
74BuildRequires: nasm
75%endif
e1fe03f7 76%endif
136f0f45 77BuildRequires: perl-Encode
1463656a 78BuildRequires: perl-tools-pod
ef3c0513 79BuildRequires: pkgconfig
db8052c8 80BuildRequires: rpmbuild(macros) >= 1.470
126fb805 81BuildRequires: schroedinger-devel
64f8f109
ER
82%{?with_doc:BuildRequires: tetex}
83%{?with_doc:BuildRequires: texi2html}
84%{?with_doc:BuildRequires: texinfo}
5dc039cb
JB
85BuildRequires: vo-aacenc-devel
86BuildRequires: vo-amrwbenc-devel
87BuildRequires: xavs-devel
cbdd2688
JB
88BuildRequires: xorg-lib-libXext-devel
89BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 90BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 91BuildRequires: zlib-devel
57ebb8ad 92%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 93Requires: %{name}-libs = %{version}-%{release}
839e806f 94Requires: xvid >= 1:1.1.0
af49d6ab 95Obsoletes: libpostproc
539b540f 96BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 97
2a60eebe
JB
98%define _noautoreqdep libGL.so.1 libGLU.so.1
99
c01d7857
PS
100%define specflags -fno-strict-aliasing
101
102# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
103%define specflags_ia32 -fomit-frame-pointer
104# -mmmx is needed to enable <mmintrin.h> code.
105%define specflags_i586 -mmmx
106%define specflags_i686 -mmmx
1162803a 107%define specflags_ppc -fPIC
c01d7857 108
9fc4ad22 109%description
85f7cea1
ER
110FFmpeg is a complete solution to record, convert and stream audio and
111video. It is a command line tool to convert one video file format to
112another. It also supports grabbing and encoding in real time from a TV
113card.
9fc4ad22 114
cdb7b42e 115%description -l pl.UTF-8
cbdd2688
JB
116FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
117strumieni dźwięku i obrazu. Jest to działające z linii poleceń
118narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
119także przechwytywanie i kodowanie w czasie rzeczywistym z karty
120telewizyjnej.
9fc4ad22 121
54ec280e
PG
122%package libs
123Summary: ffmpeg libraries
adcc0f76 124Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
125Group: Libraries
126
127%description libs
cbdd2688
JB
128This package contains the ffmpeg shared libraries:
129- the codec library (libavcodec). It supports most existing encoding
130 formats (MPEG, DivX, MPEG4, AC3, DV...),
131- demuxer library (libavformat). It supports most existing file
132 formats (AVI, MPEG, OGG, Matroska, ASF...),
133- video postprocessing library (libpostproc).
54ec280e 134
cdb7b42e 135%description libs -l pl.UTF-8
cbdd2688
JB
136Ten pakiet zawiera biblioteki współdzielone ffmpeg:
137- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
138 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
139- bibliotekę demuksera (libavformat); obsługuje większość istniejących
140 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
141- bibliotekę postprocessingu (libpostproc).
54ec280e 142
af49d6ab
JB
143%package devel
144Summary: ffmpeg header files
adcc0f76 145Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 146Group: Development/Libraries
54ec280e 147Requires: %{name}-libs = %{version}-%{release}
38cefaee
JB
148# Libs.private from *.pc (unreasonably they are all the same)
149Requires: SDL-devel
150Requires: alsa-lib-devel
151Requires: bzip2-devel
152Requires: celt-devel
153Requires: dirac-devel >= 1.0.0
154%{?with_nonfree:Requires: faac-devel}
155Requires: jack-audio-connection-kit-devel
156Requires: lame-libs-devel >= 3.98.3
157Requires: libdc1394-devel
bf479bc6 158Requires: libgsm-devel
4a927f9d 159Requires: libnut-devel
7571bfa0 160Requires: libraw1394-devel >= 2
38cefaee
JB
161Requires: librtmp-devel
162Requires: libtheora-devel >= 1.0-0.beta3
163%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 164Requires: libvorbis-devel
38cefaee 165%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 166%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee
JB
167Requires: opencore-amr-devel
168Requires: openjpeg-devel >= 1.3-2
169Requires: schroedinger-devel
170Requires: speex-devel >= 1:1.2-rc1
171Requires: vo-aacenc-devel
172Requires: vo-amrwbenc-devel
173Requires: xavs-devel
174Requires: xorg-lib-libXext-devel
175Requires: xorg-lib-libXfixes-devel
46f2a56b 176Requires: xvid-devel >= 1:1.1.0
33a1c0f3 177Requires: zlib-devel
8152d6a2 178Obsoletes: libpostproc-devel
af49d6ab
JB
179
180%description devel
181ffmpeg header files.
182
cdb7b42e
JR
183%description devel -l pl.UTF-8
184Pliki nagłówkowe ffmpeg.
af49d6ab
JB
185
186%package static
187Summary: ffmpeg static libraries
adcc0f76 188Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
189Group: Development/Libraries
190Requires: %{name}-devel = %{version}-%{release}
191
192%description static
193ffmpeg static libraries (libavcodec and libavformat).
194
cdb7b42e 195%description static -l pl.UTF-8
af49d6ab
JB
196Statyczne biblioteki ffmpeg (libavcodec i libavformat).
197
2a60eebe
JB
198%package ffplay
199Summary: FFplay - SDL-based media player
adcc0f76 200Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 201Group: Applications/Multimedia
54ec280e 202Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
203
204%description ffplay
205FFplay is a very simple and portable media player using the FFmpeg
206libraries and the SDL library. It is mostly used as a test bench for
207the various APIs of FFmpeg.
208
cdb7b42e
JR
209%description ffplay -l pl.UTF-8
210FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
211bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
212testowania różnych API FFmpeg.
2a60eebe 213
fde29260
ER
214%package ffserver
215Summary: FFserver video server
adcc0f76 216Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 217Group: Daemons
593d3a64 218Requires(post,preun): /sbin/chkconfig
67103923 219Requires: %{name}-libs = %{version}-%{release}
2305d791 220Requires: rc-scripts >= 0.4.0.10
fde29260
ER
221
222%description ffserver
223FFserver is a streaming server for both audio and video. It supports
224several live feeds, streaming from files and time shifting on live
225feeds (you can seek to positions in the past on each live feed,
226provided you specify a big enough feed storage in ffserver.conf).
227
cdb7b42e
JR
228%description ffserver -l pl.UTF-8
229FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
230źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
231czasie dla źródeł na żywo (można przeskakiwać na położenia w
232przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
233dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 234
9fc4ad22 235%prep
aed8e8c9 236%setup -q
f1669449 237%patch0 -p1
3a7b84be 238%patch1 -p0
9fc4ad22 239
9d4f8977
ER
240# package the grep result for mplayer, the result formatted as ./mplayer/configure
241cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
242#! /bin/sh
243_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
244_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
245_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
246_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
247_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
248_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
249_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
250EOF
9d4f8977 251cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
252
253case "$1" in
254--decoders)
255 echo $_libavdecoders_all
256 ;;
257--encoders)
258 echo $_libavencoders_all
259 ;;
260--parsers)
261 echo $_libavparsers_all
262 ;;
263--bsfs)
264 echo $_libavbsfs_all
265 ;;
266--demuxers)
267 echo $_libavdemuxers_all
268 ;;
269--muxers)
270 echo $_libavmuxers_all
271 ;;
272--protocols)
273 echo $_libavprotocols_all
274 ;;
275*)
276 cat <<USAGE
277Usage: $0 [OPTION]
278Options:
279 --decoders
280 --encoders
281 --parsers
282 --bsfs
283 --demuxers
284 --muxers
285 --protocols
286USAGE
287 exit 1;;
288esac
289
290exit 0
291EOF
292
9fc4ad22 293%build
05e1eb2f
JB
294# notes:
295# - it's not autoconf configure
d0a0ec26 296# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 297./configure \
b4680d0b 298 --arch=%{_target_base_arch} \
539b540f 299 --prefix=%{_prefix} \
9cf4d8a4 300 --libdir=%{_libdir} \
d81dfa95 301 --shlibdir=%{_libdir} \
2a60eebe 302 --mandir=%{_mandir} \
126fb805 303 --cc="%{__cc}" \
314ef0df 304 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 305 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
126fb805
JB
306 --disable-debug \
307 --disable-optimizations \
6382c99d 308 --disable-stripping \
314ef0df 309 --enable-avfilter \
126fb805 310 --enable-gpl \
0b43f655 311 --enable-version3 \
d7a39558 312 %{?with_frei0r:--enable-frei0r} \
2e585b44 313 %{?with_aacplus:--enable-libaacplus} \
32243b76 314 --enable-libdc1394 \
cbdd2688 315 --enable-libcelt \
32243b76 316 --enable-libdirac \
f3692243 317 --enable-libgsm \
15c15700 318 --enable-libmp3lame \
4a927f9d 319 --enable-libnut \
cbdd2688
JB
320 --enable-libopencore-amrnb \
321 --enable-libopencore-amrwb \
192f9f57 322 %{?with_opencv:--enable-libopencv} \
cbdd2688
JB
323 --enable-libopenjpeg \
324 --enable-librtmp \
126fb805 325 --enable-libschroedinger \
da99dcf2 326 --enable-libspeex \
126fb805 327 --enable-libtheora \
5dc039cb
JB
328 --enable-libvo-aacenc \
329 --enable-libvo-amrwbenc \
126fb805 330 --enable-libvorbis \
64f8f109 331 %{?with_vpx:--enable-libvpx} \
ea09f25d 332 %{?with_x264:--enable-libx264} \
5dc039cb 333 --enable-libxavs \
126fb805 334 --enable-libxvid \
6382c99d 335 --enable-postproc \
d7493de8 336 --enable-pthreads \
9cf4d8a4 337 --enable-shared \
6382c99d 338 --enable-swscale \
0b43f655 339 --enable-vdpau \
75231f25 340 --enable-x11grab \
7a286645 341%ifnarch %{ix86} %{x8664}
e1fe03f7 342 --disable-mmx \
343%endif
344%ifarch i386 i486
05e1eb2f 345 --disable-mmx \
b524cd99 346%endif
0b43f655 347%if %{with nonfree}
48610c64 348 --enable-nonfree \
0b43f655 349 --enable-libfaac \
76243dbd 350%endif
75231f25 351 --enable-runtime-cpudetect
2305d791 352
da99dcf2 353# force oldscaler build
b8c60172 354%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 355
1ef27ea1
JB
356%{__make} \
357 V=1
9fc4ad22 358
b8c60172
ER
359# CC_O to add -c to commandline. makefile should be patched
360%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
361
9fc4ad22
AM
362%install
363rm -rf $RPM_BUILD_ROOT
38cf6de3 364install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 365 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 366 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 367
539b540f 368%{__make} install \
1ef27ea1
JB
369 DESTDIR=$RPM_BUILD_ROOT \
370 V=1
539b540f 371
544421b2
ER
372cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
373cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
374cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
375cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
376cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
377for a in libavutil/*/bswap.h; do
378 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
379done
9d4f8977
ER
380cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
381cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
382# for lim-omx ffmpeg components
383cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 384
b8c60172
ER
385install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
386cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
387cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 388mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 389install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 390
2b2445b7
ER
391# install as ffmpeg-avconfig to avoid with possible programs looking for
392# ffmpeg-config and expecting --libs output from it which is not implemented
393# simple to do (by querying pkgconfig), but why?
b8c60172 394install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 395
9fc4ad22
AM
396%clean
397rm -rf $RPM_BUILD_ROOT
398
1ef27ea1
JB
399%post libs -p /sbin/ldconfig
400%postun libs -p /sbin/ldconfig
539b540f 401
38cf6de3
ER
402%pre ffserver
403%groupadd -g 167 ffserver
404%useradd -g ffserver -u 167 ffserver
405
593d3a64
ER
406%post ffserver
407/sbin/chkconfig --add ffserver
408%service ffserver restart
409
38cf6de3 410%preun ffserver
593d3a64
ER
411if [ "$1" = 0 ]; then
412 %service ffserver stop
413 /sbin/chkconfig --del ffserver
414fi
415
38cf6de3
ER
416%postun ffserver
417if [ "$1" = 0 ]; then
418 %userremove ffserver
419 %groupremove ffserver
420fi
421
9fc4ad22
AM
422%files
423%defattr(644,root,root,755)
660918c5
AM
424%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
425%attr(755,root,root) %{_bindir}/avconv
2a60eebe 426%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 427%attr(755,root,root) %{_bindir}/ffprobe
b7313442 428%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
429%dir %{_datadir}/ffmpeg
430%{_datadir}/ffmpeg/*.ffpreset
660918c5 431%{?with_doc:%{_mandir}/man1/avconv.1*}
64f8f109
ER
432%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
433%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
434
435%files libs
436%defattr(644,root,root,755)
f50f7d7c 437%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
cbdd2688 438%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.53
d0a0ec26 439%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
cbdd2688 440%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.53
314ef0df 441%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
cbdd2688 442%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.2
f50f7d7c 443%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
cbdd2688 444%attr(755,root,root) %ghost %{_libdir}/libavformat.so.53
f50f7d7c 445%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 446%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 447%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
314ef0df 448%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.51
660918c5
AM
449%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
450%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 451%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 452%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 453
539b540f
JB
454%files devel
455%defattr(644,root,root,755)
54ec280e 456%doc doc/optimization.txt
1ef27ea1 457%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 458%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 459%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 460%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 461%attr(755,root,root) %{_libdir}/libavformat.so
d7493de8 462%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 463%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 464%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 465%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 466%{_includedir}/ffmpeg
6382c99d
AM
467%{_includedir}/libavcodec
468%{_includedir}/libavdevice
314ef0df 469%{_includedir}/libavfilter
6382c99d
AM
470%{_includedir}/libavformat
471%{_includedir}/libavutil
472%{_includedir}/libpostproc
660918c5 473%{_includedir}/libswresample
6382c99d 474%{_includedir}/libswscale
1ef27ea1
JB
475%{_pkgconfigdir}/libavcodec.pc
476%{_pkgconfigdir}/libavdevice.pc
477%{_pkgconfigdir}/libavfilter.pc
478%{_pkgconfigdir}/libavformat.pc
479%{_pkgconfigdir}/libavutil.pc
480%{_pkgconfigdir}/libpostproc.pc
660918c5 481%{_pkgconfigdir}/libswresample.pc
1ef27ea1 482%{_pkgconfigdir}/libswscale.pc
539b540f 483
9cf4d8a4
JB
484%files static
485%defattr(644,root,root,755)
1ef27ea1
JB
486%{_libdir}/libavcodec.a
487%{_libdir}/libavdevice.a
488%{_libdir}/libavfilter.a
489%{_libdir}/libavformat.a
490%{_libdir}/libavutil.a
491%{_libdir}/libpostproc.a
660918c5 492%{_libdir}/libswresample.a
1ef27ea1 493%{_libdir}/libswscale.a
af49d6ab
JB
494
495%files ffplay
496%defattr(644,root,root,755)
497%attr(755,root,root) %{_bindir}/ffplay
64f8f109 498%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 499
fde29260
ER
500%files ffserver
501%defattr(644,root,root,755)
502%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
503%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
504%attr(755,root,root) %{_sbindir}/ffserver
505%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 506%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
507%dir %attr(770,root,ffserver) /var/cache/ffserver
508%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.139899 seconds and 4 git commands to generate.