]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- up to 2.8.11.1
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
1fbe3ed6 10%bcond_without tests
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
1fbe3ed6
AM
15Version: 2.8.11.1
16Release: 1
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
28f0bd6c 19Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
1fbe3ed6 20# Source0-md5: df5324a3b203373a9e0a04b924281a43
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
fe667d6f 23Patch2: cmake-findruby.patch
a315a797 24URL: http://www.cmake.org/
33042d59 25%{?with_gui:BuildRequires: QtGui-devel}
fef12180 26BuildRequires: libarchive-devel
ece9e155 27BuildRequires: libstdc++-devel
59917d1a 28BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
29%{?with_gui:BuildRequires: qt4-build}
30%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 31BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 32%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 33Requires: filesystem >= 3.0-52
efafbc62 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
35
36%description
efafbc62
AG
37CMake is used to control the software compilation process using simple
38platform and compiler independent configuration files. CMake generates
39native makefiles and workspaces that can be used in the compiler
40environment of your choice. CMake is quite sophisticated: it is
41possible to support complex environments requiring system
42configuration, pre-processor generation, code generation, and template
43instantiation.
3fcbc09a 44
520c9eb8
JR
45%description -l pl.UTF-8
46CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 47użyciu prostych plików konfiguracyjnych niezależnych od platformy i
48kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 49których można używać w wybranym środowisku kompilatora. CMake jest
59787775 50dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 51konfiguracji systemu, generowanie preprocesora, generowanie kodu i
52dziedziczenie szablonów.
33042d59
KK
53
54%package gui
b563f9dc
JB
55Summary: Qt GUI for CMake
56Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
57Group: Development/Tools
58Requires: %{name} = %{version}-%{release}
59
b563f9dc
JB
60%description gui
61This package contains the Qt based GUI for CMake.
62
63%description gui -l pl.UTF-8
64Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
65CMake.
72a696fa 66
9ec4f08d 67%package emacs
69d19c08
JB
68Summary: Emacs mode for cmake files
69Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
70Group: Development/Tools
71
72%description emacs
69d19c08
JB
73Emacs mode for cmake files.
74
75%description emacs -l pl.UTF-8
76Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
77
78%package -n bash-completion-%{name}
79Summary: bash-completion for cmake
69d19c08 80Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 81Group: Applications/Shells
69d19c08 82Requires: %{name} = %{version}-%{release}
9ec4f08d
KK
83
84%description -n bash-completion-%{name}
69d19c08
JB
85bash-completion for cmake.
86
87%description -n bash-completion-%{name} -l pl.UTF-8
88Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 89
3fcbc09a 90%prep
923851a2 91%setup -q
286b1479 92%if "%{_lib}" == "lib64"
6342daf8 93%patch0 -p1
286b1479 94%endif
9ec4f08d 95%patch1 -p1
fe667d6f 96%patch2 -p1
3fcbc09a 97
ece9e155 98cat > "init.cmake" <<EOF
286b1479 99SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
100SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
101SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
102EOF
103
3fcbc09a 104%build
ece9e155
KK
105export CC="%{__cc}"
106export CXX="%{__cxx}"
107export CFLAGS="%{rpmcflags}"
108export CXXFLAGS="%{rpmcxxflags}"
ccca321d 109export LDFLAGS="%{rpmldflags}"
923851a2
AG
110./bootstrap \
111 --prefix=%{_prefix} \
112 --mandir=/share/man \
113 --datadir=/share/cmake \
ece9e155 114 --init=init.cmake \
c342f103 115 %{!?with_bootstrap:--system-libs} \
33042d59 116 %{?with_gui:--qt-gui} \
08bb5e07 117 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
118 --verbose
119
28f0bd6c 120%{__make} VERBOSE=1
3fcbc09a 121
1fbe3ed6
AM
122%{?with_tests:%{__make} test}
123
3fcbc09a 124%install
efafbc62 125rm -rf $RPM_BUILD_ROOT
72a696fa
JB
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
75cb386f 129%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%files
efafbc62 135%defattr(644,root,root,755)
51ed65c6 136%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
137%attr(755,root,root) %{_bindir}/ccmake
138%attr(755,root,root) %{_bindir}/cmake
08b6790a 139%attr(755,root,root) %{_bindir}/cpack
72a696fa 140%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
141%{_mandir}/man1/ccmake.1*
142%{_mandir}/man1/cmake.1*
143%{_mandir}/man1/cmakecommands.1*
144%{_mandir}/man1/cmakecompat.1*
145%{_mandir}/man1/cmakemodules.1*
146%{_mandir}/man1/cmakepolicies.1*
147%{_mandir}/man1/cmakeprops.1*
148%{_mandir}/man1/cmakevars.1*
149%{_mandir}/man1/cpack.1*
150%{_mandir}/man1/ctest.1*
b24a2e64
JB
151# top cmake/Modules dirs belong to filesystem
152%{_datadir}/cmake/Modules/.NoDartCoverage
153%{_datadir}/cmake/Modules/*
154%{_datadir}/cmake/Templates
f13d1e41 155%{_datadir}/cmake/editors
b24a2e64 156%{_datadir}/cmake/include
09f5d631 157%{_aclocaldir}/cmake.m4
33042d59 158
1a3a9dcd 159%if %{with gui}
33042d59
KK
160%files gui
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_bindir}/cmake-gui
163%{_datadir}/mime/packages/cmakecache.xml
164%{_desktopdir}/CMake.desktop
ca760f29 165%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 166%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 167%endif
9ec4f08d
KK
168
169%files emacs
170%defattr(644,root,root,755)
171%{_datadir}/emacs/site-lisp/cmake-mode.el
172
173%files -n bash-completion-%{name}
174%defattr(644,root,root,755)
69d19c08
JB
175/etc/bash_completion.d/cmake
176/etc/bash_completion.d/cpack
177/etc/bash_completion.d/ctest
This page took 0.061034 seconds and 4 git commands to generate.