]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
disable debuginfo on 32bit hosts
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
ba685303 21%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
22%bcond_without system_libexif # system libexif
23%bcond_without system_libmtp # system libmtp
3934d767 24%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 25%bcond_without system_libwebp # system libwebp
4884fc99 26%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 27%bcond_with system_mesa # system Mesa
126ea630 28%bcond_without system_minizip # system minizip
62950103 29%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 30%bcond_without system_protobuf # system protobuf
543e99ac 31%bcond_without system_re2 # system re2
7e634b46 32%bcond_without system_snappy # system snappy
ba685303 33%bcond_without system_speex # system speex
a8f4f3ac 34%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 35%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 36%bcond_with system_v8 # system v8
f047b07c 37%bcond_with system_libvpx # system libvpx
ba685303 38%bcond_without system_yasm # system yasm
1c00315b 39%bcond_without system_zlib # system zlib
14c8ce0e 40%bcond_with tcmalloc # use tcmalloc
7e136323 41%bcond_without verbose # verbose build (V=1)
0c480b89 42
b3fc6cb2
ER
43%ifarch %{ix86}
44# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
45%undefine with_system_mesa
5e3c5baa
ER
46
47# unable build with debuginfo on 32bit build systems
48%undefine with_debuginfo
b3fc6cb2
ER
49%endif
50
6d92f81c 51# TODO
b363f856 52# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 53# - use_system_skia
a3140cd1 54# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 55# - use_system_stlport (android specific)
7b8f219a 56# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 57
e53ecfb5 58# NOTES:
4fe038cb
ER
59# - mute BEEP mixer if you do not want to hear horrible system bell when
60# pressing home/end in url bar or more ^F search results on page.
7c638678 61# - space considerations:
0bb93ab2 62# - unpacked sources: ~490MiB
c1ecd31f 63# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 64# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 65# - to look for new tarball, use update-source.sh script
f1b276d4 66
ebdea798
ER
67%define branch 38.0.2125
68%define basever 101
605f0a8d 69#define patchver 132
a3140cd1 70%define gyp_rev 1014
11ad81c4 71Summary: A WebKit powered web browser
05f72ae2 72Name: chromium-browser
f73369da
ER
73%if "%{?patchver}" != ""
74Version: %{branch}.%{patchver}
75%else
76Version: %{branch}.%{basever}
77%endif
d37862c1 78Release: 1
5bb99ef4 79License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 80Group: X11/Applications/Networking
f177fdad 81Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
9a540589 82# Source0-md5: f2ec6a50864d8b2ddcda0baef50e9c33
3c73e180
ER
83%if "%{?patchver}" != ""
84Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
c925a554 85# Patch0-md5: 4eafe1e64bd47a11dbfaf61a2dd50b6e
3c73e180 86%endif
37ceaf05 87Source1: %{name}.default
8b53130d
ER
88Source2: %{name}.sh
89Source3: %{name}.desktop
56c6e811
ER
90Source5: find-lang.sh
91Source6: update-source.sh
92Source7: clean-source.sh
836b1cac 93Source8: get-source.sh
0562b864 94Source9: master_preferences.json
627e6027 95Patch2: enable-video-decode-accel.patch
72cb20c1 96Patch4: path-libpdf.patch
5aa5df39 97Patch7: dlopen_sonamed_gl.patch
4765ddf1 98Patch8: chromium_useragent.patch.in
1347c76c
AM
99# https://bugs.gentoo.org/show_bug.cgi?id=393471
100# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 101Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
102Patch15: nacl-build-irt.patch
103Patch16: nacl-linkingfix.patch
9516ca97 104Patch18: nacl-no-untar.patch
6897926c 105Patch24: nacl-verbose.patch
c5b396f3
ER
106Patch25: gnome3-volume-control.patch
107Patch26: master-prefs-path.patch
25d4e23c 108Patch28: system-mesa.patch
e0a7fe40 109Patch30: system-ply.patch
9cce36cb 110Patch31: system-jinja.patch
708e64c2 111Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 112Patch35: etc-dir.patch
6e3c39b4 113Patch36: angle.patch
750b48f7 114URL: http://www.chromium.org/Home
ae3fe89f 115%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 116%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 117BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 118%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 119%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
120BuildRequires: alsa-lib-devel
121BuildRequires: atk-devel
122BuildRequires: bison
11ad81c4 123BuildRequires: bzip2-devel
5997e180
ER
124%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
125%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
126%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 127%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 128%{?with_cups:BuildRequires: cups-devel}
92965b0e 129BuildRequires: elfutils-devel
77f32fa3 130BuildRequires: expat-devel
7d0dbc8d 131%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 132%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 133BuildRequires: fontconfig-devel
f1b276d4 134BuildRequires: glib2-devel
05f72ae2 135BuildRequires: gperf
71d49434 136%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 137BuildRequires: gtest-devel
8b53130d 138BuildRequires: gtk+2-devel
01b4dc8e 139%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 140%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 141%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 142BuildRequires: hicolor-icon-theme
ed514974 143%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 144%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 145BuildRequires: libevent-devel
8456d676 146%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 147%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 148BuildRequires: libicu-devel >= 4.6
39c71b4c 149%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 150%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 151%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 152BuildRequires: libpng-devel
e266589e 153%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 154BuildRequires: libstdc++-devel
ba685303 155%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
156%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
157%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 158BuildRequires: libxml2-devel
11ad81c4 159BuildRequires: libxslt-devel
535cb410 160BuildRequires: man-db
62950103 161%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 162%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 163BuildRequires: nspr-devel
f1b276d4 164BuildRequires: nss-devel >= 1:3.12.3
8456d676 165%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 166BuildRequires: pam-devel
f1b276d4 167BuildRequires: pango-devel
ef121064 168BuildRequires: pciutils-devel
3a3b7da9 169BuildRequires: perl-JSON
48b341f5 170BuildRequires: perl-modules
171BuildRequires: pkgconfig
75a27c2e 172%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 173%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 174BuildRequires: python
46cdefee 175#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 176BuildRequires: python-jinja2 >= 2.7
48b341f5 177BuildRequires: python-modules
e0a7fe40 178BuildRequires: python-ply >= 3.4
543e99ac 179%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 180BuildRequires: rpm >= 4.4.9-56
f1b276d4 181BuildRequires: rpmbuild(macros) >= 1.453
f099161f 182%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 183BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 184%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 185%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 186%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 187BuildRequires: tar >= 1:1.22
0a424ee2 188BuildRequires: udev-devel
7d1152d4 189BuildRequires: usbutils
2303ed45 190BuildRequires: util-linux
c14cd342 191%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 192BuildRequires: which
f1b276d4 193BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 194BuildRequires: xorg-lib-libXtst-devel
836b1cac 195BuildRequires: xz
a3140cd1 196%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 197%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 198Requires: browser-plugins >= 2.0
0cad051b 199Requires: desktop-file-utils
8f5f6775 200%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
201# crashes if no fontconfig font present
202Requires: fonts-Type1-urw
0eb19b0b 203Requires: hicolor-icon-theme
56403697 204Requires: libevent >= 2.0.21
c1edaafa 205%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 206%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 207Requires: lsb-release
b2c4ae39 208%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 209%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 210Requires: shared-mime-info
f7b16691 211%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 212Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 213Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 214Provides: wwwbrowser
c3582150 215Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 216Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 217ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 218BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 219
319f81f7
ER
220# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
221# Note: these are for PLD Linux use ONLY.
222# For your own distribution, please get your own set of keys.
223%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
224%define google_default_client_id 724288223830.apps.googleusercontent.com
225%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
226
7ebeabb6 227%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 228
e7fa0817
ER
229# Usage: gyp_with BCOND_NAME [OPTION_NAME]
230%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 231
a323900c
ER
232%ifarch %{ix86}
233%define target_arch ia32
234%endif
235%ifarch %{x8664}
236%define target_arch x64
237%endif
238
f8597c6e
ER
239%define buildtype %{?debug:Debug}%{!?debug:Release}
240%define builddir out/%{buildtype}
241
6b113615
ER
242%if %{without debuginfo}
243%define _enable_debug_packages 0
244%endif
245
11ad81c4 246%description
80838854
ER
247Chromium is an open-source browser project that aims to build a safer,
248faster, and more stable way for all Internet users to experience the
249web.
250
251Chromium serves as a base for Google Chrome, which is Chromium
252rebranded (name and logo) with very few additions such as usage
253tracking and an auto-updater system.
254
f1b276d4
ER
255%package l10n
256Summary: chromium-browser language packages
257Group: I18n
258Requires: %{name} = %{version}-%{release}
8da7b90b
ER
259%if "%{_rpmversion}" >= "5"
260BuildArch: noarch
261%endif
f1b276d4
ER
262
263%description l10n
264Chromium is an open-source browser project that aims to build a safer,
265faster, and more stable way for all Internet users to experience the
266web.
267
268This package contains language packages for 50 languages:
269
e7fa0817
ER
270ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
271he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
272pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
273zh-TW
f1b276d4
ER
274
275%prep
3c73e180
ER
276%setup -qc
277%if "%{?patchver}" != ""
77bd7e0a 278cd chromium*-%{branch}.%{basever}
3c73e180
ER
279%patch0 -p1
280cd ..
281%endif
77bd7e0a 282mv chromium*-%{branch}.%{basever}/* .
589d90ea 283
05f72ae2
ER
284# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
285# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 286. ./chrome/VERSION
e00e4177
ER
287chrome=$MAJOR.$MINOR.$BUILD.$PATCH
288test "$chrome" = %{version}
a3140cd1 289
75f96a39 290gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 291test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 292
4765ddf1
ER
293# add chromium and pld to useragent
294%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
295sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
296 -e 's/@BUILD_DIST_NAME@/PLD/g' \
297 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 298 < %{PATCH8} | %{__patch} -p1
4765ddf1 299
8da7b90b 300%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
301ln -s %{SOURCE7} .
302
12dc0aee 303#%patch2 -p1 NOT COMPILING
75f96a39 304%patch4 -p3
7879021e 305%patch7 -p1
75f96a39 306%patch15 -p2
f4a8da6a 307%{!?with_libjpegturbo:%patch11 -p0}
5997e180 308%patch16 -p1
41d6a4b1 309%patch28 -p1
a323900c 310%patch25 -p1
3aa67e11 311%{?with_nacl:%patch18 -p1}
ffb05754 312%patch24 -p1
75f96a39 313%patch26 -p2
77bd7e0a
ER
314#%patch30 -p1
315#%patch31 -p0
708e64c2 316%patch32 -p1
d7fca4aa 317%patch35 -p1
6e3c39b4 318%patch36 -p1
e9abb380 319
f684992e
ER
320%{?with_dev:exit 0}
321
75a27c2e
ER
322sh -x clean-source.sh \
323 %{!?with_nacl:nacl=0} \
bbdce24d
ER
324 %{!?with_system_libvpx:libvpx=0} \
325 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 326 %{!?with_system_mesa:mesa=0} \
75a27c2e 327 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 328 %{!?with_system_re2:re2=0} \
7e634b46 329 %{!?with_system_snappy:snappy=0} \
5048b37a 330 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 331 %{!?with_system_v8:v8=0} \
0767a7a0 332 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 333 %{!?with_system_zlib:zlib=0} \
f177fdad 334 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 335 %{nil}
fded59be 336
e266589e 337%build
5997e180 338%if %{with nacl}
108c5f7c 339rm -rf native_client/toolchain/linux_x86_newlib
fded59be 340if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 341# Make symlinks for NaCL
108c5f7c 342install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 343
108c5f7c
ER
344cd native_client/toolchain/linux_x86_newlib
345ln -s x86_64-nacl/bin bin
346cd x86_64-nacl/bin
2e4113fd 347__cc='%{__cc}'
f64e73f6 348if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
349 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
350 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
351 %{__sed} -i -e '1i#!/bin/sh' gcc g++
352 chmod +x gcc g++
353else
354 ln -s %{_bindir}/x86_64-nacl-gcc gcc
355 ln -s %{_bindir}/x86_64-nacl-g++ g++
356fi
108c5f7c
ER
357ln -s gcc x86_64-nacl-gcc
358ln -s g++ x86_64-nacl-g++
359ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
360ln -s %{_bindir}/x86_64-nacl-ar ar
361ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 362ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 363ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 364ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 365ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 366ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
367ln -s %{_prefix}/x86_64-nacl/lib ../lib
368ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
369ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
370cd ../../../../..
fded59be 371fi
5997e180
ER
372%endif
373
a323900c 374%if %{without system_ffmpeg}
f8597c6e
ER
375if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
376 # Re-configure bundled ffmpeg
377 cd third_party/ffmpeg
6e3c39b4 378 chromium/scripts/build_ffmpeg.py linux %{target_arch}
f8597c6e 379 chromium/scripts/copy_config.sh
6e3c39b4 380 chromium/scripts/generate_gyp.py
f8597c6e
ER
381 cd -
382fi
0c480b89 383%endif
a323900c 384
6e3c39b4
ER
385third_party/libaddressinput/chromium/tools/update-strings.py
386
a323900c
ER
387flags="
388 -Dtarget_arch=%{target_arch} \
389 -Dpython_arch=%{target_arch} \
6e3c39b4 390 -Dffmpeg_branding=Chromium \
b91ce587 391 -Dsystem_libdir=%{_lib} \
a323900c 392 -Dpython_ver=%{py_ver} \
7b454a31
AM
393%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
394 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 395%endif
f047b07c 396 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 397 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 398 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 399 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
77bd7e0a 400 -Dinclude_tests__=0 \
c0808220 401%if %{with nacl}
038f76b9 402 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
403 -Ddisable_glibc_untar=1 \
404 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
405 -Ddisable_glibc=1 \
406 -Ddisable_pnacl=1 \
407 -Dbuild_pnacl_newlib=0 \
c0808220 408%else
8fb1dc98 409 -Ddisable_pnacl_untar=1 \
c0808220
ER
410 -Ddisable_nacl=1 \
411%endif
a3140cd1
ER
412 %{!?with_sse2:-Ddisable_sse2=1} \
413 %{?with_selinux:-Dselinux=1} \
7d1152d4 414 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 415 -Dlinux_link_libpci=1 \
7879021e 416 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 417 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 418 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
419 -Dclang=0 \
420 -Dhost_clang=0 \
14c8ce0e
ER
421 -Dlinux_use_bundled_binutils=0 \
422 -Dlinux_use_bundled_gold=0 \
05998197 423 -Dlinux_use_gold_flags=0 \
71581184 424 -Dlogging_like_official_build=1 \
319f81f7
ER
425 -Dgoogle_api_key=%{google_api_key} \
426 -Dgoogle_default_client_id=%{google_default_client_id} \
427 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 428 %{gyp_with cups} \
8dda6bbc 429 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 430 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
431 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
432 %{gyp_with pulseaudio} \
41d6a4b1 433 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 434 %{gyp_with system_flac} \
01b4dc8e 435 %{gyp_with system_harfbuzz} \
2d65d095 436 %{gyp_with system_jsoncpp} \
62950103
ER
437 %{gyp_with system_libexif} \
438 %{gyp_with system_libmtp} \
9bd2659c 439 %{gyp_with system_libsrtp} \
581aec44 440 %{gyp_with system_libusb} \
88171dca 441 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 442 %{gyp_with system_libwebp} \
4884fc99 443 %{gyp_with system_libxnvctrl} \
7b8f219a 444 %{gyp_with system_mesa} \
126ea630 445 %{gyp_with system_minizip} \
62950103 446 %{gyp_with system_opus} \
75a27c2e 447 %{gyp_with system_protobuf} \
bbdce24d 448 %{gyp_with system_re2} \
7e634b46 449 %{gyp_with system_snappy} \
e7fa0817 450 %{gyp_with system_speex} \
914ee37c 451 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
452 %{gyp_with system_v8} \
453 %{gyp_with system_yasm} \
454 %{gyp_with system_zlib} \
0c480b89 455 -Duse_system_bzip2=1 \
62950103 456 -Duse_system_expat=1 \
5e64e51b 457 -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
f1b276d4 458 -Duse_system_libevent=1 \
0c480b89 459 -Duse_system_libjpeg=1 \
f1b276d4
ER
460 -Duse_system_libpng=1 \
461 -Duse_system_libxml=1 \
462 -Duse_system_libxslt=1 \
b363f856 463 -Duse_system_nspr=1 \
7f40f3f4 464 -Duse_system_xdg_utils=1 \
7879021e
ER
465"
466
467build/linux/unbundle/replace_gyp_files.py $flags
468
f8597c6e
ER
469%if %{with ninja}
470chkfile=%{builddir}/build.ninja
471%else
472chkfile=Makefile
473%endif
474test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
475test -e $chkfile || \
7879021e
ER
476 CC="%{__cc}" \
477 CXX="%{__cxx}" \
478 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
479 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
480 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
481 CC_host="%{__cc}" \
482 CXX_host="%{__cxx}" \
483 LD_host="%{__cxx}" \
484%{__python} build/gyp_chromium \
f8597c6e 485 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
486 --depth=. \
487 build/all.gyp \
488 $flags
11ad81c4 489
f8597c6e
ER
490%if %{with ninja}
491ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
492%else
b4d75247 493# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
494%{__make} -r \
495 BUILDTYPE=%{buildtype} \
f1b276d4 496 %{?with_verbose:V=1} \
f1b276d4
ER
497 CC.host="%{__cc}" \
498 CXX.host="%{__cxx}" \
b4d75247 499 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
500%endif
501 chrome %{?with_sandboxing:chrome_sandbox} \
502 %{nil}
11ad81c4 503
f8597c6e 504cd %{builddir}
535cb410
ER
505MANWIDTH=80 man ./chrome.1 > man.out
506%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
507
11ad81c4
AM
508%install
509rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
510install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
511 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
512 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
513 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 514
f8597c6e 515cd %{builddir}
37ceaf05 516cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 517install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
518%{__sed} -i -e '
519 s,@libdir@,%{_libdir}/%{name},
520
521 /@OPTIONS@/ {
522 r options.txt
523 d
524 }
525' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 526cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
c925a554 527cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
528ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
529ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 530cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 531install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 532install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 533%if %{without system_ffmpeg}
f1b276d4 534install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 535%endif
6e3c39b4 536install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
e7fa0817 537cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 538cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 539
8da7b90b 540%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 541
164020eb
ER
542%if %{with nacl}
543# Install Native Client files on platforms that support it.
544install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
545install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
546%ifarch %{x8664}
547install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
548%endif
549%ifarch %{ix86}
550install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
551%endif
552%endif
553
0c480b89
ER
554cd -
555
75f96a39 556for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
557 size=${icon##*/product_logo_}
558 size=${size%.png}
559
560 # this will skip non-numeric (22_mono_invert, 22_mono)
561 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
562 test -d "$dir" || continue
563
564 install -d $RPM_BUILD_ROOT$dir
565 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
566done
7f40f3f4 567
13840bc2
AM
568%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
569# http://code.google.com/p/chromium/issues/detail?id=24507
570gecko-mediaplayer*.so
571EOF
11ad81c4 572
589d90ea
ER
573# find locales
574%find_lang %{name}.lang
e7fa0817 575# always package en-US
f1b276d4 576%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 577
11ad81c4
AM
578%clean
579rm -rf $RPM_BUILD_ROOT
580
8da7b90b
ER
581%pretrans
582for d in locales resources; do
583 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
584 install -d %{_datadir}/%{name}
585 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
586 fi
587done
588exit 0
589
f1b276d4 590%post
0eb19b0b 591%update_icon_cache hicolor
b7a6e4ee 592%update_desktop_database
f1b276d4
ER
593%update_browser_plugins
594
595%postun
596if [ "$1" = 0 ]; then
0eb19b0b 597 %update_icon_cache hicolor
f1b276d4
ER
598 %update_browser_plugins
599fi
600
1d2b9616 601%files
11ad81c4 602%defattr(644,root,root,755)
75f96a39 603%doc AUTHORS LICENSE
f1b276d4
ER
604%{_browserpluginsconfdir}/browsers.d/%{name}.*
605%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
606%dir %{_sysconfdir}/%{name}
607%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 608%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
609%dir %{_sysconfdir}/%{name}/native-messaging-hosts
610%dir %{_sysconfdir}/%{name}/policies
611%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
612%attr(755,root,root) %{_bindir}/%{name}
613%{_mandir}/man1/%{name}.1*
11ad81c4 614%{_desktopdir}/*.desktop
0eb19b0b 615%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 616%dir %{_libdir}/%{name}
e9abb380 617%{_libdir}/%{name}/chrome*.pak
c14cd342 618%{_libdir}/%{name}/content_resources.pak
f047b07c 619%{_libdir}/%{name}/keyboard_resources.pak
97fac491 620%{_libdir}/%{name}/resources.pak
8da7b90b
ER
621%{_libdir}/%{name}/locales
622%{_libdir}/%{name}/resources
623
4b5c45ee
ER
624# conflicts with browser-plugin-chrome-pdf?
625%attr(755,root,root) %{_libdir}/%{name}/libpdf.so
626
8da7b90b
ER
627%dir %{_datadir}/%{name}
628%dir %{_datadir}/%{name}/locales
629%{_datadir}/%{name}/locales/en-US.pak
630%dir %{_datadir}/%{name}/resources
631%{_datadir}/%{name}/resources/inspector
632
f1b276d4
ER
633%dir %{_libdir}/%{name}/plugins
634%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 635# These unique permissions are intentional and necessary for the sandboxing
d1a83042 636%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
637
638# ffmpeg libs
fcc48c19 639%if %{without system_ffmpeg}
f1b276d4 640%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 641%endif
f1b276d4 642
164020eb
ER
643%if %{with nacl}
644%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
645%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
646%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
647%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
648%endif
649
f1b276d4
ER
650%files l10n -f %{name}.lang
651%defattr(644,root,root,755)
This page took 0.188441 seconds and 4 git commands to generate.