]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 38.0.2125.104
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
ba685303 21%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
22%bcond_without system_libexif # system libexif
23%bcond_without system_libmtp # system libmtp
3934d767 24%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 25%bcond_without system_libwebp # system libwebp
4884fc99 26%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 27%bcond_with system_mesa # system Mesa
126ea630 28%bcond_without system_minizip # system minizip
62950103 29%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 30%bcond_without system_protobuf # system protobuf
543e99ac 31%bcond_without system_re2 # system re2
7e634b46 32%bcond_without system_snappy # system snappy
ba685303 33%bcond_without system_speex # system speex
a8f4f3ac 34%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 35%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 36%bcond_with system_v8 # system v8
f047b07c 37%bcond_with system_libvpx # system libvpx
ba685303 38%bcond_without system_yasm # system yasm
1c00315b 39%bcond_without system_zlib # system zlib
14c8ce0e 40%bcond_with tcmalloc # use tcmalloc
7e136323 41%bcond_without verbose # verbose build (V=1)
0c480b89 42
b3fc6cb2
ER
43%ifarch %{ix86}
44# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
45%undefine with_system_mesa
5e3c5baa
ER
46
47# unable build with debuginfo on 32bit build systems
313715ac
ER
48# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
49%undefine with_debuginfo
50%endif
51
52%ifarch %{x8664}
53# x86_64 systems fail with debugedit crashing
54# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 55%undefine with_debuginfo
b3fc6cb2
ER
56%endif
57
6d92f81c 58# TODO
b363f856 59# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 60# - use_system_skia
a3140cd1 61# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 62# - use_system_stlport (android specific)
7b8f219a 63# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 64
e53ecfb5 65# NOTES:
4fe038cb
ER
66# - mute BEEP mixer if you do not want to hear horrible system bell when
67# pressing home/end in url bar or more ^F search results on page.
7c638678 68# - space considerations:
0bb93ab2 69# - unpacked sources: ~490MiB
c1ecd31f 70# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 71# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 72# - to look for new tarball, use update-source.sh script
f1b276d4 73
ebdea798
ER
74%define branch 38.0.2125
75%define basever 101
50d701c6 76%define patchver 104
a3140cd1 77%define gyp_rev 1014
11ad81c4 78Summary: A WebKit powered web browser
05f72ae2 79Name: chromium-browser
f73369da
ER
80%if "%{?patchver}" != ""
81Version: %{branch}.%{patchver}
82%else
83Version: %{branch}.%{basever}
84%endif
d37862c1 85Release: 1
5bb99ef4 86License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 87Group: X11/Applications/Networking
f177fdad 88Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
9a540589 89# Source0-md5: f2ec6a50864d8b2ddcda0baef50e9c33
3c73e180
ER
90%if "%{?patchver}" != ""
91Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
50d701c6 92# Patch0-md5: 0d734cfd35874b4c25b1a762a648e9b6
3c73e180 93%endif
37ceaf05 94Source1: %{name}.default
8b53130d
ER
95Source2: %{name}.sh
96Source3: %{name}.desktop
56c6e811
ER
97Source5: find-lang.sh
98Source6: update-source.sh
99Source7: clean-source.sh
836b1cac 100Source8: get-source.sh
0562b864 101Source9: master_preferences.json
627e6027 102Patch2: enable-video-decode-accel.patch
72cb20c1 103Patch4: path-libpdf.patch
5aa5df39 104Patch7: dlopen_sonamed_gl.patch
4765ddf1 105Patch8: chromium_useragent.patch.in
1347c76c
AM
106# https://bugs.gentoo.org/show_bug.cgi?id=393471
107# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 108Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
109Patch15: nacl-build-irt.patch
110Patch16: nacl-linkingfix.patch
9516ca97 111Patch18: nacl-no-untar.patch
6897926c 112Patch24: nacl-verbose.patch
c5b396f3
ER
113Patch25: gnome3-volume-control.patch
114Patch26: master-prefs-path.patch
25d4e23c 115Patch28: system-mesa.patch
e0a7fe40 116Patch30: system-ply.patch
9cce36cb 117Patch31: system-jinja.patch
708e64c2 118Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 119Patch35: etc-dir.patch
6e3c39b4 120Patch36: angle.patch
750b48f7 121URL: http://www.chromium.org/Home
ae3fe89f 122%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 123%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 124BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 125%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 126%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
127BuildRequires: alsa-lib-devel
128BuildRequires: atk-devel
129BuildRequires: bison
11ad81c4 130BuildRequires: bzip2-devel
5997e180
ER
131%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
132%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
133%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 134%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 135%{?with_cups:BuildRequires: cups-devel}
92965b0e 136BuildRequires: elfutils-devel
77f32fa3 137BuildRequires: expat-devel
7d0dbc8d 138%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 139%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 140BuildRequires: fontconfig-devel
f1b276d4 141BuildRequires: glib2-devel
05f72ae2 142BuildRequires: gperf
71d49434 143%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 144BuildRequires: gtest-devel
8b53130d 145BuildRequires: gtk+2-devel
01b4dc8e 146%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 147%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 148%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 149BuildRequires: hicolor-icon-theme
ed514974 150%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 151%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 152BuildRequires: libevent-devel
8456d676 153%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 154%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 155BuildRequires: libicu-devel >= 4.6
39c71b4c 156%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 157%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 158%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 159BuildRequires: libpng-devel
e266589e 160%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 161BuildRequires: libstdc++-devel
ba685303 162%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
163%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
164%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 165BuildRequires: libxml2-devel
11ad81c4 166BuildRequires: libxslt-devel
535cb410 167BuildRequires: man-db
62950103 168%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 169%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 170BuildRequires: nspr-devel
f1b276d4 171BuildRequires: nss-devel >= 1:3.12.3
8456d676 172%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 173BuildRequires: pam-devel
f1b276d4 174BuildRequires: pango-devel
ef121064 175BuildRequires: pciutils-devel
3a3b7da9 176BuildRequires: perl-JSON
48b341f5 177BuildRequires: perl-modules
178BuildRequires: pkgconfig
75a27c2e 179%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 180%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 181BuildRequires: python
46cdefee 182#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 183BuildRequires: python-jinja2 >= 2.7
48b341f5 184BuildRequires: python-modules
e0a7fe40 185BuildRequires: python-ply >= 3.4
543e99ac 186%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 187BuildRequires: rpm >= 4.4.9-56
f1b276d4 188BuildRequires: rpmbuild(macros) >= 1.453
f099161f 189%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 190BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 191%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 192%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 193%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 194BuildRequires: tar >= 1:1.22
0a424ee2 195BuildRequires: udev-devel
7d1152d4 196BuildRequires: usbutils
2303ed45 197BuildRequires: util-linux
c14cd342 198%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 199BuildRequires: which
f1b276d4 200BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 201BuildRequires: xorg-lib-libXtst-devel
836b1cac 202BuildRequires: xz
a3140cd1 203%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 204%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 205Requires: browser-plugins >= 2.0
0cad051b 206Requires: desktop-file-utils
8f5f6775 207%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
208# crashes if no fontconfig font present
209Requires: fonts-Type1-urw
0eb19b0b 210Requires: hicolor-icon-theme
56403697 211Requires: libevent >= 2.0.21
c1edaafa 212%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 213%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 214Requires: lsb-release
b2c4ae39 215%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 216%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 217Requires: shared-mime-info
f7b16691 218%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 219Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 220Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 221Provides: wwwbrowser
c3582150 222Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 223Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 224ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 225BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 226
319f81f7
ER
227# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
228# Note: these are for PLD Linux use ONLY.
229# For your own distribution, please get your own set of keys.
230%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
231%define google_default_client_id 724288223830.apps.googleusercontent.com
232%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
233
7ebeabb6 234%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 235
e7fa0817
ER
236# Usage: gyp_with BCOND_NAME [OPTION_NAME]
237%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 238
a323900c
ER
239%ifarch %{ix86}
240%define target_arch ia32
241%endif
242%ifarch %{x8664}
243%define target_arch x64
244%endif
245
f8597c6e
ER
246%define buildtype %{?debug:Debug}%{!?debug:Release}
247%define builddir out/%{buildtype}
248
6b113615
ER
249%if %{without debuginfo}
250%define _enable_debug_packages 0
251%endif
252
11ad81c4 253%description
80838854
ER
254Chromium is an open-source browser project that aims to build a safer,
255faster, and more stable way for all Internet users to experience the
256web.
257
258Chromium serves as a base for Google Chrome, which is Chromium
259rebranded (name and logo) with very few additions such as usage
260tracking and an auto-updater system.
261
f1b276d4
ER
262%package l10n
263Summary: chromium-browser language packages
264Group: I18n
265Requires: %{name} = %{version}-%{release}
8da7b90b
ER
266%if "%{_rpmversion}" >= "5"
267BuildArch: noarch
268%endif
f1b276d4
ER
269
270%description l10n
271Chromium is an open-source browser project that aims to build a safer,
272faster, and more stable way for all Internet users to experience the
273web.
274
275This package contains language packages for 50 languages:
276
e7fa0817
ER
277ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
278he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
279pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
280zh-TW
f1b276d4
ER
281
282%prep
3c73e180
ER
283%setup -qc
284%if "%{?patchver}" != ""
77bd7e0a 285cd chromium*-%{branch}.%{basever}
3c73e180
ER
286%patch0 -p1
287cd ..
288%endif
77bd7e0a 289mv chromium*-%{branch}.%{basever}/* .
589d90ea 290
05f72ae2
ER
291# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
292# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 293. ./chrome/VERSION
e00e4177
ER
294chrome=$MAJOR.$MINOR.$BUILD.$PATCH
295test "$chrome" = %{version}
a3140cd1 296
75f96a39 297gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 298test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 299
4765ddf1
ER
300# add chromium and pld to useragent
301%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
302sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
303 -e 's/@BUILD_DIST_NAME@/PLD/g' \
304 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 305 < %{PATCH8} | %{__patch} -p1
4765ddf1 306
8da7b90b 307%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
308ln -s %{SOURCE7} .
309
12dc0aee 310#%patch2 -p1 NOT COMPILING
75f96a39 311%patch4 -p3
7879021e 312%patch7 -p1
75f96a39 313%patch15 -p2
f4a8da6a 314%{!?with_libjpegturbo:%patch11 -p0}
5997e180 315%patch16 -p1
41d6a4b1 316%patch28 -p1
a323900c 317%patch25 -p1
3aa67e11 318%{?with_nacl:%patch18 -p1}
ffb05754 319%patch24 -p1
75f96a39 320%patch26 -p2
77bd7e0a
ER
321#%patch30 -p1
322#%patch31 -p0
708e64c2 323%patch32 -p1
d7fca4aa 324%patch35 -p1
6e3c39b4 325%patch36 -p1
e9abb380 326
f684992e
ER
327%{?with_dev:exit 0}
328
75a27c2e
ER
329sh -x clean-source.sh \
330 %{!?with_nacl:nacl=0} \
bbdce24d
ER
331 %{!?with_system_libvpx:libvpx=0} \
332 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 333 %{!?with_system_mesa:mesa=0} \
75a27c2e 334 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 335 %{!?with_system_re2:re2=0} \
7e634b46 336 %{!?with_system_snappy:snappy=0} \
5048b37a 337 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 338 %{!?with_system_v8:v8=0} \
0767a7a0 339 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 340 %{!?with_system_zlib:zlib=0} \
f177fdad 341 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 342 %{nil}
fded59be 343
e266589e 344%build
5997e180 345%if %{with nacl}
108c5f7c 346rm -rf native_client/toolchain/linux_x86_newlib
fded59be 347if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 348# Make symlinks for NaCL
108c5f7c 349install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 350
108c5f7c
ER
351cd native_client/toolchain/linux_x86_newlib
352ln -s x86_64-nacl/bin bin
353cd x86_64-nacl/bin
2e4113fd 354__cc='%{__cc}'
f64e73f6 355if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
356 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
357 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
358 %{__sed} -i -e '1i#!/bin/sh' gcc g++
359 chmod +x gcc g++
360else
361 ln -s %{_bindir}/x86_64-nacl-gcc gcc
362 ln -s %{_bindir}/x86_64-nacl-g++ g++
363fi
108c5f7c
ER
364ln -s gcc x86_64-nacl-gcc
365ln -s g++ x86_64-nacl-g++
366ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
367ln -s %{_bindir}/x86_64-nacl-ar ar
368ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 369ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 370ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 371ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 372ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 373ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
374ln -s %{_prefix}/x86_64-nacl/lib ../lib
375ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
376ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
377cd ../../../../..
fded59be 378fi
5997e180
ER
379%endif
380
a323900c 381%if %{without system_ffmpeg}
f8597c6e
ER
382if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
383 # Re-configure bundled ffmpeg
384 cd third_party/ffmpeg
50d701c6
ER
385 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
386 --branding Chromium
f8597c6e 387 chromium/scripts/copy_config.sh
6e3c39b4 388 chromium/scripts/generate_gyp.py
f8597c6e
ER
389 cd -
390fi
0c480b89 391%endif
a323900c 392
6e3c39b4
ER
393third_party/libaddressinput/chromium/tools/update-strings.py
394
a323900c
ER
395flags="
396 -Dtarget_arch=%{target_arch} \
397 -Dpython_arch=%{target_arch} \
6e3c39b4 398 -Dffmpeg_branding=Chromium \
b91ce587 399 -Dsystem_libdir=%{_lib} \
a323900c 400 -Dpython_ver=%{py_ver} \
7b454a31
AM
401%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
402 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 403%endif
f047b07c 404 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 405 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 406 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 407 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
77bd7e0a 408 -Dinclude_tests__=0 \
c0808220 409%if %{with nacl}
038f76b9 410 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
411 -Ddisable_glibc_untar=1 \
412 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
413 -Ddisable_glibc=1 \
414 -Ddisable_pnacl=1 \
415 -Dbuild_pnacl_newlib=0 \
c0808220 416%else
8fb1dc98 417 -Ddisable_pnacl_untar=1 \
c0808220
ER
418 -Ddisable_nacl=1 \
419%endif
a3140cd1
ER
420 %{!?with_sse2:-Ddisable_sse2=1} \
421 %{?with_selinux:-Dselinux=1} \
7d1152d4 422 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 423 -Dlinux_link_libpci=1 \
7879021e 424 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 425 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 426 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
427 -Dclang=0 \
428 -Dhost_clang=0 \
14c8ce0e
ER
429 -Dlinux_use_bundled_binutils=0 \
430 -Dlinux_use_bundled_gold=0 \
05998197 431 -Dlinux_use_gold_flags=0 \
71581184 432 -Dlogging_like_official_build=1 \
319f81f7
ER
433 -Dgoogle_api_key=%{google_api_key} \
434 -Dgoogle_default_client_id=%{google_default_client_id} \
435 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 436 %{gyp_with cups} \
8dda6bbc 437 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 438 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
439 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
440 %{gyp_with pulseaudio} \
41d6a4b1 441 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 442 %{gyp_with system_flac} \
01b4dc8e 443 %{gyp_with system_harfbuzz} \
2d65d095 444 %{gyp_with system_jsoncpp} \
62950103
ER
445 %{gyp_with system_libexif} \
446 %{gyp_with system_libmtp} \
9bd2659c 447 %{gyp_with system_libsrtp} \
581aec44 448 %{gyp_with system_libusb} \
88171dca 449 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 450 %{gyp_with system_libwebp} \
4884fc99 451 %{gyp_with system_libxnvctrl} \
7b8f219a 452 %{gyp_with system_mesa} \
126ea630 453 %{gyp_with system_minizip} \
62950103 454 %{gyp_with system_opus} \
75a27c2e 455 %{gyp_with system_protobuf} \
bbdce24d 456 %{gyp_with system_re2} \
7e634b46 457 %{gyp_with system_snappy} \
e7fa0817 458 %{gyp_with system_speex} \
914ee37c 459 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
460 %{gyp_with system_v8} \
461 %{gyp_with system_yasm} \
462 %{gyp_with system_zlib} \
0c480b89 463 -Duse_system_bzip2=1 \
62950103 464 -Duse_system_expat=1 \
5e64e51b 465 -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
f1b276d4 466 -Duse_system_libevent=1 \
0c480b89 467 -Duse_system_libjpeg=1 \
f1b276d4
ER
468 -Duse_system_libpng=1 \
469 -Duse_system_libxml=1 \
470 -Duse_system_libxslt=1 \
b363f856 471 -Duse_system_nspr=1 \
7f40f3f4 472 -Duse_system_xdg_utils=1 \
7879021e
ER
473"
474
475build/linux/unbundle/replace_gyp_files.py $flags
476
f8597c6e
ER
477%if %{with ninja}
478chkfile=%{builddir}/build.ninja
479%else
480chkfile=Makefile
481%endif
482test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
483test -e $chkfile || \
7879021e
ER
484 CC="%{__cc}" \
485 CXX="%{__cxx}" \
486 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
487 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
488 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
489 CC_host="%{__cc}" \
490 CXX_host="%{__cxx}" \
491 LD_host="%{__cxx}" \
492%{__python} build/gyp_chromium \
f8597c6e 493 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
494 --depth=. \
495 build/all.gyp \
496 $flags
11ad81c4 497
f8597c6e
ER
498%if %{with ninja}
499ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
500%else
b4d75247 501# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
502%{__make} -r \
503 BUILDTYPE=%{buildtype} \
f1b276d4 504 %{?with_verbose:V=1} \
f1b276d4
ER
505 CC.host="%{__cc}" \
506 CXX.host="%{__cxx}" \
b4d75247 507 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
508%endif
509 chrome %{?with_sandboxing:chrome_sandbox} \
510 %{nil}
11ad81c4 511
f8597c6e 512cd %{builddir}
535cb410
ER
513MANWIDTH=80 man ./chrome.1 > man.out
514%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
515
11ad81c4
AM
516%install
517rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
518install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
519 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
520 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
521 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 522
f8597c6e 523cd %{builddir}
37ceaf05 524cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 525install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
526%{__sed} -i -e '
527 s,@libdir@,%{_libdir}/%{name},
528
529 /@OPTIONS@/ {
530 r options.txt
531 d
532 }
533' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 534cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
c925a554 535cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
536ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
537ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 538cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 539install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 540install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 541%if %{without system_ffmpeg}
f1b276d4 542install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 543%endif
6e3c39b4 544install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
e7fa0817 545cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 546cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 547
8da7b90b 548%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 549
164020eb
ER
550%if %{with nacl}
551# Install Native Client files on platforms that support it.
552install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
553install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
554%ifarch %{x8664}
555install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
556%endif
557%ifarch %{ix86}
558install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
559%endif
560%endif
561
0c480b89
ER
562cd -
563
75f96a39 564for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
565 size=${icon##*/product_logo_}
566 size=${size%.png}
567
568 # this will skip non-numeric (22_mono_invert, 22_mono)
569 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
570 test -d "$dir" || continue
571
572 install -d $RPM_BUILD_ROOT$dir
573 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
574done
7f40f3f4 575
13840bc2
AM
576%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
577# http://code.google.com/p/chromium/issues/detail?id=24507
578gecko-mediaplayer*.so
579EOF
11ad81c4 580
589d90ea
ER
581# find locales
582%find_lang %{name}.lang
e7fa0817 583# always package en-US
f1b276d4 584%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 585
11ad81c4
AM
586%clean
587rm -rf $RPM_BUILD_ROOT
588
8da7b90b
ER
589%pretrans
590for d in locales resources; do
591 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
592 install -d %{_datadir}/%{name}
593 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
594 fi
595done
596exit 0
597
f1b276d4 598%post
0eb19b0b 599%update_icon_cache hicolor
b7a6e4ee 600%update_desktop_database
f1b276d4
ER
601%update_browser_plugins
602
603%postun
604if [ "$1" = 0 ]; then
0eb19b0b 605 %update_icon_cache hicolor
f1b276d4
ER
606 %update_browser_plugins
607fi
608
1d2b9616 609%files
11ad81c4 610%defattr(644,root,root,755)
75f96a39 611%doc AUTHORS LICENSE
f1b276d4
ER
612%{_browserpluginsconfdir}/browsers.d/%{name}.*
613%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
614%dir %{_sysconfdir}/%{name}
615%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 616%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
617%dir %{_sysconfdir}/%{name}/native-messaging-hosts
618%dir %{_sysconfdir}/%{name}/policies
619%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
620%attr(755,root,root) %{_bindir}/%{name}
621%{_mandir}/man1/%{name}.1*
11ad81c4 622%{_desktopdir}/*.desktop
0eb19b0b 623%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 624%dir %{_libdir}/%{name}
e9abb380 625%{_libdir}/%{name}/chrome*.pak
c14cd342 626%{_libdir}/%{name}/content_resources.pak
f047b07c 627%{_libdir}/%{name}/keyboard_resources.pak
97fac491 628%{_libdir}/%{name}/resources.pak
8da7b90b
ER
629%{_libdir}/%{name}/locales
630%{_libdir}/%{name}/resources
631
4b5c45ee
ER
632# conflicts with browser-plugin-chrome-pdf?
633%attr(755,root,root) %{_libdir}/%{name}/libpdf.so
634
8da7b90b
ER
635%dir %{_datadir}/%{name}
636%dir %{_datadir}/%{name}/locales
637%{_datadir}/%{name}/locales/en-US.pak
638%dir %{_datadir}/%{name}/resources
639%{_datadir}/%{name}/resources/inspector
640
f1b276d4
ER
641%dir %{_libdir}/%{name}/plugins
642%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 643# These unique permissions are intentional and necessary for the sandboxing
d1a83042 644%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
645
646# ffmpeg libs
fcc48c19 647%if %{without system_ffmpeg}
f1b276d4 648%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 649%endif
f1b276d4 650
164020eb
ER
651%if %{with nacl}
652%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
653%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
654%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
655%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
656%endif
657
f1b276d4
ER
658%files l10n -f %{name}.lang
659%defattr(644,root,root,755)
This page took 0.208081 seconds and 4 git commands to generate.