]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 44.0.2403.107
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
ffcc39d4 21%bcond_with system_icu # system icu, disabled: http://bugs.icu-project.org/trac/ticket/11358)
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
543e99ac 33%bcond_without system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 38%bcond_with system_v8 # system v8
207c863c 39%bcond_without system_libvpx # system libvpx
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
a3140cd1 65
e53ecfb5 66# NOTES:
4fe038cb
ER
67# - mute BEEP mixer if you do not want to hear horrible system bell when
68# pressing home/end in url bar or more ^F search results on page.
7c638678 69# - space considerations:
0bb93ab2 70# - unpacked sources: ~490MiB
c1ecd31f 71# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 72# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 73# - to look for new tarball, use update-source.sh script
f1b276d4 74
f5554d90 75%define branch 44.0.2403
31be7c15 76%define basever 107
f5554d90 77#define patchver 118
a3140cd1 78%define gyp_rev 1014
11ad81c4 79Summary: A WebKit powered web browser
05f72ae2 80Name: chromium-browser
f73369da
ER
81%if "%{?patchver}" != ""
82Version: %{branch}.%{patchver}
83%else
84Version: %{branch}.%{basever}
85%endif
9d867387 86Release: 1
5bb99ef4 87License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 88Group: X11/Applications/Networking
cb240878 89Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
31be7c15 90# Source0-md5: 8686c4033cb1d25d0c60c9b6e09c65e1
3c73e180
ER
91%if "%{?patchver}" != ""
92Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
1e007e9c 93# Patch0-md5: 4265bb63c75457923cdbaa15a49a22ae
3c73e180 94%endif
37ceaf05 95Source1: %{name}.default
8b53130d
ER
96Source2: %{name}.sh
97Source3: %{name}.desktop
56c6e811
ER
98Source5: find-lang.sh
99Source6: update-source.sh
100Source7: clean-source.sh
836b1cac 101Source8: get-source.sh
0562b864 102Source9: master_preferences.json
a198be7c 103# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 104Patch2: enable-video-decode-accel.patch
5aa5df39 105Patch7: dlopen_sonamed_gl.patch
4765ddf1 106Patch8: chromium_useragent.patch.in
1347c76c
AM
107# https://bugs.gentoo.org/show_bug.cgi?id=393471
108# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 109Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
110Patch15: nacl-build-irt.patch
111Patch16: nacl-linkingfix.patch
9516ca97 112Patch18: nacl-no-untar.patch
6897926c 113Patch24: nacl-verbose.patch
c5b396f3
ER
114Patch25: gnome3-volume-control.patch
115Patch26: master-prefs-path.patch
25d4e23c 116Patch28: system-mesa.patch
9cce36cb 117Patch31: system-jinja.patch
708e64c2 118Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 119Patch35: etc-dir.patch
6e3c39b4 120Patch36: angle.patch
a20f29ed 121Patch37: %{name}-build.patch
a198be7c 122Patch38: vaapi_include.patch
221355ea 123Patch39: libsecret.patch
750b48f7 124URL: http://www.chromium.org/Home
ae3fe89f 125%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 126%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 127BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 128%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 129%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
130BuildRequires: alsa-lib-devel
131BuildRequires: atk-devel
132BuildRequires: bison
11ad81c4 133BuildRequires: bzip2-devel
5997e180
ER
134%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
135%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
136%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 137%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 138%{?with_cups:BuildRequires: cups-devel}
92965b0e 139BuildRequires: elfutils-devel
77f32fa3 140BuildRequires: expat-devel
7d0dbc8d 141%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 142%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 143BuildRequires: fontconfig-devel
f1b276d4 144BuildRequires: glib2-devel
05f72ae2 145BuildRequires: gperf
71d49434 146%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 147BuildRequires: gtest-devel
8b53130d 148BuildRequires: gtk+2-devel
01b4dc8e 149%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 150%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 151%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 152BuildRequires: hicolor-icon-theme
ed514974 153%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 154%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 155BuildRequires: libevent-devel
8456d676 156%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 157%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 158%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 159%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 160%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 161%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 162BuildRequires: libpng-devel
221355ea 163BuildRequires: libsecret-devel
e266589e 164%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 165BuildRequires: libstdc++-devel
ba685303 166%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
5f786a22 167%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.4.0}
88171dca 168%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 169BuildRequires: libxml2-devel
11ad81c4 170BuildRequires: libxslt-devel
535cb410 171BuildRequires: man-db
62950103 172%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 173%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 174BuildRequires: nspr-devel
f1b276d4 175BuildRequires: nss-devel >= 1:3.12.3
8456d676 176%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 177BuildRequires: pam-devel
f1b276d4 178BuildRequires: pango-devel
ef121064 179BuildRequires: pciutils-devel
3a3b7da9 180BuildRequires: perl-JSON
48b341f5 181BuildRequires: perl-modules
182BuildRequires: pkgconfig
75a27c2e 183%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 184%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 185BuildRequires: python
e2f921c3 186BuildRequires: python-BeautifulSoup
46cdefee 187#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 188BuildRequires: python-jinja2 >= 2.7
48b341f5 189BuildRequires: python-modules
e0a7fe40 190BuildRequires: python-ply >= 3.4
543e99ac 191%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 192BuildRequires: rpm >= 4.4.9-56
f1b276d4 193BuildRequires: rpmbuild(macros) >= 1.453
f099161f 194%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 195BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 196%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 197%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 198%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 199BuildRequires: tar >= 1:1.22
0a424ee2 200BuildRequires: udev-devel
7d1152d4 201BuildRequires: usbutils
2303ed45 202BuildRequires: util-linux
c14cd342 203%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 204BuildRequires: which
f1b276d4 205BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 206BuildRequires: xorg-lib-libXtst-devel
836b1cac 207BuildRequires: xz
a3140cd1 208%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 209%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 210Requires: browser-plugins >= 2.0
0cad051b 211Requires: desktop-file-utils
8f5f6775 212%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
213# crashes if no fontconfig font present
214Requires: fonts-Type1-urw
0eb19b0b 215Requires: hicolor-icon-theme
56403697 216Requires: libevent >= 2.0.21
c1edaafa 217%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 218%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 219Requires: lsb-release
b2c4ae39 220%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 221%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 222Requires: shared-mime-info
f7b16691 223%{?with_system_sqlite:Requires: sqlite3(icu)}
5c9227ee 224Requires: uname(release) >= 3.17
4dc49133 225Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 226Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 227Provides: wwwbrowser
c3582150 228Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 229Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 230ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 231BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 232
319f81f7
ER
233# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
234# Note: these are for PLD Linux use ONLY.
235# For your own distribution, please get your own set of keys.
236%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
237%define google_default_client_id 724288223830.apps.googleusercontent.com
238%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
239
7ebeabb6 240%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 241
e7fa0817
ER
242# Usage: gyp_with BCOND_NAME [OPTION_NAME]
243%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 244
a323900c
ER
245%ifarch %{ix86}
246%define target_arch ia32
247%endif
248%ifarch %{x8664}
249%define target_arch x64
250%endif
251
f8597c6e
ER
252%define buildtype %{?debug:Debug}%{!?debug:Release}
253%define builddir out/%{buildtype}
254
6b113615
ER
255%if %{without debuginfo}
256%define _enable_debug_packages 0
257%endif
258
11ad81c4 259%description
80838854
ER
260Chromium is an open-source browser project that aims to build a safer,
261faster, and more stable way for all Internet users to experience the
262web.
263
264Chromium serves as a base for Google Chrome, which is Chromium
265rebranded (name and logo) with very few additions such as usage
266tracking and an auto-updater system.
267
f1b276d4
ER
268%package l10n
269Summary: chromium-browser language packages
270Group: I18n
271Requires: %{name} = %{version}-%{release}
8da7b90b
ER
272%if "%{_rpmversion}" >= "5"
273BuildArch: noarch
274%endif
f1b276d4
ER
275
276%description l10n
277Chromium is an open-source browser project that aims to build a safer,
278faster, and more stable way for all Internet users to experience the
279web.
280
281This package contains language packages for 50 languages:
282
e7fa0817
ER
283ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
284he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
285pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
286zh-TW
f1b276d4
ER
287
288%prep
3c73e180
ER
289%setup -qc
290%if "%{?patchver}" != ""
77bd7e0a 291cd chromium*-%{branch}.%{basever}
3c73e180
ER
292%patch0 -p1
293cd ..
294%endif
77bd7e0a 295mv chromium*-%{branch}.%{basever}/* .
589d90ea 296
05f72ae2
ER
297# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
298# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 299. ./chrome/VERSION
e00e4177
ER
300chrome=$MAJOR.$MINOR.$BUILD.$PATCH
301test "$chrome" = %{version}
a3140cd1 302
75f96a39 303gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 304test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 305
4765ddf1
ER
306# add chromium and pld to useragent
307%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
308sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
309 -e 's/@BUILD_DIST_NAME@/PLD/g' \
310 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 311 < %{PATCH8} | %{__patch} -p1
4765ddf1 312
8da7b90b 313%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
314ln -s %{SOURCE7} .
315
810e0294 316#%patch2 -p1 CHECK
7879021e 317%patch7 -p1
75f96a39 318%patch15 -p2
f4a8da6a 319%{!?with_libjpegturbo:%patch11 -p0}
5997e180 320%patch16 -p1
41d6a4b1 321%patch28 -p1
a323900c 322%patch25 -p1
3aa67e11 323%{?with_nacl:%patch18 -p1}
ffb05754 324%patch24 -p1
75f96a39 325%patch26 -p2
cb6dde87 326%patch31 -p0
708e64c2 327%patch32 -p1
d7fca4aa 328%patch35 -p1
6e3c39b4 329%patch36 -p1
a20f29ed 330%patch37 -p1
810e0294 331#%patch38 -p1 CHECK
deef15b4 332%patch39 -p1
e9abb380 333
f684992e
ER
334%{?with_dev:exit 0}
335
75a27c2e
ER
336sh -x clean-source.sh \
337 %{!?with_nacl:nacl=0} \
bbdce24d
ER
338 %{!?with_system_libvpx:libvpx=0} \
339 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 340 %{!?with_system_mesa:mesa=0} \
75a27c2e 341 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 342 %{!?with_system_re2:re2=0} \
7e634b46 343 %{!?with_system_snappy:snappy=0} \
5048b37a 344 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 345 %{!?with_system_v8:v8=0} \
0767a7a0 346 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 347 %{!?with_system_zlib:zlib=0} \
f177fdad 348 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 349 %{nil}
fded59be 350
e266589e 351%build
5997e180 352%if %{with nacl}
108c5f7c 353rm -rf native_client/toolchain/linux_x86_newlib
fded59be 354if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 355# Make symlinks for NaCL
108c5f7c 356install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 357
108c5f7c
ER
358cd native_client/toolchain/linux_x86_newlib
359ln -s x86_64-nacl/bin bin
360cd x86_64-nacl/bin
2e4113fd 361__cc='%{__cc}'
f64e73f6 362if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
363 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
364 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
365 %{__sed} -i -e '1i#!/bin/sh' gcc g++
366 chmod +x gcc g++
367else
368 ln -s %{_bindir}/x86_64-nacl-gcc gcc
369 ln -s %{_bindir}/x86_64-nacl-g++ g++
370fi
108c5f7c
ER
371ln -s gcc x86_64-nacl-gcc
372ln -s g++ x86_64-nacl-g++
373ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
374ln -s %{_bindir}/x86_64-nacl-ar ar
375ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 376ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 377ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 378ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 379ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 380ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
381ln -s %{_prefix}/x86_64-nacl/lib ../lib
382ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
383ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
384cd ../../../../..
fded59be 385fi
5997e180
ER
386%endif
387
a323900c 388%if %{without system_ffmpeg}
f8597c6e
ER
389if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
390 # Re-configure bundled ffmpeg
391 cd third_party/ffmpeg
50d701c6
ER
392 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
393 --branding Chromium
f8597c6e 394 chromium/scripts/copy_config.sh
6e3c39b4 395 chromium/scripts/generate_gyp.py
f8597c6e
ER
396 cd -
397fi
0c480b89 398%endif
a323900c 399
6e3c39b4
ER
400third_party/libaddressinput/chromium/tools/update-strings.py
401
a323900c
ER
402flags="
403 -Dtarget_arch=%{target_arch} \
404 -Dpython_arch=%{target_arch} \
12687dbd 405 -Dproprietary_codecs=1 \
6e3c39b4 406 -Dffmpeg_branding=Chromium \
b91ce587 407 -Dsystem_libdir=%{_lib} \
a323900c 408 -Dpython_ver=%{py_ver} \
7b454a31
AM
409%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
410 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 411%endif
f047b07c 412 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 413 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 414 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 415 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 416 -Dinclude_tests__=0 \
c0808220 417%if %{with nacl}
038f76b9 418 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
419 -Ddisable_glibc_untar=1 \
420 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
421 -Ddisable_glibc=1 \
422 -Ddisable_pnacl=1 \
423 -Dbuild_pnacl_newlib=0 \
c0808220 424%else
8fb1dc98 425 -Ddisable_pnacl_untar=1 \
c0808220
ER
426 -Ddisable_nacl=1 \
427%endif
a3140cd1
ER
428 %{!?with_sse2:-Ddisable_sse2=1} \
429 %{?with_selinux:-Dselinux=1} \
7d1152d4 430 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 431 -Dlinux_link_libpci=1 \
7879021e 432 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 433 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 434 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
435 -Dclang=0 \
436 -Dhost_clang=0 \
14c8ce0e
ER
437 -Dlinux_use_bundled_binutils=0 \
438 -Dlinux_use_bundled_gold=0 \
05998197 439 -Dlinux_use_gold_flags=0 \
71581184 440 -Dlogging_like_official_build=1 \
319f81f7
ER
441 -Dgoogle_api_key=%{google_api_key} \
442 -Dgoogle_default_client_id=%{google_default_client_id} \
443 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 444 %{gyp_with cups} \
8dda6bbc 445 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 446 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
447 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
448 %{gyp_with pulseaudio} \
41d6a4b1 449 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 450 %{gyp_with system_flac} \
01b4dc8e 451 %{gyp_with system_harfbuzz} \
cb6dde87 452 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 453 %{gyp_with system_jsoncpp} \
62950103
ER
454 %{gyp_with system_libexif} \
455 %{gyp_with system_libmtp} \
9bd2659c 456 %{gyp_with system_libsrtp} \
581aec44 457 %{gyp_with system_libusb} \
88171dca 458 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 459 %{gyp_with system_libwebp} \
4884fc99 460 %{gyp_with system_libxnvctrl} \
7b8f219a 461 %{gyp_with system_mesa} \
126ea630 462 %{gyp_with system_minizip} \
62950103 463 %{gyp_with system_opus} \
75a27c2e 464 %{gyp_with system_protobuf} \
bbdce24d 465 %{gyp_with system_re2} \
7e634b46 466 %{gyp_with system_snappy} \
e7fa0817 467 %{gyp_with system_speex} \
914ee37c 468 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
469 %{gyp_with system_v8} \
470 %{gyp_with system_yasm} \
471 %{gyp_with system_zlib} \
0c480b89 472 -Duse_system_bzip2=1 \
62950103 473 -Duse_system_expat=1 \
f1b276d4 474 -Duse_system_libevent=1 \
0c480b89 475 -Duse_system_libjpeg=1 \
f1b276d4
ER
476 -Duse_system_libpng=1 \
477 -Duse_system_libxml=1 \
478 -Duse_system_libxslt=1 \
b363f856 479 -Duse_system_nspr=1 \
7f40f3f4 480 -Duse_system_xdg_utils=1 \
7879021e
ER
481"
482
483build/linux/unbundle/replace_gyp_files.py $flags
484
f8597c6e
ER
485%if %{with ninja}
486chkfile=%{builddir}/build.ninja
487%else
488chkfile=Makefile
489%endif
490test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
491test -e $chkfile || \
7879021e
ER
492 CC="%{__cc}" \
493 CXX="%{__cxx}" \
494 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
495 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
496 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
497 CC_host="%{__cc}" \
498 CXX_host="%{__cxx}" \
499 LD_host="%{__cxx}" \
500%{__python} build/gyp_chromium \
f8597c6e 501 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
502 --depth=. \
503 build/all.gyp \
504 $flags
11ad81c4 505
f8597c6e
ER
506%if %{with ninja}
507ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
508%else
b4d75247 509# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
510%{__make} -r \
511 BUILDTYPE=%{buildtype} \
f1b276d4 512 %{?with_verbose:V=1} \
f1b276d4
ER
513 CC.host="%{__cc}" \
514 CXX.host="%{__cxx}" \
b4d75247 515 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
516%endif
517 chrome %{?with_sandboxing:chrome_sandbox} \
518 %{nil}
11ad81c4 519
f8597c6e 520cd %{builddir}
535cb410
ER
521MANWIDTH=80 man ./chrome.1 > man.out
522%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
523
11ad81c4
AM
524%install
525rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
526install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
527 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
528 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
529 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 530
f8597c6e 531cd %{builddir}
37ceaf05 532cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 533install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
534%{__sed} -i -e '
535 s,@libdir@,%{_libdir}/%{name},
536
537 /@OPTIONS@/ {
538 r options.txt
539 d
540 }
541' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 542cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 543cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
544ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
545ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 546cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 547install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 548install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 549%if %{without system_ffmpeg}
f1b276d4 550install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 551%endif
e7fa0817 552cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 553cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 554
8da7b90b 555%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 556
164020eb
ER
557%if %{with nacl}
558# Install Native Client files on platforms that support it.
559install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
560install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
561%ifarch %{x8664}
562install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
563%endif
564%ifarch %{ix86}
565install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
566%endif
567%endif
568
0c480b89
ER
569cd -
570
75f96a39 571for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
572 size=${icon##*/product_logo_}
573 size=${size%.png}
574
575 # this will skip non-numeric (22_mono_invert, 22_mono)
576 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
577 test -d "$dir" || continue
578
579 install -d $RPM_BUILD_ROOT$dir
580 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
581done
7f40f3f4 582
13840bc2
AM
583%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
584# http://code.google.com/p/chromium/issues/detail?id=24507
585gecko-mediaplayer*.so
586EOF
11ad81c4 587
589d90ea
ER
588# find locales
589%find_lang %{name}.lang
e7fa0817 590# always package en-US
f1b276d4 591%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 592
11ad81c4
AM
593%clean
594rm -rf $RPM_BUILD_ROOT
595
8da7b90b
ER
596%pretrans
597for d in locales resources; do
598 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
599 install -d %{_datadir}/%{name}
600 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
601 fi
602done
603exit 0
604
f1b276d4 605%post
0eb19b0b 606%update_icon_cache hicolor
b7a6e4ee 607%update_desktop_database
f1b276d4
ER
608%update_browser_plugins
609
610%postun
611if [ "$1" = 0 ]; then
0eb19b0b 612 %update_icon_cache hicolor
f1b276d4
ER
613 %update_browser_plugins
614fi
615
1d2b9616 616%files
11ad81c4 617%defattr(644,root,root,755)
75f96a39 618%doc AUTHORS LICENSE
f1b276d4
ER
619%{_browserpluginsconfdir}/browsers.d/%{name}.*
620%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
621%dir %{_sysconfdir}/%{name}
622%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 623%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
624%dir %{_sysconfdir}/%{name}/native-messaging-hosts
625%dir %{_sysconfdir}/%{name}/policies
626%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
627%attr(755,root,root) %{_bindir}/%{name}
628%{_mandir}/man1/%{name}.1*
11ad81c4 629%{_desktopdir}/*.desktop
0eb19b0b 630%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 631%dir %{_libdir}/%{name}
e9abb380 632%{_libdir}/%{name}/chrome*.pak
c14cd342 633%{_libdir}/%{name}/content_resources.pak
f047b07c 634%{_libdir}/%{name}/keyboard_resources.pak
97fac491 635%{_libdir}/%{name}/resources.pak
fa8317a0
ER
636%{_libdir}/%{name}/natives_blob.bin
637%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
638%{_libdir}/%{name}/locales
639%{_libdir}/%{name}/resources
640
641%dir %{_datadir}/%{name}
642%dir %{_datadir}/%{name}/locales
643%{_datadir}/%{name}/locales/en-US.pak
644%dir %{_datadir}/%{name}/resources
645%{_datadir}/%{name}/resources/inspector
646
f1b276d4
ER
647%dir %{_libdir}/%{name}/plugins
648%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 649# These unique permissions are intentional and necessary for the sandboxing
d1a83042 650%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
651
652# ffmpeg libs
fcc48c19 653%if %{without system_ffmpeg}
f1b276d4 654%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 655%endif
f1b276d4 656
164020eb
ER
657%if %{with nacl}
658%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
659%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
660%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
661%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
662%endif
663
f1b276d4
ER
664%files l10n -f %{name}.lang
665%defattr(644,root,root,755)
This page took 0.200414 seconds and 4 git commands to generate.