]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 36.0.1985.143
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
ba685303 21%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
22%bcond_without system_libexif # system libexif
23%bcond_without system_libmtp # system libmtp
3934d767 24%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 25%bcond_without system_libwebp # system libwebp
4884fc99 26%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 27%bcond_with system_mesa # system Mesa
126ea630 28%bcond_without system_minizip # system minizip
62950103 29%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 30%bcond_without system_protobuf # system protobuf
543e99ac 31%bcond_without system_re2 # system re2
7e634b46 32%bcond_without system_snappy # system snappy
ba685303 33%bcond_without system_speex # system speex
a8f4f3ac 34%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 35%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 36%bcond_with system_v8 # system v8
f047b07c 37%bcond_with system_libvpx # system libvpx
ba685303 38%bcond_without system_yasm # system yasm
1c00315b 39%bcond_without system_zlib # system zlib
14c8ce0e 40%bcond_with tcmalloc # use tcmalloc
7e136323 41%bcond_without verbose # verbose build (V=1)
0c480b89 42
b3fc6cb2
ER
43%ifarch %{ix86}
44# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
45%undefine with_system_mesa
46%endif
47
6d92f81c 48# TODO
b363f856 49# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 50# - use_system_skia
a3140cd1 51# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 52# - use_system_stlport (android specific)
7b8f219a 53# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 54
e53ecfb5 55# NOTES:
4fe038cb
ER
56# - mute BEEP mixer if you do not want to hear horrible system bell when
57# pressing home/end in url bar or more ^F search results on page.
7c638678 58# - space considerations:
0bb93ab2 59# - unpacked sources: ~490MiB
c1ecd31f 60# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 61# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 62# - to look for new tarball, use update-source.sh script
f1b276d4 63
236719e5
ER
64%define branch 36.0.1985
65%define basever 143
605f0a8d 66#define patchver 132
a3140cd1 67%define gyp_rev 1014
11ad81c4 68Summary: A WebKit powered web browser
05f72ae2 69Name: chromium-browser
f73369da
ER
70%if "%{?patchver}" != ""
71Version: %{branch}.%{patchver}
72%else
73Version: %{branch}.%{basever}
74%endif
d37862c1 75Release: 1
5bb99ef4 76License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 77Group: X11/Applications/Networking
f177fdad 78Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
12e2c80b 79# Source0-md5: 8180f26a32fec2f28ae0a2f9a25bdca2
3c73e180
ER
80%if "%{?patchver}" != ""
81Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
c925a554 82# Patch0-md5: 4eafe1e64bd47a11dbfaf61a2dd50b6e
3c73e180 83%endif
37ceaf05 84Source1: %{name}.default
8b53130d
ER
85Source2: %{name}.sh
86Source3: %{name}.desktop
56c6e811
ER
87Source5: find-lang.sh
88Source6: update-source.sh
89Source7: clean-source.sh
836b1cac 90Source8: get-source.sh
0562b864 91Source9: master_preferences.json
627e6027 92Patch2: enable-video-decode-accel.patch
72cb20c1 93Patch4: path-libpdf.patch
5aa5df39 94Patch7: dlopen_sonamed_gl.patch
4765ddf1 95Patch8: chromium_useragent.patch.in
1347c76c
AM
96# https://bugs.gentoo.org/show_bug.cgi?id=393471
97# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 98Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
9516ca97 101Patch18: nacl-no-untar.patch
6897926c 102Patch24: nacl-verbose.patch
c5b396f3
ER
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
25d4e23c 105Patch28: system-mesa.patch
e0a7fe40 106Patch30: system-ply.patch
9cce36cb 107Patch31: system-jinja.patch
708e64c2 108Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 109Patch35: etc-dir.patch
750b48f7 110URL: http://www.chromium.org/Home
ae3fe89f 111%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 112%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 113BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 114%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 115%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
116BuildRequires: alsa-lib-devel
117BuildRequires: atk-devel
118BuildRequires: bison
11ad81c4 119BuildRequires: bzip2-devel
5997e180
ER
120%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
121%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
122%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 123%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 124%{?with_cups:BuildRequires: cups-devel}
92965b0e 125BuildRequires: elfutils-devel
77f32fa3 126BuildRequires: expat-devel
7d0dbc8d 127%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 128%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 129BuildRequires: fontconfig-devel
f1b276d4 130BuildRequires: glib2-devel
05f72ae2 131BuildRequires: gperf
71d49434 132%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 133BuildRequires: gtest-devel
8b53130d 134BuildRequires: gtk+2-devel
01b4dc8e 135%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 136%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 137%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 138BuildRequires: hicolor-icon-theme
ed514974 139%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 140%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 141BuildRequires: libevent-devel
8456d676 142%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 143%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 144BuildRequires: libicu-devel >= 4.6
39c71b4c 145%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 146%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 147%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 148BuildRequires: libpng-devel
e266589e 149%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 150BuildRequires: libstdc++-devel
ba685303 151%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
152%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
153%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 154BuildRequires: libxml2-devel
11ad81c4 155BuildRequires: libxslt-devel
535cb410 156BuildRequires: man-db
62950103 157%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 158%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 159BuildRequires: nspr-devel
f1b276d4 160BuildRequires: nss-devel >= 1:3.12.3
8456d676 161%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 162BuildRequires: pam-devel
f1b276d4 163BuildRequires: pango-devel
ef121064 164BuildRequires: pciutils-devel
3a3b7da9 165BuildRequires: perl-JSON
48b341f5 166BuildRequires: perl-modules
167BuildRequires: pkgconfig
75a27c2e 168%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 169%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 170BuildRequires: python
46cdefee 171#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 172BuildRequires: python-jinja2 >= 2.7
48b341f5 173BuildRequires: python-modules
e0a7fe40 174BuildRequires: python-ply >= 3.4
543e99ac 175%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 176BuildRequires: rpm >= 4.4.9-56
f1b276d4 177BuildRequires: rpmbuild(macros) >= 1.453
f099161f 178%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 179BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 180%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 181%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 182%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 183BuildRequires: tar >= 1:1.22
0a424ee2 184BuildRequires: udev-devel
7d1152d4 185BuildRequires: usbutils
2303ed45 186BuildRequires: util-linux
c14cd342 187%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 188BuildRequires: which
f1b276d4 189BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 190BuildRequires: xorg-lib-libXtst-devel
836b1cac 191BuildRequires: xz
a3140cd1 192%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 193%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 194Requires: browser-plugins >= 2.0
0cad051b 195Requires: desktop-file-utils
8f5f6775 196%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
197# crashes if no fontconfig font present
198Requires: fonts-Type1-urw
0eb19b0b 199Requires: hicolor-icon-theme
56403697 200Requires: libevent >= 2.0.21
c1edaafa 201%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 202%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 203Requires: lsb-release
b2c4ae39 204%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 205Requires: shared-mime-info
f7b16691 206%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 207Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 208Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 209Provides: wwwbrowser
c3582150 210Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 211Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 212ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 213BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 214
319f81f7
ER
215# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
216# Note: these are for PLD Linux use ONLY.
217# For your own distribution, please get your own set of keys.
218%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
219%define google_default_client_id 724288223830.apps.googleusercontent.com
220%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
221
7ebeabb6 222%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 223
e7fa0817
ER
224# Usage: gyp_with BCOND_NAME [OPTION_NAME]
225%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 226
a323900c
ER
227%ifarch %{ix86}
228%define target_arch ia32
229%endif
230%ifarch %{x8664}
231%define target_arch x64
232%endif
233
f8597c6e
ER
234%define buildtype %{?debug:Debug}%{!?debug:Release}
235%define builddir out/%{buildtype}
236
6b113615
ER
237%if %{without debuginfo}
238%define _enable_debug_packages 0
239%endif
240
11ad81c4 241%description
80838854
ER
242Chromium is an open-source browser project that aims to build a safer,
243faster, and more stable way for all Internet users to experience the
244web.
245
246Chromium serves as a base for Google Chrome, which is Chromium
247rebranded (name and logo) with very few additions such as usage
248tracking and an auto-updater system.
249
f1b276d4
ER
250%package l10n
251Summary: chromium-browser language packages
252Group: I18n
253Requires: %{name} = %{version}-%{release}
8da7b90b
ER
254%if "%{_rpmversion}" >= "5"
255BuildArch: noarch
256%endif
f1b276d4
ER
257
258%description l10n
259Chromium is an open-source browser project that aims to build a safer,
260faster, and more stable way for all Internet users to experience the
261web.
262
263This package contains language packages for 50 languages:
264
e7fa0817
ER
265ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
266he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
267pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
268zh-TW
f1b276d4
ER
269
270%prep
3c73e180
ER
271%setup -qc
272%if "%{?patchver}" != ""
77bd7e0a 273cd chromium*-%{branch}.%{basever}
3c73e180
ER
274%patch0 -p1
275cd ..
276%endif
77bd7e0a 277mv chromium*-%{branch}.%{basever}/* .
589d90ea 278
05f72ae2
ER
279# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
280# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 281. ./chrome/VERSION
e00e4177
ER
282chrome=$MAJOR.$MINOR.$BUILD.$PATCH
283test "$chrome" = %{version}
a3140cd1 284
75f96a39 285gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 286test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 287
4765ddf1
ER
288# add chromium and pld to useragent
289%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
290sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
291 -e 's/@BUILD_DIST_NAME@/PLD/g' \
292 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 293 < %{PATCH8} | %{__patch} -p1
4765ddf1 294
8da7b90b 295%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
296ln -s %{SOURCE7} .
297
12dc0aee 298#%patch2 -p1 NOT COMPILING
75f96a39 299%patch4 -p3
7879021e 300%patch7 -p1
75f96a39 301%patch15 -p2
f4a8da6a 302%{!?with_libjpegturbo:%patch11 -p0}
5997e180 303%patch16 -p1
41d6a4b1 304%patch28 -p1
a323900c 305%patch25 -p1
3aa67e11 306%{?with_nacl:%patch18 -p1}
ffb05754 307%patch24 -p1
75f96a39 308%patch26 -p2
77bd7e0a
ER
309#%patch30 -p1
310#%patch31 -p0
708e64c2 311%patch32 -p1
d7fca4aa 312%patch35 -p1
e9abb380 313
f684992e
ER
314%{?with_dev:exit 0}
315
75a27c2e
ER
316sh -x clean-source.sh \
317 %{!?with_nacl:nacl=0} \
bbdce24d
ER
318 %{!?with_system_libvpx:libvpx=0} \
319 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 320 %{!?with_system_mesa:mesa=0} \
75a27c2e 321 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 322 %{!?with_system_re2:re2=0} \
7e634b46 323 %{!?with_system_snappy:snappy=0} \
5048b37a 324 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 325 %{!?with_system_v8:v8=0} \
0767a7a0 326 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 327 %{!?with_system_zlib:zlib=0} \
f177fdad 328 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 329 %{nil}
fded59be 330
e266589e 331%build
5997e180 332%if %{with nacl}
108c5f7c 333rm -rf native_client/toolchain/linux_x86_newlib
fded59be 334if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 335# Make symlinks for NaCL
108c5f7c 336install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 337
108c5f7c
ER
338cd native_client/toolchain/linux_x86_newlib
339ln -s x86_64-nacl/bin bin
340cd x86_64-nacl/bin
2e4113fd 341__cc='%{__cc}'
f64e73f6 342if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
343 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
344 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
345 %{__sed} -i -e '1i#!/bin/sh' gcc g++
346 chmod +x gcc g++
347else
348 ln -s %{_bindir}/x86_64-nacl-gcc gcc
349 ln -s %{_bindir}/x86_64-nacl-g++ g++
350fi
108c5f7c
ER
351ln -s gcc x86_64-nacl-gcc
352ln -s g++ x86_64-nacl-g++
353ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
354ln -s %{_bindir}/x86_64-nacl-ar ar
355ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 356ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 357ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 358ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 359ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 360ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
361ln -s %{_prefix}/x86_64-nacl/lib ../lib
362ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
363ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
364cd ../../../../..
fded59be 365fi
5997e180
ER
366%endif
367
a323900c 368%if %{without system_ffmpeg}
f8597c6e
ER
369if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
370 # Re-configure bundled ffmpeg
371 cd third_party/ffmpeg
372 chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
373 chromium/scripts/copy_config.sh
374 cd -
375fi
0c480b89 376%endif
a323900c
ER
377
378flags="
379 -Dtarget_arch=%{target_arch} \
380 -Dpython_arch=%{target_arch} \
b91ce587 381 -Dsystem_libdir=%{_lib} \
a323900c 382 -Dpython_ver=%{py_ver} \
7b454a31
AM
383%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
384 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 385%endif
f047b07c 386 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 387 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 388 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 389 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
77bd7e0a 390 -Dinclude_tests__=0 \
c0808220 391%if %{with nacl}
038f76b9 392 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
393 -Ddisable_glibc_untar=1 \
394 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
395 -Ddisable_glibc=1 \
396 -Ddisable_pnacl=1 \
397 -Dbuild_pnacl_newlib=0 \
c0808220 398%else
8fb1dc98 399 -Ddisable_pnacl_untar=1 \
c0808220
ER
400 -Ddisable_nacl=1 \
401%endif
a3140cd1
ER
402 %{!?with_sse2:-Ddisable_sse2=1} \
403 %{?with_selinux:-Dselinux=1} \
7d1152d4 404 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 405 -Dlinux_link_libpci=1 \
7879021e 406 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 407 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 408 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
14c8ce0e
ER
409 -Dlinux_use_bundled_binutils=0 \
410 -Dlinux_use_bundled_gold=0 \
05998197 411 -Dlinux_use_gold_flags=0 \
71581184 412 -Dlogging_like_official_build=1 \
319f81f7
ER
413 -Dgoogle_api_key=%{google_api_key} \
414 -Dgoogle_default_client_id=%{google_default_client_id} \
415 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 416 %{gyp_with cups} \
8dda6bbc 417 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 418 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
419 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
420 %{gyp_with pulseaudio} \
41d6a4b1 421 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 422 %{gyp_with system_flac} \
01b4dc8e 423 %{gyp_with system_harfbuzz} \
2d65d095 424 %{gyp_with system_jsoncpp} \
62950103
ER
425 %{gyp_with system_libexif} \
426 %{gyp_with system_libmtp} \
9bd2659c 427 %{gyp_with system_libsrtp} \
581aec44 428 %{gyp_with system_libusb} \
88171dca 429 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 430 %{gyp_with system_libwebp} \
4884fc99 431 %{gyp_with system_libxnvctrl} \
7b8f219a 432 %{gyp_with system_mesa} \
126ea630 433 %{gyp_with system_minizip} \
62950103 434 %{gyp_with system_opus} \
75a27c2e 435 %{gyp_with system_protobuf} \
bbdce24d 436 %{gyp_with system_re2} \
7e634b46 437 %{gyp_with system_snappy} \
e7fa0817 438 %{gyp_with system_speex} \
914ee37c 439 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
440 %{gyp_with system_v8} \
441 %{gyp_with system_yasm} \
442 %{gyp_with system_zlib} \
0c480b89 443 -Duse_system_bzip2=1 \
62950103 444 -Duse_system_expat=1 \
5e64e51b 445 -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
f1b276d4 446 -Duse_system_libevent=1 \
0c480b89 447 -Duse_system_libjpeg=1 \
f1b276d4
ER
448 -Duse_system_libpng=1 \
449 -Duse_system_libxml=1 \
450 -Duse_system_libxslt=1 \
b363f856 451 -Duse_system_nspr=1 \
7f40f3f4 452 -Duse_system_xdg_utils=1 \
7879021e
ER
453"
454
455build/linux/unbundle/replace_gyp_files.py $flags
456
f8597c6e
ER
457%if %{with ninja}
458chkfile=%{builddir}/build.ninja
459%else
460chkfile=Makefile
461%endif
462test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
463test -e $chkfile || \
7879021e
ER
464 CC="%{__cc}" \
465 CXX="%{__cxx}" \
466 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
467 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
468 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
469 CC_host="%{__cc}" \
470 CXX_host="%{__cxx}" \
471 LD_host="%{__cxx}" \
472%{__python} build/gyp_chromium \
f8597c6e 473 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
474 --depth=. \
475 build/all.gyp \
476 $flags
11ad81c4 477
f8597c6e
ER
478%if %{with ninja}
479ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
480%else
b4d75247 481# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
482%{__make} -r \
483 BUILDTYPE=%{buildtype} \
f1b276d4 484 %{?with_verbose:V=1} \
f1b276d4
ER
485 CC.host="%{__cc}" \
486 CXX.host="%{__cxx}" \
b4d75247 487 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
488%endif
489 chrome %{?with_sandboxing:chrome_sandbox} \
490 %{nil}
11ad81c4 491
f8597c6e 492cd %{builddir}
535cb410
ER
493MANWIDTH=80 man ./chrome.1 > man.out
494%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
495
11ad81c4
AM
496%install
497rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
498install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
499 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
500 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
501 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 502
f8597c6e 503cd %{builddir}
37ceaf05 504cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 505install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
506%{__sed} -i -e '
507 s,@libdir@,%{_libdir}/%{name},
508
509 /@OPTIONS@/ {
510 r options.txt
511 d
512 }
513' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 514cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
c925a554 515cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
516ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
517ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 518cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 519install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 520install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 521%if %{without system_ffmpeg}
f1b276d4 522install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 523%endif
e7fa0817 524cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 525cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 526
8da7b90b 527%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 528
164020eb
ER
529%if %{with nacl}
530# Install Native Client files on platforms that support it.
531install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
532install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
533%ifarch %{x8664}
534install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
535%endif
536%ifarch %{ix86}
537install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
538%endif
539%endif
540
0c480b89
ER
541cd -
542
75f96a39 543for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
544 size=${icon##*/product_logo_}
545 size=${size%.png}
546
547 # this will skip non-numeric (22_mono_invert, 22_mono)
548 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
549 test -d "$dir" || continue
550
551 install -d $RPM_BUILD_ROOT$dir
552 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
553done
7f40f3f4 554
13840bc2
AM
555%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
556# http://code.google.com/p/chromium/issues/detail?id=24507
557gecko-mediaplayer*.so
558EOF
11ad81c4 559
589d90ea
ER
560# find locales
561%find_lang %{name}.lang
e7fa0817 562# always package en-US
f1b276d4 563%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 564
11ad81c4
AM
565%clean
566rm -rf $RPM_BUILD_ROOT
567
8da7b90b
ER
568%pretrans
569for d in locales resources; do
570 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
571 install -d %{_datadir}/%{name}
572 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
573 fi
574done
575exit 0
576
f1b276d4 577%post
0eb19b0b 578%update_icon_cache hicolor
b7a6e4ee 579%update_desktop_database
f1b276d4
ER
580%update_browser_plugins
581
582%postun
583if [ "$1" = 0 ]; then
0eb19b0b 584 %update_icon_cache hicolor
f1b276d4
ER
585 %update_browser_plugins
586fi
587
1d2b9616 588%files
11ad81c4 589%defattr(644,root,root,755)
75f96a39 590%doc AUTHORS LICENSE
f1b276d4
ER
591%{_browserpluginsconfdir}/browsers.d/%{name}.*
592%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
593%dir %{_sysconfdir}/%{name}
594%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 595%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
596%dir %{_sysconfdir}/%{name}/native-messaging-hosts
597%dir %{_sysconfdir}/%{name}/policies
598%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
599%attr(755,root,root) %{_bindir}/%{name}
600%{_mandir}/man1/%{name}.1*
11ad81c4 601%{_desktopdir}/*.desktop
0eb19b0b 602%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 603%dir %{_libdir}/%{name}
e9abb380 604%{_libdir}/%{name}/chrome*.pak
c14cd342 605%{_libdir}/%{name}/content_resources.pak
f047b07c 606%{_libdir}/%{name}/keyboard_resources.pak
97fac491 607%{_libdir}/%{name}/resources.pak
8da7b90b
ER
608%{_libdir}/%{name}/locales
609%{_libdir}/%{name}/resources
610
611%dir %{_datadir}/%{name}
612%dir %{_datadir}/%{name}/locales
613%{_datadir}/%{name}/locales/en-US.pak
614%dir %{_datadir}/%{name}/resources
615%{_datadir}/%{name}/resources/inspector
616
f1b276d4
ER
617%dir %{_libdir}/%{name}/plugins
618%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 619# These unique permissions are intentional and necessary for the sandboxing
d1a83042 620%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
621
622# ffmpeg libs
fcc48c19 623%if %{without system_ffmpeg}
f1b276d4 624%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 625%endif
f1b276d4 626
164020eb
ER
627%if %{with nacl}
628%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
629%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
630%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
631%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
632%endif
633
f1b276d4
ER
634%files l10n -f %{name}.lang
635%defattr(644,root,root,755)
This page took 0.184623 seconds and 4 git commands to generate.