]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
- updated to 1.2.7; switched to python3
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
574f2e60
JB
4# - setup dnf vendor properly? (see meson command)
5# - daemon user (see meson command)
d05d9108
MB
6#
7# Conditional build:
658d6c88 8%bcond_without apidocs # API documentation
53810c7c 9%bcond_without introspection # gobject introspection, time to time broken
aa278a7b
JB
10%bcond_without static_libs # static library
11%bcond_without python # Python binding (used by entropy and portage backends)
12%bcond_without vala # Vala binding
13# backends
d06070b1 14%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045 15%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
574f2e60 16%bcond_without dnf # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
04e18045 17%bcond_with entropy # Entropy (Sabayon) backend (Python)
574f2e60 18%bcond_with nix # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
04e18045
JB
19%bcond_without poldek # Poldek (PLD) backend
20%bcond_with portage # portage (Gentoo) backend (Python)
49ea0764 21%bcond_with slack # Slack (Slackware) backend
574f2e60 22%bcond_with zypp # ZYPP (openSUSE/SLE) backend
0e84469f 23
aa278a7b
JB
24%if %{without python}
25%undefine with_entropy
26%undefine with_portage
04e18045 27%endif
0e84469f 28
85d27e4f
JB
29Summary: System daemon that is a D-Bus abstraction layer for package management
30Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 31Name: PackageKit
dd5c7282 32Version: 1.2.7
783c79a3 33Release: 1
a2d83637 34License: GPL v2+
85d27e4f 35Group: Applications/System
90405068 36Source0: https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
dd5c7282 37# Source0-md5: 3bca1b66bff0267515ff0761df2701cf
02b3d2d3 38Patch0: %{name}-poldek.patch
aa278a7b 39Patch2: %{name}-meson.patch
bcd7526e 40Patch3: consolekit-fallback.patch
90405068 41URL: https://www.freedesktop.org/software/PackageKit/
ea58ad5c 42%{?with_apt:BuildRequires: AppStream-devel >= 0.12}
a2d83637 43BuildRequires: NetworkManager-devel >= 0.6.5
574f2e60
JB
44# pkgconfig(libalpm) >= 13.0.0
45%{?with_alpm:BuildRequires: alpm-devel >= 6.0}
49ea0764 46%{?with_dnf:BuildRequires: appstream-glib-devel}
ea58ad5c 47%{?with_apt:BuildRequires: apt-devel >= 1.9.2}
dd5c7282 48BuildRequires: bash-completion-devel >= 1:2.0
577193a4 49BuildRequires: connman-devel
49ea0764 50%{?with_slack:BuildRequires: curl-devel}
6808f644 51BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 52BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 53BuildRequires: docbook-dtd412-xml
54BuildRequires: docbook-dtd42-xml
dac2b5e1 55BuildRequires: fontconfig-devel
a0f1aeda 56BuildRequires: gettext-tools
574f2e60 57BuildRequires: glib2-devel >= 1:2.62
53810c7c 58%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
59BuildRequires: gstreamer-devel >= 1.0.0
60BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
dac2b5e1 61BuildRequires: gtk+3-devel >= 3.0.0
658d6c88 62%{?with_apidocs:BuildRequires: gtk-doc >= 1.11}
78293e06 63BuildRequires: libarchive-devel
aa278a7b 64%{?with_dnf:BuildRequires: libdnf-devel >= 0.43.1}
49ea0764
JB
65%if %{with apt} || %{with nix}
66BuildRequires: libstdc++-devel >= 6:4.7
67%endif
68%{?with_slack:BuildRequires: libstdc++-devel >= 6:5}
dac2b5e1 69BuildRequires: libxslt-progs
5ece0444 70%{?with_zypp:BuildRequires: libzypp-devel >= 17.31.0}
e0e35018 71BuildRequires: meson >= 0.50
aa278a7b 72BuildRequires: ninja >= 1.5
49ea0764 73# nix-expr nix-main nix-store
5ece0444 74%{?with_nix:BuildRequires: nix-devel >= 2.9}
dac2b5e1 75BuildRequires: pango-devel
a2d83637 76BuildRequires: pkgconfig
e0e35018 77# just to detect which reboot modes to use (library not linked)
49ea0764 78#BuildRequires: plymouth-devel >= 0.9.5
7cd3cbcf 79%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
49ea0764 80BuildRequires: polkit-devel >= 0.114
dd5c7282 81%{?with_python:BuildRequires: python3-devel >= 1:3.2}
827cd5e7 82BuildRequires: readline-devel
e0e35018 83BuildRequires: rpm-build >= 4.6
ea58ad5c 84%{?with_dnf:BuildRequires: rpm-devel >= 1:4.6}
a2d83637 85BuildRequires: rpm-pythonprov
aa278a7b
JB
86BuildRequires: rpmbuild(macros) >= 1.736
87BuildRequires: sed >= 4.0
577193a4 88BuildRequires: sqlite3-devel >= 3
574f2e60 89# or elogind >= 229.4
49ea0764 90BuildRequires: systemd-devel >= 1:213
e216f3d9 91BuildRequires: tar >= 1:1.22
9ed4ca79 92BuildRequires: udev-glib-devel
8ad97aee 93%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 94BuildRequires: xz
fcd0bc5c 95Requires(post,postun): shared-mime-info
0d5f415c 96Requires: %{name}-backend
a2d83637 97Requires: %{name}-libs = %{version}-%{release}
8d48627e 98Requires: crondaemon
49ea0764 99Requires: polkit >= 0.114
48178e4e 100Suggests: ConsoleKit-x11
e0e35018
JB
101Obsoletes: PackageKit-backend-pisi < 1.2
102Obsoletes: PackageKit-backend-ports < 1.2
103Obsoletes: PackageKit-backend-smart < 1.0
104Obsoletes: PackageKit-backend-urpmi < 1.2
105Obsoletes: PackageKit-backend-yum < 1.2
7cd3cbcf 106Obsoletes: PackageKit-docs < 0.8.4
e0e35018 107Obsoletes: pm-utils-packagekit < 0.8.15
a2d83637
MB
108BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110%description
111PackageKit is a D-Bus abstraction layer that allows the session user
112to manage packages in a secure way using a cross-distro,
113cross-architecture API.
114
85d27e4f
JB
115%description -l pl.UTF-8
116PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
117sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
118zgodnego z wieloma dystrybucjami i architekturami.
119
a2d83637 120%package libs
d05d9108
MB
121Summary: packagekit-glib library
122Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 123Group: Libraries
574f2e60 124Requires: glib2 >= 1:2.62
49ea0764 125Obsoletes: browser-plugin-packagekit < 1.1.0
a2d83637
MB
126
127%description libs
d05d9108 128packagekit-glib library.
a2d83637
MB
129
130%description libs -l pl.UTF-8
d05d9108 131Biblioteka packagekit-glib.
a2d83637
MB
132
133%package devel
d05d9108
MB
134Summary: Header files for packagekit-glib library
135Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
136Group: Development/Libraries
137Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 138Requires: dbus-devel >= 1.2.0
574f2e60 139Requires: glib2-devel >= 1:2.62
9ed4ca79 140Requires: sqlite3-devel
a2d83637
MB
141
142%description devel
d05d9108 143Header files for packagekit-glib library.
a2d83637
MB
144
145%description devel -l pl.UTF-8
d05d9108 146Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
147
148%package static
d05d9108
MB
149Summary: Static packagekit-glib library
150Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
151Group: Development/Libraries
152Requires: %{name}-devel = %{version}-%{release}
153
154%description static
d05d9108 155Static packagekit-glib library.
a2d83637
MB
156
157%description static -l pl.UTF-8
d05d9108
MB
158Statyczna biblioteka packagekit-glib.
159
8ad97aee
JB
160%package -n vala-packagekit
161Summary: Vala API for PackageKit library
162Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
163Group: Development/Libraries
164Requires: %{name}-devel = %{version}-%{release}
165Requires: vala >= 2:0.16
0e84469f 166BuildArch: noarch
8ad97aee
JB
167
168%description -n vala-packagekit
169Vala API for PackageKit library.
170
171%description -n vala-packagekit -l pl.UTF-8
172API języka Vala do biblioteki PackageKitu.
173
16acf8d5
JB
174%package apidocs
175Summary: PackageKit library API documentation
176Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
177Group: Documentation
178Requires: gtk-doc-common
2aa4ef3d 179BuildArch: noarch
16acf8d5
JB
180
181%description apidocs
182PackageKit library API documentation.
183
184%description apidocs -l pl.UTF-8
185Dokumentacja API biblioteki PackageKit.
186
d06070b1
JB
187%package backend-alpm
188Summary: PackageKit ALPM backend
189Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
190Group: Libraries
191Requires: %{name} = %{version}-%{release}
192Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
193
194%description backend-alpm
195A backend for PackageKit to enable Arch Linux packages via ALPM
196library.
197
198%description backend-alpm -l pl.UTF-8
199Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
200bibliotekę ALPM.
201
04e18045
JB
202%package backend-aptcc
203Summary: PackageKit APTcc backend
204Summary(pl.UTF-8): Backend PackageKit APTcc
205Group: Libraries
206Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
207Requires: AppStream >= 0.12
208Requires: apt >= 1.9.2
04e18045
JB
209Provides: %{name}-backend = %{version}-%{release}
210
211%description backend-aptcc
212A backend for PackageKit to enable APT support via C++ API.
213
214%description backend-aptcc -l pl.UTF-8
215Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
216C++.
217
49ea0764
JB
218%package backend-dnf
219Summary: PackageKit dnf backend
220Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece dnfhif
221Group: Libraries
222Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
223Requires: libdnf >= 0.43.1
224Requires: rpm >= 1:4.6
49ea0764 225Provides: %{name}-backend = %{version}-%{release}
e0e35018
JB
226Obsoletes: PackageKit-backend-hawkey < 1.0
227Obsoletes: PackageKit-backend-hif < 1.2
49ea0764
JB
228
229%description backend-dnf
230A backend for PackageKit to enable RPM packages support via dnf
231library (used in Fedora).
232
233%description backend-dnf -l pl.UTF-8
234Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
235dnf (używaną w dystrybucji Fedora).
236
04e18045
JB
237%package backend-entropy
238Summary: PackageKit Entropy backend
239Summary(pl.UTF-8): Backend PackageKit Entropy
240Group: Libraries
241Requires: %{name} = %{version}-%{release}
dd5c7282
JB
242Requires: python3-packagekit = %{version}-%{release}
243#Requires: python3-entropy
04e18045
JB
244Provides: %{name}-backend = %{version}-%{release}
245
246%description backend-entropy
247A backend for PackageKit to enable Sabayon packages support through
248Entropy package manager.
249
250%description backend-entropy -l pl.UTF-8
251Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
252użyciu zarządcy pakietów Entropy.
253
49ea0764
JB
254%package backend-nix
255Summary: PackageKit Nix backend
256Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów Nix
04e18045
JB
257Group: Libraries
258Requires: %{name} = %{version}-%{release}
5ece0444 259Requires: nix >= 2.9
04e18045
JB
260Provides: %{name}-backend = %{version}-%{release}
261
49ea0764
JB
262%description backend-nix
263A backend for PackageKit to enable Nix packages support (used in
264NixOS).
04e18045 265
49ea0764
JB
266%description backend-nix -l pl.UTF-8
267Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
04e18045 268
0d5f415c
ER
269%package backend-poldek
270Summary: PackageKit Poldek backend
16acf8d5 271Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
272Group: Libraries
273Requires: %{name} = %{version}-%{release}
7cd3cbcf 274Requires: poldek >= 0.30-1.rc6.4
16acf8d5 275Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
276
277%description backend-poldek
04e18045
JB
278A backend for PackageKit to enable RPM packages support through Poldek
279- native PLD package manager.
0d5f415c 280
16acf8d5 281%description backend-poldek -l pl.UTF-8
04e18045
JB
282Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
283natywnego zarządcę pakietów dystrybucji PLD.
284
285%package backend-portage
286Summary: PackageKit Portage backend
287Summary(pl.UTF-8): Backend PackageKit Portage
288Group: Libraries
289Requires: %{name} = %{version}-%{release}
dd5c7282
JB
290Requires: python3-packagekit = %{version}-%{release}
291#Requires: python3-portage
04e18045
JB
292Provides: %{name}-backend = %{version}-%{release}
293
294%description backend-portage
295A backend for PackageKit to enable Gentoo Portage support.
296
297%description backend-portage -l pl.UTF-8
298Backend PackageKit dodający obsługę systemu Portage dystrybucji
299Gentoo.
300
49ea0764
JB
301%package backend-slack
302Summary: PackageKit Slack backend
303Summary(pl.UTF-8): Backend PackageKit Slack
304Group: Libraries
305Requires: %{name} = %{version}-%{release}
306Provides: %{name}-backend = %{version}-%{release}
e0e35018 307Obsoletes: PackageKit-backend-katja < 1.2
49ea0764
JB
308
309%description backend-slack
310Slack backend for PackageKit to enable Slackware repositories support.
311
312%description backend-slack -l pl.UTF-8
313Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
314
04e18045
JB
315%package backend-zypp
316Summary: PackageKit Zypp backend
317Summary(pl.UTF-8): Backend PackageKit Zypp
318Group: Libraries
319Requires: %{name} = %{version}-%{release}
5ece0444 320Requires: libzypp >= 17.31.0
04e18045
JB
321Provides: %{name}-backend = %{version}-%{release}
322
323%description backend-zypp
324A backend for PackageKit to enable RPM packages support through Zypp
325library (originated in openSUSE/SLE).
326
327%description backend-zypp -l pl.UTF-8
328Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
329Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 330
d05d9108
MB
331%package gstreamer-plugin
332Summary: GStreamer codecs installer
333Summary(pl.UTF-8): Instalator kodeków GStreamera
334Group: Applications
335Requires: %{name} = %{version}-%{release}
aa278a7b 336Requires: %{name}-gtk3-module = %{version}-%{release}
d05d9108
MB
337
338%description gstreamer-plugin
339The PackageKit GStreamer plugin allows any GStreamer application to
340install codecs from configured repositories using PackageKit.
341
342%description gstreamer-plugin -l pl.UTF-8
343Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
344zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
345
dac2b5e1
AF
346%package gtk3-module
347Summary: GTK+ 3.x module to detect and install missing fonts
348Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
349Group: X11/Libraries
aa278a7b 350Obsoletes: PackageKit-gtk-module < 1.2.0
dac2b5e1
AF
351
352%description gtk3-module
353The PackageKit GTK+ 3.x module allows any pango application to install
354missing fonts from configured repositories using PackageKit.
355
356%description gtk3-module -l pl.UTF-8
357Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
358brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
359
a2d83637 360%package -n bash-completion-packagekit
16acf8d5
JB
361Summary: Bash completion for PackageKit console commands
362Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 363Group: Applications/Shells
577193a4 364Requires: %{name} = %{version}-%{release}
dd5c7282 365Requires: bash-completion >= 1:2.0
ead2d2f6 366BuildArch: noarch
a2d83637
MB
367
368%description -n bash-completion-packagekit
16acf8d5 369This package provides bash-completion for PackageKit console commands.
a2d83637
MB
370
371%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
372Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
373konsolowych PackageKit.
a2d83637 374
dd5c7282 375%package -n python3-packagekit
a2d83637
MB
376Summary: PackageKit Python bindings
377Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
378Group: Development/Languages/Python
dd5c7282 379Obsoletes: python-packagekit < 1.2.7
a2d83637 380
dd5c7282 381%description -n python3-packagekit
a2d83637
MB
382PackageKit Python bindings.
383
dd5c7282 384%description -n python3-packagekit -l pl.UTF-8
a2d83637
MB
385Wiązania PackageKit dla Pythona.
386
387%prep
388%setup -q
d113818a 389%patch0 -p1
aa278a7b 390%patch2 -p1
bcd7526e 391%patch3 -p1
a2d83637 392
aa278a7b
JB
393%if %{with static_libs}
394%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
d5617342 395%endif
aa278a7b
JB
396
397%build
aa278a7b 398%meson build \
dd5c7282 399 --python.bytecompile=2 \
aa278a7b 400 -Dbash_command_not_found=false \
aa278a7b 401 %{!?with_introspection:-Dgobject_introspection=false} \
658d6c88 402 %{?with_apidocs:-Dgtk_doc=true} \
aa278a7b
JB
403 -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
404 %{!?with_python:-Dpython_backend=false} \
aa278a7b
JB
405 -Dsystemdsystemunitdir=%{systemdunitdir}
406
407# TODO:
408# -Ddnf_vendor=
409# -Dpackagekit_user=
410
411%ninja_build -C build
a2d83637
MB
412
413%install
414rm -rf $RPM_BUILD_ROOT
aa278a7b 415install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
a2d83637 416
aa278a7b
JB
417%ninja_install -C build
418
419%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
e0e35018 420%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
5059111f 421
d05d9108 422# use pk-gstreamer-install as codec installer
aa278a7b 423ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
d05d9108 424
aa278a7b
JB
425install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
426ln -sf ../packagekit-offline-update.service \
427 $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
428
6808f644
MB
429%find_lang %{name}
430
a2d83637
MB
431%clean
432rm -rf $RPM_BUILD_ROOT
433
fcd0bc5c
MB
434%post
435%update_mime_database
436
437%postun
438%update_mime_database
439
85d27e4f 440%post libs -p /sbin/ldconfig
a2d83637
MB
441%postun libs -p /sbin/ldconfig
442
6808f644 443%files -f %{name}.lang
a2d83637 444%defattr(644,root,root,755)
02b3d2d3 445%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
446%attr(755,root,root) %{_bindir}/pkcon
447%attr(755,root,root) %{_bindir}/pkmon
50832223 448%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
449%attr(755,root,root) %{_libexecdir}/packagekit-direct
450%attr(755,root,root) %{_libexecdir}/packagekitd
451%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 452%dir %{_libdir}/packagekit-backend
aa278a7b 453%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
a2d83637
MB
454%dir %{_sysconfdir}/PackageKit
455%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 456%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa 457%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
d05d9108 458%dir %{_datadir}/PackageKit
6e66a3a4 459%dir %{_datadir}/PackageKit/helpers
d05d9108 460%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 461%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 462%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 463%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
dd5c7282 464%{_datadir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
a2d83637 465%{_mandir}/man1/pkcon.1*
78293e06 466%{_mandir}/man1/pkmon.1*
53810c7c 467%{systemdunitdir}/packagekit.service
7cd3cbcf 468%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 469%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
470%dir /var/cache/PackageKit
471%dir /var/cache/PackageKit/downloads
a2d83637 472%dir /var/lib/PackageKit
d05d9108 473%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
474
475%files libs
476%defattr(644,root,root,755)
74872af2 477%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 478%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 479%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
480# NOTE: dbus interface xmls are commonly used:
481# - at runtime by packagekitd
482# - for development of applications using PK dbus interface
483%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
484%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 485
a2d83637
MB
486%files devel
487%defattr(644,root,root,755)
74872af2 488%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 489%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 490%dir %{_includedir}/PackageKit
74872af2 491%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 492%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 493
0e57d6d1 494%if %{with static_libs}
a2d83637
MB
495%files static
496%defattr(644,root,root,755)
74872af2 497%{_libdir}/libpackagekit-glib2.a
0e57d6d1 498%endif
d05d9108 499
8ad97aee
JB
500%if %{with vala}
501%files -n vala-packagekit
502%defattr(644,root,root,755)
aa278a7b 503%{_datadir}/vala/vapi/packagekit-glib2.deps
8ad97aee
JB
504%{_datadir}/vala/vapi/packagekit-glib2.vapi
505%endif
506
0e57d6d1 507%if %{with apidocs}
16acf8d5
JB
508%files apidocs
509%defattr(644,root,root,755)
510%{_gtkdocdir}/PackageKit
0e57d6d1 511%endif
16acf8d5 512
d06070b1
JB
513%if %{with alpm}
514%files backend-alpm
0d5f415c 515%defattr(644,root,root,755)
d06070b1
JB
516%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
517%dir %{_sysconfdir}/PackageKit/alpm.d
518%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
519%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
520%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
574f2e60
JB
521# FIXME: dirs should be owned by alpm?
522%dir %{_datadir}/libalpm
523%dir %{_datadir}/libalpm/hooks
524%{_datadir}/libalpm/hooks/90-packagekit-refresh.hook
0d5f415c
ER
525%endif
526
04e18045
JB
527%if %{with apt}
528%files backend-aptcc
529%defattr(644,root,root,755)
530%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
531%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
532%dir %{_datadir}/PackageKit/helpers/aptcc
533%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
534%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
535%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
536%endif
537
49ea0764
JB
538%if %{with dnf}
539%files backend-dnf
540%defattr(644,root,root,755)
541%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
dd5c7282
JB
542%attr(755,root,root) %{_libexecdir}/packagekit-dnf-refresh-repo
543%{py3_sitescriptdir}/dnf-plugins/notify_packagekit.py
544%{py3_sitescriptdir}/dnf-plugins/__pycache__/notify_packagekit.cpython-*.py[co]
49ea0764
JB
545%endif
546
04e18045
JB
547%if %{with entropy}
548%files backend-entropy
549%defattr(644,root,root,755)
550%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
551%dir %{_datadir}/PackageKit/helpers/entropy
552%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
553%endif
554
49ea0764
JB
555%if %{with nix}
556%files backend-nix
ee375c30 557%defattr(644,root,root,755)
49ea0764 558%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
04e18045
JB
559%endif
560
d06070b1
JB
561%if %{with poldek}
562%files backend-poldek
563%defattr(644,root,root,755)
564%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
565%endif
566
04e18045
JB
567%if %{with portage}
568%files backend-portage
569%defattr(644,root,root,755)
570%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
571%dir %{_datadir}/PackageKit/helpers/portage
572%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
573%endif
574
49ea0764
JB
575%if %{with slack}
576%files backend-slack
577%defattr(644,root,root,755)
578%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
579%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
580%dir /var/cache/PackageKit/metadata
581%ghost /var/cache/PackageKit/metadata/metadata.db
582%endif
583
04e18045
JB
584%if %{with zypp}
585%files backend-zypp
586%defattr(644,root,root,755)
587%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
588%endif
589
d05d9108
MB
590%files gstreamer-plugin
591%defattr(644,root,root,755)
592%doc contrib/gstreamer-plugin/README
aa278a7b 593%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
02b3d2d3 594%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108 595
dac2b5e1
AF
596%files gtk3-module
597%defattr(644,root,root,755)
aa278a7b 598%doc contrib/gtk-module/{GLASS.txt,README}
dac2b5e1 599%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 600%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 601
a2d83637
MB
602%files -n bash-completion-packagekit
603%defattr(644,root,root,755)
577193a4 604%{bash_compdir}/pkcon
a2d83637 605
02b3d2d3 606%if %{with python}
dd5c7282 607%files -n python3-packagekit
a2d83637 608%defattr(644,root,root,755)
dd5c7282 609%{py3_sitescriptdir}/packagekit
02b3d2d3 610%endif
This page took 0.206852 seconds and 4 git commands to generate.