]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blob - apache-mod_clamav.spec
- added clamav patch (fix build with clamav 0.101); release 3
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
1 %define         apxs            /usr/sbin/apxs
2 %define         mod_name        clamav
3 Summary:        An Apache virus scanning filter
4 Summary(pl.UTF-8):      Filtr skanera antywirusowego dla Apache'a
5 Name:           apache-mod_%{mod_name}
6 Version:        0.23
7 Release:        3
8 License:        GPL v2
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  32c7b285dfdff5d13371b92ebe73b352
12 Source1:        %{name}.conf
13 Patch0:         %{name}-clamav.patch
14 URL:            http://software.othello.ch/mod_clamav/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0
17 BuildRequires:  apr-devel >= 1:1.0
18 BuildRequires:  apr-util-devel >= 1:1.0
19 BuildRequires:  autoconf >= 2.12
20 BuildRequires:  automake
21 BuildRequires:  clamav-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 Requires:       apache(modules-api) = %apache_modules_api
26 Requires:       apache-mod_proxy
27 Requires:       clamav
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
31 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
32
33 %description
34 mod_clamav is an Apache 2 filter which scans the content delivered by
35 the proxy module (mod_proxy) for viruses using the Clamav virus
36 scanning engine.
37
38 %description -l pl.UTF-8
39 mod_clamav to filtr dla serwera Apache 2 skanujący treści dostarczane
40 przez moduł proxy (mod_proxy) pod kątem wirusów przy użyciu silnika
41 skanera antywirusowego Clamav.
42
43 %prep
44 %setup -q -n mod_%{mod_name}-%{version}
45 %patch0 -p1
46
47 %build
48 %{__libtoolize}
49 %{__aclocal}
50 %{__autoconf}
51 %{__automake}
52 CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) -I$(/usr/bin/apu-1-config --includedir) $(pkg-config --cflags libclamav)"
53 %configure \
54         --with-apxs=%{apxs}
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
60
61 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
62 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/32_mod_clamav.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %service -q httpd restart
69
70 %postun
71 if [ "$1" = "0" ]; then
72         %service -q httpd restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS ChangeLog mod_clamav.html NEWS README TODO
78 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_clamav.conf
79 %attr(755,root,root) %{_pkglibdir}/mod_clamav.so
This page took 0.287765 seconds and 3 git commands to generate.