]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blob - apache-mod_clamav.spec
Release 8 (by relup.sh)
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
1 %define         apxs            /usr/sbin/apxs
2 %define         mod_name        clamav
3 Summary:        An Apache virus scanning filter
4 Summary(pl.UTF-8):      Filtr skanera antywirusowego dla Apache'a
5 Name:           apache-mod_%{mod_name}
6 Version:        0.23
7 Release:        8
8 License:        GPL v2
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  32c7b285dfdff5d13371b92ebe73b352
12 Source1:        %{name}.conf
13 Patch0:         %{name}-clamav.patch
14 Patch1:         gcc10.patch
15 URL:            http://software.othello.ch/mod_clamav/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel >= 2.0
18 BuildRequires:  apr-devel >= 1:1.0
19 BuildRequires:  apr-util-devel >= 1:1.0
20 BuildRequires:  autoconf >= 2.12
21 BuildRequires:  automake
22 BuildRequires:  clamav-devel
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires:       apache(modules-api) = %apache_modules_api
27 Requires:       apache-mod_proxy
28 Requires:       clamav
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
33
34 %description
35 mod_clamav is an Apache 2 filter which scans the content delivered by
36 the proxy module (mod_proxy) for viruses using the Clamav virus
37 scanning engine.
38
39 %description -l pl.UTF-8
40 mod_clamav to filtr dla serwera Apache 2 skanujący treści dostarczane
41 przez moduł proxy (mod_proxy) pod kątem wirusów przy użyciu silnika
42 skanera antywirusowego Clamav.
43
44 %prep
45 %setup -q -n mod_%{mod_name}-%{version}
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 %{__libtoolize}
51 %{__aclocal}
52 %{__autoconf}
53 %{__automake}
54 CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) -I$(/usr/bin/apu-1-config --includedir) $(pkg-config --cflags libclamav)"
55 %configure \
56         --with-apxs=%{apxs}
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
62
63 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
64 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/32_mod_clamav.conf
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %service -q httpd restart
71
72 %postun
73 if [ "$1" = "0" ]; then
74         %service -q httpd restart
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog mod_clamav.html NEWS README TODO
80 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_clamav.conf
81 %attr(755,root,root) %{_pkglibdir}/mod_clamav.so
This page took 0.082471 seconds and 4 git commands to generate.