summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2023-07-03 10:36:01 (GMT)
committerJan Palus2023-07-03 10:36:01 (GMT)
commit11d61debe5d9c5e2cc38260e5ab1c97e02a90921 (patch)
treeacf5341bfa9bd28f2df89dfe068dce97209508d0
parent67274bfd527b58203e36fd2547df984eb4a632e8 (diff)
downloadsystemtap-11d61debe5d9c5e2cc38260e5ab1c97e02a90921.zip
systemtap-11d61debe5d9c5e2cc38260e5ab1c97e02a90921.tar.gz
do disable python probes when bcond is disabled
-rw-r--r--systemtap.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/systemtap.spec b/systemtap.spec
index 638d364..3e8e24b 100644
--- a/systemtap.spec
+++ b/systemtap.spec
@@ -327,7 +327,10 @@ find testsuite/systemtap.examples/ -name '*.stp' -print0 | xargs -0 \
--enable-server \
--enable-sqlite \
--with-dyninst%{!?with_dyninst:=no} \
- --with-java=%{?with_java:%{java_home}}%{!?with_java:no}
+ --with-java=%{?with_java:%{java_home}}%{!?with_java:no} \
+ %{!?with_python2:--without-python2-probes} \
+ %{!?with_python3:--without-python3-probes}
+
%{__make} \
%{?with_java:JAVAC="%{java_home}/bin/javac"} \
%{?with_java:JAR="%{java_home}/bin/jar"}