summaryrefslogtreecommitdiff
path: root/systemtap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'systemtap.spec')
-rw-r--r--systemtap.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/systemtap.spec b/systemtap.spec
index 638d364..3e8e24b 100644
--- a/systemtap.spec
+++ b/systemtap.spec
@@ -327,7 +327,10 @@ find testsuite/systemtap.examples/ -name '*.stp' -print0 | xargs -0 \
--enable-server \
--enable-sqlite \
--with-dyninst%{!?with_dyninst:=no} \
- --with-java=%{?with_java:%{java_home}}%{!?with_java:no}
+ --with-java=%{?with_java:%{java_home}}%{!?with_java:no} \
+ %{!?with_python2:--without-python2-probes} \
+ %{!?with_python3:--without-python3-probes}
+
%{__make} \
%{?with_java:JAVAC="%{java_home}/bin/javac"} \
%{?with_java:JAR="%{java_home}/bin/jar"}