summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2015-04-11 16:27:36 (GMT)
committerJakub Bogusz2015-04-11 16:27:36 (GMT)
commit6ad503be31c57ab428c29cdee024e4b3e238187d (patch)
treea307800d88d4a1d41b2a96742d30dfc319e3ad98
parent6a8f5094881bb0989bf8fde5121d41ff6db2523a (diff)
downloadlibhif-6ad503be31c57ab428c29cdee024e4b3e238187d.zip
libhif-6ad503be31c57ab428c29cdee024e4b3e238187d.tar.gz
- updated to 0.2.0auto/th/libhif-0.2.0-1
- updated rpm5 patch - removed obsolete hawkey patch
-rw-r--r--libhif-hawkey.patch20
-rw-r--r--libhif-rpm5.patch30
-rw-r--r--libhif.spec8
3 files changed, 23 insertions, 35 deletions
diff --git a/libhif-hawkey.patch b/libhif-hawkey.patch
deleted file mode 100644
index 0a537b9..0000000
--- a/libhif-hawkey.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- libhif-0.1.8/libhif/hif-context.c.orig 2015-03-17 21:14:28.322673463 +0100
-+++ libhif-0.1.8/libhif/hif-context.c 2015-03-17 21:19:36.569327195 +0100
-@@ -36,6 +36,7 @@
-
- #include <hawkey/query.h>
- #include <hawkey/packagelist.h>
-+#include <hawkey/version.h>
- #include <librepo/librepo.h>
-
- #include "hif-cleanup.h"
-@@ -917,6 +918,9 @@
- solv_dir_real = hif_realpath (priv->solv_dir);
- priv->sack = hy_sack_create (solv_dir_real, NULL,
- priv->install_root,
-+#if HY_VERSION_CHECK(0,5,3)
-+ NULL,
-+#endif
- HY_MAKE_CACHE_DIR);
- if (priv->sack == NULL) {
- g_set_error (error,
diff --git a/libhif-rpm5.patch b/libhif-rpm5.patch
index 2e62119..875ebab 100644
--- a/libhif-rpm5.patch
+++ b/libhif-rpm5.patch
@@ -1,16 +1,16 @@
---- libhif-0.1.6/libhif/hif-context.c.orig 2014-11-10 17:12:02.000000000 +0100
-+++ libhif-0.1.6/libhif/hif-context.c 2014-11-16 15:10:10.086198310 +0100
-@@ -31,7 +31,8 @@
+--- libhif-0.2.0/libhif/hif-context.c.orig 2015-03-20 21:24:51.000000000 +0100
++++ libhif-0.2.0/libhif/hif-context.c 2015-04-11 17:13:34.053370041 +0200
+@@ -31,8 +31,8 @@
#include "config.h"
-#include <rpm/rpmlib.h>
-+#include <rpm/rpmmacro.h>
+ #include <rpm/rpmmacro.h>
+#include <rpm/rpmrc.h>
#include <hawkey/query.h>
#include <hawkey/packagelist.h>
-@@ -1133,7 +1134,7 @@ hif_context_setup (HifContext *context,
+@@ -1240,7 +1240,7 @@ hif_context_setup (HifContext *context,
"alphaev68", "alphaev7", "alphapca56", NULL } },
{ "arm", { "armv5tejl", "armv5tel", "armv6l", "armv7l", NULL } },
{ "armhfp", { "armv7hl", "armv7hnl", NULL } },
@@ -19,7 +19,7 @@
"i486", "i586", "i686", NULL } },
{ "ia64", { "ia64", NULL } },
{ "noarch", { "noarch", NULL } },
-@@ -1196,9 +1197,9 @@ hif_context_setup (HifContext *context,
+@@ -1317,9 +1317,9 @@ hif_context_setup (HifContext *context,
}
/* get info from RPM */
@@ -486,9 +486,17 @@
+}
+
+#endif /* RPMORG_COMPAT_H */
---- libhif-0.1.7/libhif/hif-source.c.orig 2014-12-18 11:01:15.000000000 +0100
-+++ libhif-0.1.7/libhif/hif-source.c 2014-12-24 00:29:49.057033122 +0100
-@@ -1127,14 +1127,11 @@ hif_source_add_public_key (HifSource *so
+--- libhif-0.2.0/libhif/hif-source.c.orig 2015-04-08 20:57:23.000000000 +0200
++++ libhif-0.2.0/libhif/hif-source.c 2015-04-11 18:00:35.709977897 +0200
+@@ -44,6 +44,7 @@
+ #include <glib/gstdio.h>
+ #include <hawkey/util.h>
+ #include <librepo/librepo.h>
++#include <rpm/rpmio.h>
+ #include <rpm/rpmts.h>
+
+ #include "hif-cleanup.h"
+@@ -1171,15 +1172,12 @@ hif_source_add_public_key (HifSource *so
{
HifSourcePrivate *priv = GET_PRIVATE (source);
gboolean ret;
@@ -500,7 +508,9 @@
- keyring = rpmtsGetKeyring (ts, 1);
- ret = hif_keyring_add_public_key (keyring, priv->pubkey_tmp, error);
- rpmKeyringFree (keyring);
+- rpmtsFree (ts);
+ ret = hif_keyring_add_public_key (ts, priv->pubkey_tmp, error);
- rpmtsFree (ts);
++ ts = rpmtsFree (ts);
return ret;
}
+
diff --git a/libhif.spec b/libhif.spec
index 6fc1292..e5917b9 100644
--- a/libhif.spec
+++ b/libhif.spec
@@ -1,14 +1,13 @@
Summary: Simple package library built on top of hawkey and librepo
Summary(pl.UTF-8): Prosta biblioteka obsługi pakietów oparta na bibliotekach hawkey i librepo
Name: libhif
-Version: 0.1.8
-Release: 2
+Version: 0.2.0
+Release: 1
License: LGPL v2.1+
Group: Libraries
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
-# Source0-md5: e2ff81e857b767491b0cb5b23b7c69de
+# Source0-md5: 550ad748c0a36ec6d27dc9a425d88baf
Patch0: %{name}-rpm5.patch
-Patch1: %{name}-hawkey.patch
URL: https://github.com/hughsie/libhif
BuildRequires: glib2-devel >= 1:2.36.0
BuildRequires: gobject-introspection-devel >= 0.9.8
@@ -75,7 +74,6 @@ Dokumentacja API biblioteki libhif.
%prep
%setup -q
%patch0 -p1
-%patch1 -p1
%build
%configure \