summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2015-03-17 20:35:24 (GMT)
committerJakub Bogusz2015-03-17 20:35:24 (GMT)
commit6a8f5094881bb0989bf8fde5121d41ff6db2523a (patch)
treeea60274b317280dc7dde4762a28c343e3491b6c5
parent178c1ad6a559d23c3bcbb8616d3aa42ed761287b (diff)
downloadlibhif-6a8f5094881bb0989bf8fde5121d41ff6db2523a.zip
libhif-6a8f5094881bb0989bf8fde5121d41ff6db2523a.tar.gz
- added hawkey patch (hawkey 0.5.3 support)
-rw-r--r--libhif-hawkey.patch20
-rw-r--r--libhif.spec4
2 files changed, 23 insertions, 1 deletions
diff --git a/libhif-hawkey.patch b/libhif-hawkey.patch
new file mode 100644
index 0000000..0a537b9
--- /dev/null
+++ b/libhif-hawkey.patch
@@ -0,0 +1,20 @@
+--- libhif-0.1.8/libhif/hif-context.c.orig 2015-03-17 21:14:28.322673463 +0100
++++ libhif-0.1.8/libhif/hif-context.c 2015-03-17 21:19:36.569327195 +0100
+@@ -36,6 +36,7 @@
+
+ #include <hawkey/query.h>
+ #include <hawkey/packagelist.h>
++#include <hawkey/version.h>
+ #include <librepo/librepo.h>
+
+ #include "hif-cleanup.h"
+@@ -917,6 +918,9 @@
+ solv_dir_real = hif_realpath (priv->solv_dir);
+ priv->sack = hy_sack_create (solv_dir_real, NULL,
+ priv->install_root,
++#if HY_VERSION_CHECK(0,5,3)
++ NULL,
++#endif
+ HY_MAKE_CACHE_DIR);
+ if (priv->sack == NULL) {
+ g_set_error (error,
diff --git a/libhif.spec b/libhif.spec
index cf206c5..6fc1292 100644
--- a/libhif.spec
+++ b/libhif.spec
@@ -2,12 +2,13 @@ Summary: Simple package library built on top of hawkey and librepo
Summary(pl.UTF-8): Prosta biblioteka obsługi pakietów oparta na bibliotekach hawkey i librepo
Name: libhif
Version: 0.1.8
-Release: 1
+Release: 2
License: LGPL v2.1+
Group: Libraries
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
# Source0-md5: e2ff81e857b767491b0cb5b23b7c69de
Patch0: %{name}-rpm5.patch
+Patch1: %{name}-hawkey.patch
URL: https://github.com/hughsie/libhif
BuildRequires: glib2-devel >= 1:2.36.0
BuildRequires: gobject-introspection-devel >= 0.9.8
@@ -74,6 +75,7 @@ Dokumentacja API biblioteki libhif.
%prep
%setup -q
%patch0 -p1
+%patch1 -p1
%build
%configure \