]> git.pld-linux.org Git - projects/template-specs.git/blob - python3-ext.spec
57d323f0ffa4149352ad815a73cfedb041a89c1e
[projects/template-specs.git] / python3-ext.spec
1 #
2 # This is template for python 3 extension modules (including compiled C code)
3 # use template-specs/python3.spec for pure python packages
4 #
5 # Conditional build:
6 %bcond_without  doc     # don't build doc
7 %bcond_without  tests   # do not perform "make test"
8
9 %define         module  template
10 Summary:        -
11 Summary(pl.UTF-8):      -
12 # Name must match the python module/package name (as on pypi or in 'import' statement)
13 Name:           python3-%{module}
14 Version:        _
15 Release:        0.1
16 License:        - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
17 Group:          Libraries/Python
18 # if pypi:
19 #Source0Download: https://pypi.org/simple/MODULE/
20 Source0:        https://files.pythonhosted.org/packages/source/M/MODULE/%{module}-%{version}.tar.gz
21 # Source0-md5:  -
22 #URL:           https://pypi.org/project/MODULE/
23 URL:            -
24 #BuildRequires: python3-setuptools
25 %if %{with tests}
26 #BuildRequires: python3-
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 BuildRequires:  python3-devel >= 1:3.2
31 # when using /usr/bin/env or other in-place substitutions
32 #BuildRequires:        sed >= 4.0
33 %if %{with doc}
34 BuildRequires:  sphinx-pdg-3
35 %endif
36 # replace with other requires if defined in setup.py
37 Requires:       python3-modules >= 1:3.2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41
42 %description -l pl.UTF-8
43
44 %package apidocs
45 Summary:        %{module} API documentation
46 Summary(pl.UTF-8):      Dokumentacja API %{module}
47 Group:          Documentation
48 %if "%{_rpmversion}" >= "4.6"
49 BuildArch:      noarch
50 %endif
51
52 %description apidocs
53 API documentation for %{module}.
54
55 %description apidocs -l pl.UTF-8
56 Dokumentacja API %{module}.
57
58 %prep
59 %setup -q -n %{module}-%{version}
60
61 # fix #!/usr/bin/env python -> #!/usr/bin/python:
62 #%{__sed} -i -e '1s,^#!.*python3,#!%{__python3},' %{name}.py
63
64 %build
65 %py3_build
66 # deprecated target, but sometimes still used: %{?with_tests:test}
67
68 %if %{with tests}
69 %{__python3} -m pytest ...
70 %endif
71
72 %if %{with doc}
73 %{__make} -C docs html \
74         SPHINXBUILD=sphinx-build-3
75 rm -rf docs/_build/html/_sources
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %py3_install
82
83 %if %{with enable_if_there_are_examples_provided_in_package}
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
85 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
86 find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
87         | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
96 %dir %{py3_sitedir}/%{module}
97 %{py3_sitedir}/%{module}/*.py
98 %attr(755,root,root) %{py3_sitedir}/%{module}/*.so
99 %{py3_sitedir}/%{module}/__pycache__
100 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
101 %{_examplesdir}/%{name}-%{version}
102
103 %if %{with doc}
104 %files apidocs
105 %defattr(644,root,root,755)
106 %doc docs/_build/html/*
107 %endif
This page took 0.036184 seconds and 2 git commands to generate.