]> git.pld-linux.org Git - projects/template-specs.git/blob - php-pecl.spec
- cleanup
[projects/template-specs.git] / php-pecl.spec
1 %define         _modname        -
2 %define         _status         -
3 Summary:        %{_modname} -
4 Summary(pl):    %{_modname} -
5 Name:           php-pecl-%{_modname}
6 Version:        1.0
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 URL:            http://pecl.php.net/package/Modname/
12 BuildRequires:  php-devel >= 3:5.0.0
13 BuildRequires:  rpmbuild(macros) >= 1.344
14 %{?requires_php_extension}
15 Requires:       php-common >= 4:5.0.4
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19
20 In PECL status of this extension is: %{_status}.
21
22 %description -l pl
23
24 To rozszerzenie ma w PECL status: %{_status}.
25
26 %prep
27 %setup -q -c
28
29 %build
30 cd %{_modname}-%{version}
31 phpize
32 %configure
33 %{__make}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
38
39 %{__make} install \
40         -C %{_modname}-%{version} \
41         INSTALL_ROOT=$RPM_BUILD_ROOT \
42         EXTENSION_DIR=%{php_extensiondir}
43 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
44 ; Enable %{_modname} extension module
45 extension=%{_modname}.so
46 EOF
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %php_webserver_restart
53
54 %postun
55 if [ "$1" = 0 ]; then
56         %php_webserver_restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
62 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
63 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.049211 seconds and 4 git commands to generate.