]> git.pld-linux.org Git - projects/template-specs.git/blob - php-pecl.spec
golang: update
[projects/template-specs.git] / php-pecl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname MODULE_NAME
7 Summary:        %{modname} -
8 Summary(pl.UTF-8):      %{modname} -
9 Name:           %{php_name}-pecl-%{modname}
10 Version:        1.0
11 Release:        1
12 License:        PHP 3.01
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
15 # Source0-md5:  -
16 URL:            http://pecl.php.net/package/MODULE_NAME/
17 %{?with_tests:BuildRequires:    %{php_name}-cli}
18 BuildRequires:  %{php_name}-devel
19 BuildRequires:  rpmbuild(macros) >= 1.666
20 %if %{with tests}
21 BuildRequires:  %{php_name}-cli
22 BuildRequires:  %{php_name}-pcre
23 %endif
24 %{?requires_php_extension}
25 Provides:       php(MODULE_NAME) = %{version}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29
30 %description -l pl.UTF-8
31
32 %prep
33 %setup -qc
34 mv %{modname}-%{version}/* .
35
36 %build
37 phpize
38 %configure
39 %{__make}
40
41 %if %{with tests}
42 # simple module load test
43 %{__php} -n -q \
44         -d extension_dir=modules \
45         -d extension=%{modname}.so \
46         -m > modules.log
47 grep %{modname} modules.log
48
49 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
50 %{__make} test \
51         PHP_EXECUTABLE=%{__php} \
52         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl" \
53
54 # or:
55 cat <<'EOF' > run-tests.sh
56 #!/bin/sh
57 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
58 %{__make} test \
59         PHP_EXECUTABLE=%{__php} \
60         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl pdo session" \
61         RUN_TESTS_SETTINGS="-q $*"
62 EOF
63
64 chmod +x run-tests.sh
65 ./run-tests.sh -w failed.log
66 test -f failed.log -a ! -s failed.log
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
72 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
73 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
74
75 %{__make} install \
76         EXTENSION_DIR=%{php_extensiondir} \
77         INSTALL_ROOT=$RPM_BUILD_ROOT
78
79 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
80 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
81 ; Enable %{modname} extension module
82 extension=%{modname}.so
83 EOF
84
85 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 %php_webserver_restart
93
94 %postun
95 if [ "$1" = 0 ]; then
96         %php_webserver_restart
97 fi
98
99 %files
100 %defattr(644,root,root,755)
101 %doc CREDITS EXPERIMENTAL
102 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
103 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
104 %{_examplesdir}/%{name}-%{version}
This page took 0.039152 seconds and 3 git commands to generate.