]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
- converted to UTF-8
[projects/template-specs.git] / perl.spec
1 # NOTE
2 # - you should consider using pldcpan for new perl packages
3 #
4 # Conditional build:
5 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
6 %bcond_without  tests   # do not perform "make test"
7 #
8 %include        /usr/lib/rpm/macros.perl
9 %define         pdir    PDIR
10 %define         pnam    PNAM
11 Summary:        -
12 Summary(pl.UTF-8):   -
13 Name:           perl-PDIR-PNAM
14 Version:        -
15 Release:        -
16 # note if it is "same as perl"
17 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
18 Group:          Development/Languages/Perl
19 Source0:        http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.tar.gz
20 Patch0:         %{name}-foo.patch
21 # most of CPAN modules have generic URL (substitute pdir and pnam here)
22 URL:            http://search.cpan.org/dist/PDIR-PNAM/
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  -
26 %if %{with autodeps} || %{with tests}
27 BuildRequires:  perl-
28 BuildRequires:  perl-
29 %endif
30 Requires:       -
31 Provides:       -
32 Obsoletes:      -
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreq      'perl(anything_fake_or_conditional)'
37
38 %description
39
40 %description -l pl.UTF-8
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %patch0 -p1
45
46 %build
47 # Don't use pipes here: they generally don't work. Apply a patch.
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make}
52 # if module isn't noarch, use:
53 # %{__make} \
54 #       OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 # NOTE it's mostly easier to copy unpackaged filelist here, and run adapter over the spec.
71 # use macros:
72 #%%{perl_vendorlib}/PDIR...
73 #%%{perl_vendorarch}/PDIR...
74 %{_mandir}/man3/*
This page took 0.10755 seconds and 4 git commands to generate.