]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
- fixed BR
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    -
7 %define pnam    -
8 Summary:        -
9 Summary(de):    -
10 Summary(es):    -
11 Summary(fr):    -
12 Summary(pl):    -
13 Summary(ru):    -
14 Name:           perl-
15 Version:        -
16 Release:        -
17 Epoch:          -
18 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
19 Group:          Development/Languages/Perl
20 Icon:           -
21 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
22 Source1:        %{name}
23 Source2:        %{name}
24 Patch0:         %{name}
25 Patch1:         %{name}
26 Patch2:         %{name}
27 URL:            -
28 BuildRequires:  perl >= 5.6
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 BuildRequires:  -
31 Requires:       -
32 Prereq:         -
33 Provides:       -
34 Obsoletes:      -
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreq      "perl(anything_fake_or_conditional)"
39
40 %description
41
42 %description -l de
43
44 %description -l es
45
46 %description -l fr
47
48 %description -l pl
49
50 %description -l ru
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57
58 %build
59 # Don't use pipes here: they generally don't work. Apply a patch.
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make}
63 # if module isn't noarch, use:
64 # %{__make} OPTIMIZE="%{rpmcflags}"
65
66 %{!?_without_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 # use macros:
81 #%%{perl_vendorlib}/...
82 #%%{perl_vendorarch}/...
83 %{_mandir}/man3/*
This page took 0.036819 seconds and 4 git commands to generate.