]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
- adjusted noarch subpackage rules and some descriptions, more pl
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #BuildRequires: autoconf
19 #BuildRequires: automake
20 #BuildRequires: intltool
21 #BuildRequires: libtool
22 # if using noarchpackage:
23 #BuildRequires: rpmbuild(macros) >= 1.752
24 #Requires(postun):      -
25 #Requires(pre,post):    -
26 #Requires(preun):       -
27 #Requires:      -
28 #Provides:      -
29 #Obsoletes:     -
30 #Conflicts:     -
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # do not keep them in newly created specs
34 # these are only here to help fixing quickly broken specs
35 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
36 %define         filterout_ld    -Wl,--as-needed
37 # do not commit spec containing this (use for local testing only):
38 %define         filterout_c     -Werror=format-security
39 %define         filterout_cpp   -D_FORTIFY_SOURCE=.
40 %define         filterout_cxx   -Werror=format-security
41
42 # Ignore file in __spec_install_post_check_so
43 BuildRequires:  rpmbuild(macros) >= 1.583
44 %define         skip_post_check_so      libunresolved.so.*
45
46 # do not commit spec containing this (use for local testing only):
47 %define         no_install_post_check_tmpfiles  1
48
49 %description
50
51 #%description -l pl.UTF-8
52
53 %package common
54 Summary:        Common files for %{name} library
55 Summary(pl.UTF-8):      Wspólne pliki biblioteki %{name}
56 Group:          Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description common
60 Common files for %{name} library.
61
62 %description common -l pl.UTF-8
63 Wspólne pliki biblioteki %{name}.
64
65 %package devel
66 Summary:        Header files for %{name} library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description devel
72 Header files for %{name} library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki %{name}.
76
77 %package static
78 Summary:        Static %{name} library
79 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static %{name} library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka %{name}.
88
89 %package apidocs
90 Summary:        API documentation for %{name} library
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
92 Group:          Documentation
93 # if not arch-dependent
94 %{?noarchpackage}
95
96 %description apidocs
97 API documentation for %{name} library.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API biblioteki %{name}.
101
102 %prep
103 %setup -q
104 #%patch0 -p1
105
106 %build
107 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
108 # appropriate BuildRequires
109 #%{__libtoolize}
110 #%{__aclocal}
111 #%{__autoconf}
112 #%{__autoheader}
113 #%{__automake}
114 %configure \
115         %{!?with_static_libs:--disable-static}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 # create directories if necessary
121 #install -d $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 # if library provides pkgconfig file containing proper {Requires,Libs}.private
127 # then remove .la pollution
128 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS CREDITS README THANKS
139 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
141
142 %files common
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/%{name}*
145 %{_datadir}/%{name}
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc devel-doc/* ChangeLog NEWS TODO
150 %attr(755,root,root) %{_libdir}/%{name}.so
151 # if no pkgconfig support, or it misses .private deps, then include .la file
152 #%{_libdir}/libFOO.la
153 %{_includedir}/%{name}
154 %{_aclocaldir}/%{name}.m4
155 %{_pkgconfigdir}/%{name}.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/%{name}.a
161 %endif
162
163 %if %{with apidocs}
164 %files apidocs
165 %defattr(644,root,root,755)
166 %doc apidocs/*
167 %endif
This page took 0.073579 seconds and 3 git commands to generate.