]> git.pld-linux.org Git - projects/template-specs.git/blob - horde.spec
Add subst for system php
[projects/template-specs.git] / horde.spec
1 # TODO
2 # - lighttpd support
3
4 # REPLACE words 'SKELETON', 'Skeleton', 'skeleton' with your application
5 # GET THE Summary from here: http://www.horde.org/source/modules.php
6 # FIND .htaccess FILES AND MAKE SURE APACHE CONF DISABLES ACCESS TO
7 # THOSE DIRS: find -name '.??*' IS EASY TO LOCATE.
8
9 %define         hordeapp        skeleton
10 Summary:        Template for horde projects
11 Name:           horde-%{hordeapp}
12 Version:        0.1
13 Release:        0.1
14 License:        GPL v2 (CHECK IT FIRST, could be ASL)
15 Group:          Applications/WWW
16 Source0:        ftp://ftp.horde.org/pub/skeleton/%{hordeapp}-h3-%{version}.tar.gz
17 # Source0-md5:  -
18 Source1:        apache.conf
19 Patch0:         prefs.patch
20 URL:            http://www.horde.org/skeleton/
21 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 Requires:       horde >= 3.0
24 Requires:       webapps
25 Requires:       webserver(access)
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         hordedir        /usr/share/horde
30 %define         _appdir         %{hordedir}/%{hordeapp}
31 %define         _webapps        /etc/webapps
32 %define         _webapp         horde-%{hordeapp}
33 %define         _sysconfdir     %{_webapps}/%{_webapp}
34
35 %define         _noautoreq      pear(Horde.*)
36
37 # GET DESCRIPTION FROM PROJECT URL
38 %description
39 SKELETON
40
41 The Horde Project writes web applications in PHP and releases them
42 under the GNU Public License. For more information (including help
43 with Skeleton) please visit <http://www.horde.org/>.
44
45 %description -l pl.UTF-8
46 SKELETON
47
48 Projekt Horde tworzy aplikacje WWW w PHP i wydaje je na licencji GNU
49 General Public License. Więcej informacji (włącznie z pomocą dla
50 Skeleton) można znaleźć na stronie <http://www.horde.org/>.
51
52 %prep
53 %setup -q -n %{hordeapp}-h3-%{version}
54 %patch0 -p1
55
56 rm {,*/}.htaccess
57 for i in config/*.dist; do
58         mv $i config/$(basename $i .dist)
59 done
60 # considered harmful (horde/docs/SECURITY)
61 rm test.php
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/docs}
66
67 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
68 cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
69 echo '<?php ?>' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.php
70 touch $RPM_BUILD_ROOT%{_sysconfdir}/conf.php.bak
71 cp -a lib locale templates themes $RPM_BUILD_ROOT%{_appdir}
72 cp -a docs/CREDITS $RPM_BUILD_ROOT%{_appdir}/docs
73
74 ln -s %{_sysconfdir} $RPM_BUILD_ROOT%{_appdir}/config
75 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
76 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 if [ ! -f %{_sysconfdir}/conf.php.bak ]; then
83         install /dev/null -o root -g http -m 0660 %{_sysconfdir}/conf.php.bak
84 fi
85
86 # CHECK FIRST DOES IT HAVE SQL AND FILE THERE.
87 if [ "$1" = 1 ]; then
88         %banner %{name} -e <<-EOF
89         IMPORTANT:
90         If you are installing Skeleton for the first time, You may need to
91         create the Skeleton database tables. To do so run:
92         zcat %{_docdir}/%{name}-%{version}/scripts/sql/%{hordeapp}.sql.gz | mysql horde
93         EOF
94 fi
95
96 %triggerin -- apache1 < 1.3.37-3, apache1-base
97 %webapp_register apache %{_webapp}
98
99 %triggerun -- apache1 < 1.3.37-3, apache1-base
100 %webapp_unregister apache %{_webapp}
101
102 %triggerin -- apache < 2.2.0, apache-base
103 %webapp_register httpd %{_webapp}
104
105 %triggerun -- apache < 2.2.0, apache-base
106 %webapp_unregister httpd %{_webapp}
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README docs/* scripts
111 %dir %attr(750,root,http) %{_sysconfdir}
112 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
113 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
114 %attr(660,root,http) %config(noreplace) %{_sysconfdir}/conf.php
115 %attr(660,root,http) %config(noreplace) %ghost %{_sysconfdir}/conf.php.bak
116 %attr(640,root,http) %config(noreplace) %{_sysconfdir}/[!c]*.php
117 %attr(640,root,http) %{_sysconfdir}/conf.xml
118
119 %dir %{_appdir}
120 %{_appdir}/*.php
121 %{_appdir}/config
122 %{_appdir}/docs
123 %{_appdir}/lib
124 %{_appdir}/locale
125 %{_appdir}/templates
126 %{_appdir}/themes
This page took 0.37481 seconds and 3 git commands to generate.