]> git.pld-linux.org Git - packages/zziplib.git/blob - zziplib.spec
- fixed multi-job build
[packages/zziplib.git] / zziplib.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # build without documentation
4 #
5 Summary:        ZZipLib - libZ-based ZIP-access Library
6 Summary(pl.UTF-8):      ZZipLib - biblioteka dostępu do archiwów ZIP
7 Name:           zziplib
8 Version:        0.13.58
9 Release:        1
10 Epoch:          1
11 License:        LGPL with exceptions (see COPYING.ZZIP)
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/zziplib/%{name}-%{version}.tar.bz2
14 # Source0-md5:  a0f743a5a42ca245b2003ecaea958487
15 Patch0:         %{name}-ac.patch
16 Patch1:         %{name}-manpages.patch
17 Patch2:         %{name}-fetch.patch
18 URL:            http://zziplib.sourceforge.net/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  libtool >= 1:1.4.3
22 BuildRequires:  xmlto
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 ZZipLib provides read access to zipped files in a zip-archive, using
28 compression based solely on free algorithms provided by zlib. ZZipLib
29 provides an additional API to transparently access files being either
30 real files or zipped files with the same filepath argument. This is
31 handy to package many files being shared data into a single zip file -
32 as it is sometimes used with gamedata or script repositories. The
33 library itself is fully multithreaded, and it is namespace clean using
34 the zzip_ prefix for its exports and declarations.
35
36 %description -l pl.UTF-8
37 ZZipLib pozwala na odczyt plików skompresowanych w archiwach zip,
38 używając do dekompresji wolnodostępnych algorytmów z biblioteki zlib.
39 ZZipLib dostarcza dodatkowe API do przezroczystego dostępu do plików
40 rzeczywistych lub umieszczonych w archiwach zip przy pomocy takiej
41 samej ścieżki. Jest to przydatne przy trzymaniu wielu plików w jednym
42 archiwum, co bywa stosowane w przypadku danych dla gier lub
43 repozytoriów. Biblioteka jest w pełni wielowątkowa i ma czystą
44 przestrzeń nazw (używa prefiksu zzip_).
45
46 %package devel
47 Summary:        ZZipLib - Development Files
48 Summary(pl.UTF-8):      Pliki dla programistów ZZipLib
49 Group:          Development/Libraries
50 Requires:       %{name} = %{epoch}:%{version}-%{release}
51
52 %description devel
53 These are the header files needed to develop programs using zziplib.
54
55 %description devel -l pl.UTF-8
56 Ten pakiet zawiera plikia nagłówkowe potrzebne do tworzenia programów
57 korzystających z biblioteki zziplib.
58
59 %package static
60 Summary:        ZZipLib static library
61 Summary(pl.UTF-8):      Statyczna biblioteka ZZipLib
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 ZZipLib static library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka ZZipLib.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         --disable-builddir
85
86 %{__make}
87 %{__make} -j1 check
88 %if %{with doc}
89 %{__make} doc
90 %endif
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %if %{with doc}
99 %{__make} install-man3 -C docs \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 rm -f docs/zziplib[012].html
103 %endif
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc ChangeLog TODO docs/COPYING.Z*
114 %attr(755,root,root) %{_bindir}/zzcat
115 %attr(755,root,root) %{_bindir}/zzdir
116 %attr(755,root,root) %{_bindir}/zzxor*
117 %attr(755,root,root) %{_bindir}/unzip-mem
118 %attr(755,root,root) %{_bindir}/unzzip*
119 %attr(755,root,root) %{_libdir}/libzzip-0.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libzzip-0.so.13
121 %attr(755,root,root) %{_libdir}/libzzipfseeko-0.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libzzipfseeko-0.so.13
123 %attr(755,root,root) %{_libdir}/libzzipmmapped-0.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libzzipmmapped-0.so.13
125 %attr(755,root,root) %{_libdir}/libzzipwrap-0.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libzzipwrap-0.so.13
127
128 %files devel
129 %defattr(644,root,root,755)
130 %if %{with doc}
131 %doc docs/*.html
132 %endif
133 %attr(755,root,root) %{_libdir}/libzzip.so
134 %attr(755,root,root) %{_libdir}/libzzipfseeko.so
135 %attr(755,root,root) %{_libdir}/libzzipmmapped.so
136 %attr(755,root,root) %{_libdir}/libzzipwrap.so
137 %{_libdir}/libzzip.la
138 %{_libdir}/libzzipfseeko.la
139 %{_libdir}/libzzipmmapped.la
140 %{_libdir}/libzzipwrap.la
141 %{_includedir}/zzip
142 %{_includedir}/zzip*.h
143 %if %{with doc}
144 %{_mandir}/man3/__zzip_*.3*
145 %{_mandir}/man3/zzip_*.3*
146 %endif
147 %{_pkgconfigdir}/zzip-zlib-config.pc
148 %{_pkgconfigdir}/zzipfseeko.pc
149 %{_pkgconfigdir}/zziplib.pc
150 %{_pkgconfigdir}/zzipmmapped.pc
151 %{_pkgconfigdir}/zzipwrap.pc
152 %{_aclocaldir}/zziplib.m4
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libzzip.a
157 %{_libdir}/libzzipfseeko.a
158 %{_libdir}/libzzipmmapped.a
159 %{_libdir}/libzzipwrap.a
This page took 1.861461 seconds and 3 git commands to generate.