]> git.pld-linux.org Git - packages/zstd.git/blob - zstd.spec
disable parallel build
[packages/zstd.git] / zstd.spec
1 Summary:        Zstandard - fast lossless compression algorithm
2 Summary(pl.UTF-8):      Zstandard - szybki, bezstratny algorytm kompresji
3 Name:           zstd
4 Version:        1.4.8
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/facebook/zstd/releases
9 Source0:        https://github.com/facebook/zstd/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  6714b17a74cdb38d13b7664f38aaf264
11 URL:            https://github.com/facebook/zstd
12 BuildRequires:  gcc >= 5:3.2
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %ifarch %{arm}
16 %define         archcflags      -DMEM_FORCE_MEMORY_ACCESS=1
17 %endif
18
19 %description
20 Zstd, short for Zstandard, is a fast lossless compression algorithm,
21 targeting real-time compression scenarios at zlib-level compression
22 ratio.
23
24 %description -l pl.UTF-8
25 Zstd (skrót od Zstandard) to szybki, bezstratny algorytm kompresji, do
26 zastosowwań przy kompresji w czasie rzeczywistym ze współczynnikiem
27 kompresji zbliżonym do biblioteki zlib.
28
29 %package devel
30 Summary:        Header files for Zstd library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Zstd
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for Zstd library.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe biblioteki Zstd.
40
41 %package static
42 Summary:        Static Zstd library
43 Summary(pl.UTF-8):      Statyczna biblioteka Zstd
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static Zstd library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka Zstd.
52
53 %prep
54 %setup -q
55
56 %build
57 CC="%{__cc}" \
58 CXX="%{__cxx}" \
59 CFLAGS="%{rpmcflags} %{rpmcppflags} %{?archcflags}" \
60 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
61 LDFLAGS="%{rpmldflags}" \
62 %{__make} -j1 allmost manual \
63         V=1
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT/%{_lib}
68
69 %{__make} install \
70         V=1 \
71         DESTDIR=$RPM_BUILD_ROOT \
72         PREFIX=%{_prefix} \
73         LIBDIR=%{_libdir}
74
75 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libzstd.so.* $RPM_BUILD_ROOT/%{_lib}
76 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libzstd.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libzstd.so
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc LICENSE CHANGELOG README.md
87 %attr(755,root,root) %{_bindir}/unzstd
88 %attr(755,root,root) %{_bindir}/zstd
89 %attr(755,root,root) %{_bindir}/zstdcat
90 %attr(755,root,root) %{_bindir}/zstdgrep
91 %attr(755,root,root) %{_bindir}/zstdless
92 %attr(755,root,root) %{_bindir}/zstdmt
93 %attr(755,root,root) /%{_lib}/libzstd.so.*.*.*
94 %attr(755,root,root) %ghost /%{_lib}/libzstd.so.1
95 %{_mandir}/man1/unzstd.1*
96 %{_mandir}/man1/zstd.1*
97 %{_mandir}/man1/zstdcat.1*
98 %{_mandir}/man1/zstdgrep.1*
99 %{_mandir}/man1/zstdless.1*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc doc/{zstd_compression_format.md,zstd_manual.html,images}
104 %attr(755,root,root) %{_libdir}/libzstd.so
105 %{_includedir}/zdict.h
106 %{_includedir}/zstd.h
107 %{_includedir}/zstd_errors.h
108 %{_pkgconfigdir}/libzstd.pc
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libzstd.a
This page took 0.144413 seconds and 4 git commands to generate.