]> git.pld-linux.org Git - packages/zita-resampler.git/commitdiff
- updated to 1.8.0, now with SSE2 support (bcond added) auto/th/zita-resampler-1.8.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Sep 2021 18:04:41 +0000 (20:04 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Sep 2021 18:04:41 +0000 (20:04 +0200)
zita-resampler.spec

index cba7924523bfd1dbd57093b1990f86dcea9b9fe2..29387744f43fba2f6610f8e3066e5dd6893f7698 100644 (file)
@@ -1,15 +1,23 @@
+#
+# Conditional build:
+%bcond_with    sse2    # SSE2 support
+
+%ifarch %{x8664} x32
+%define        with_sse2       1
+%endif
 Summary:       C++ library for sample rate conversion of audio signals
 Summary(pl.UTF-8):     Biblioteka C++ do konwersji szybkości próbkowania sygnałów dźwiękowych
 Name:          zita-resampler
-Version:       1.6.2
+Version:       1.8.0
 Release:       1
 License:       GPL v3+
 Group:         Libraries
 Source0:       http://kokkinizita.linuxaudio.org/linuxaudio/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 9b2cff7fa419febbca3a13435b2a24b3
+# Source0-md5: 48071a4449820768fa45fd41cded69fa
 URL:           http://kokkinizita.linuxaudio.org/linuxaudio/
 BuildRequires: libsndfile-devel
 BuildRequires: libstdc++-devel
+BuildRequires: sed >= 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -48,18 +56,23 @@ Przykładowe aplikacje wykorzystujące bibliotekę %{name}.
 %prep
 %setup -q
 
+%if %{without sse2}
+%{__sed} -i -e '/-DENABLE_SSE2/d' source/Makefile
+%endif
+
 %build
 CPPFLAGS="%{rpmcppflags}" \
 LDFLAGS="%{rpmldflags}" \
 %{__make} -C source \
        CXX="%{__cxx}" \
-       CXXFLAGS="%{rpmcxxflags} -fPIC -Wall -ffast-math"
+       CXXFLAGS="%{rpmcxxflags} -fPIC -Wall -ffast-math%{?with_sse2: -msse2}"
 
 ln -s "$(basename source/libzita-resampler.so.*.*.*)" source/libzita-resampler.so
 
 CPPFLAGS="-I../source %{rpmcppflags}" \
 LDFLAGS="-L../source %{rpmldflags}" \
 %{__make} -C apps \
+       CXX="%{__cxx}" \
        CXXFLAGS="%{rpmcxxflags} -Wall -ffast-math"
 
 %install
This page took 0.416761 seconds and 4 git commands to generate.