]> git.pld-linux.org Git - packages/zita-resampler.git/blob - zita-resampler.spec
- updated to 1.11.2
[packages/zita-resampler.git] / zita-resampler.spec
1 #
2 # Conditional build:
3 %bcond_with     sse2    # SSE2 support
4
5 %ifarch %{x8664} x32
6 %define with_sse2       1
7 %endif
8 Summary:        C++ library for sample rate conversion of audio signals
9 Summary(pl.UTF-8):      Biblioteka C++ do konwersji szybkości próbkowania sygnałów dźwiękowych
10 Name:           zita-resampler
11 Version:        1.11.2
12 Release:        1
13 License:        GPL v3+
14 Group:          Libraries
15 Source0:        http://kokkinizita.linuxaudio.org/linuxaudio/downloads/%{name}-%{version}.tar.xz
16 # Source0-md5:  da0373a02f0d1ba0a15a1fd270a177cd
17 URL:            http://kokkinizita.linuxaudio.org/linuxaudio/
18 BuildRequires:  libsndfile-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Zita-resampler is a C++ library for sample rate conversion of audio
27 signals.
28
29 %description -l pl.UTF-8
30 Zita-resampler to biblioteka C++ do konwersji szybkości próbkowania
31 sygnałów dźwiękowych.
32
33 %package devel
34 Summary:        Header files for %{name} library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libstdc++-devel
39
40 %description devel
41 Header files for %{name} library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki %{name}.
45
46 %package apps
47 Summary:        Example applications using the %{name} library
48 Summary(pl.UTF-8):      Przykładowe aplikacje wykorzystujące bibliotekę %{name}
49 Group:          Applications/Sound
50 Requires:       %{name} = %{version}-%{release}
51
52 %description apps
53 Example applications using the %{name} library.
54
55 %description apps -l pl.UTF-8
56 Przykładowe aplikacje wykorzystujące bibliotekę %{name}.
57
58 %prep
59 %setup -q
60
61 %if %{without sse2}
62 %{__sed} -i -e '/-DENABLE_SSE2/d' source/Makefile
63 %endif
64
65 %build
66 CPPFLAGS="%{rpmcppflags}" \
67 LDFLAGS="%{rpmldflags}" \
68 %{__make} -C source \
69         CXX="%{__cxx}" \
70         CXXFLAGS="%{rpmcxxflags} -fPIC -Wall -ffast-math%{?with_sse2: -msse2}"
71
72 ln -s "$(basename source/libzita-resampler.so.*.*.*)" source/libzita-resampler.so
73
74 CPPFLAGS="-I../source %{rpmcppflags}" \
75 LDFLAGS="-L../source %{rpmldflags}" \
76 %{__make} -C apps \
77         CXX="%{__cxx}" \
78         CXXFLAGS="%{rpmcxxflags} -Wall -ffast-math"
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir}/man1}
83
84 cp -p source/lib%{name}.so.1.* $RPM_BUILD_ROOT%{_libdir}
85 /sbin/ldconfig -nN $RPM_BUILD_ROOT%{_libdir}
86 ln -s "$(basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.1.*)" $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
87 cp -pr source/%{name} $RPM_BUILD_ROOT%{_includedir}
88
89 %{__make} -C apps install \
90         PREFIX="%{_prefix}" \
91         DESTDIR="$RPM_BUILD_ROOT"
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS README
102 %attr(755,root,root) %{_libdir}/libzita-resampler.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libzita-resampler.so.1
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libzita-resampler.so
108 %{_includedir}/zita-resampler
109
110 %files apps
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_bindir}/zresample
113 %attr(755,root,root) %{_bindir}/zretune
114 %{_mandir}/man1/zresample.1*
115 %{_mandir}/man1/zretune.1*
This page took 0.12774 seconds and 4 git commands to generate.