]> git.pld-linux.org Git - packages/zint.git/blob - zint.spec
- updated to 2.12.0
[packages/zint.git] / zint.spec
1 Summary:        Barcode generator
2 Summary(pl.UTF-8):      Generator kodów kreskowych
3 Name:           zint
4 Version:        2.12.0
5 Release:        1
6 License:        BSD (zint library), GPL v3+ (Qt backend, frontends)
7 Group:          Applications/Graphics
8 Source0:        https://downloads.sourceforge.net/zint/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  6cb6d70fcbca2fa0becec628fb1aa360
10 URL:            https://sourceforge.net/projects/zint/
11 # Qt6 also possible (with -DZINT_QT6=ON)
12 BuildRequires:  Qt5Core-devel >= 5
13 BuildRequires:  Qt5Gui-devel >= 5
14 BuildRequires:  Qt5UiTools-devel >= 5
15 BuildRequires:  Qt5Widgets-devel >= 5
16 BuildRequires:  Qt5Xml-devel >= 5
17 BuildRequires:  cmake >= 3.5
18 BuildRequires:  libpng-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  qt5-build >= 5
21 BuildRequires:  qt5-qmake >= 5
22 BuildRequires:  rpmbuild(macros) >= 1.605
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Zint is a C library for encoding data in several barcode variants. The
27 bundled command-line utility provides a simple interface to the
28 library. Features of the library:
29 - Over 50 symbologies including all ISO/IEC standards, like QR codes.
30 - Unicode translation for symbologies which support Latin-1 and Kanji
31   character sets.
32 - Full GS1 support including data verification and automated insertion
33   of FNC1 characters.
34 - Support for encoding binary data including NULL (ASCII 0)
35   characters.
36 - Health Industry Barcode (HIBC) encoding capabilities.
37 - Output in PNG, EPS and SVG formats with user adjustable sizes and
38   colors.
39 - Verification stage for SBN, ISBN and ISBN-13 data.
40
41 %description -l pl.UTF-8
42 Zint to biblioteka C do kodowania danych w kilku wariantach kodów
43 koreskowych. Dołączone narzędzie linii poleceń udostępnia prosty
44 interfejs do biblioteki. Możliwości biblioteki:
45 - ponad 50 zestawów symboli, w tym wszystkie standardy ISO/IEC, typu
46   kody QR
47 - tłumaczenie unikodowe symboli obsługujących zestawy znaków Latin-1 i
48   Kanji
49 - pełna obsługa GS1, w tym weryfikacja danych i automatyczne
50   wstawianie znaków FNC1
51 - obsługa kodowania danych binarnych wraz ze znakami NULL (ASCII 0)
52 - możliwość kodowania HIBC (Health Industry Barcode)
53 - wyjście w formatach PNG, EPS, SVG z rozmiarami i kolorami
54   wybieranymi przez użytkownika
55 - etap weryfikacji dla danych SBN, ISBN i ISBN-13.
56
57 %package devel
58 Summary:        Header files for zint library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki zint
60 License:        BSD
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description devel
65 Header files for zint library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki zint.
69
70 %package qt
71 Summary:        Zint Barcode Studio
72 Summary(pl.UTF-8):      Zint Barcode Studio
73 License:        GPL v3+
74 Group:          X11/Applications/Graphics
75 Requires:       %{name} = %{version}-%{release}
76
77 %description qt
78 Zint Barcode Studio is a Qt-based GUI which allows desktop users to
79 generate barcodes which can then be embedded in documents or HTML
80 pages.
81
82 %description qt -l pl.UTF-8
83 Zint Barcode Studio jest aplikacją z interfejsem Qt, która umożliwia
84 użytkownikom komputerów generować kody kreskowe. Mogą one później
85 zostać włączone do dokumentów lub stron HTML.
86
87 %package qt-devel
88 Summary:        Header files for QZint library
89 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QZint
90 License:        GPL v3+
91 Group:          X11/Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93 Requires:       %{name}-qt = %{version}-%{release}
94 Requires:       Qt5Gui-devel >= 5
95
96 %description qt-devel
97 Header files for QZint library.
98
99 %description qt-devel -l pl.UTF-8
100 Pliki nagłówkowe biblioteki QZint.
101
102 %prep
103 %setup -q -n %{name}-%{version}-src
104
105 find -type f -exec chmod 644 {} \;
106
107 # build libQZint as shared
108 %{__sed} -i -e '/^add_library/ s/ STATIC / SHARED /' backend_qt/CMakeLists.txt
109
110 %build
111 install -d build
112 cd build
113 %cmake .. \
114         -DDATA_INSTALL_DIR=%{_datadir}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
121
122 %{__make} -C build install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__mv} $RPM_BUILD_ROOT%{_datadir}/cmake/{modules,Modules}
126
127 install zint-qt.png $RPM_BUILD_ROOT%{_pixmapsdir}
128 install zint-qt.desktop $RPM_BUILD_ROOT%{_desktopdir}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %post   qt -p /sbin/ldconfig
137 %postun qt -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc ChangeLog LICENSE README TODO
142 %attr(755,root,root) %{_bindir}/zint
143 %attr(755,root,root) %{_libdir}/libzint.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libzint.so.2.12
145 %{_mandir}/man1/zint.1*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libzint.so
150 %{_includedir}/zint.h
151 %{_datadir}/cmake/Modules/FindZint.cmake
152 %dir %{_datadir}/zint
153 %{_datadir}/zint/zint*.cmake
154
155 %files qt
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/zint-qt
158 %attr(755,root,root) %{_libdir}/libQZint.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libQZint.so.2.12
160 %{_desktopdir}/zint-qt.desktop
161 %{_pixmapsdir}/zint-qt.png
162
163 %files qt-devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libQZint.so
166 %{_includedir}/qzint.h
This page took 0.137855 seconds and 4 git commands to generate.