]> git.pld-linux.org Git - packages/z80ex.git/blob - z80ex.spec
- pl, cmake version, moved base docs to base
[packages/z80ex.git] / z80ex.spec
1 Summary:        ZiLOG Z80 CPU emulator
2 Summary(pl.UTF-8):      Emulator procesora ZiLOG Z80
3 Name:           z80ex
4 Version:        1.1.21
5 Release:        1
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/z80ex/%{name}-%{version}.tar.gz
9 # Source0-md5:  92ab8d8f45fd7b448075b820013a5f97
10 URL:            http://z80ex.sourceforge.net/
11 BuildRequires:  cmake >= 2.8
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Z80Ex is a ZiLOG Z80 CPU emulator.
16
17 Features:
18 - precise opcode emulation (documented & undocumented)
19 - exact timings for each opcode (including I/O operations)
20 - full support for all interrupt modes
21 - any number of virtual CPUs may be created
22 - portable: written in pure ANSI C
23 - builds as a library with simple callback-based API
24 - disassembler included
25
26 %description -l pl.UTF-8
27 Z80Ex to emulator procesora ZiLOG Z80.
28
29 Możliwości:
30 - precyzyjna emulacja instrukcji (udokumentowanych i nie)
31 - dokładne czasy dla wszystkich instrukcji (wraz z operacjami we/wy)
32 - pełna obsługa wszystkich trybów przerwań
33 - możliwość utworzenia dowolnej liczby wirtualnych procesorów
34 - przenośność - napisany w czystym ANSI C
35 - budowanie jako biblioteka z prostym API opartym na wywołaniach
36   zwrotnych
37 - dołączony disasembler
38
39 %package devel
40 Summary:        Z80Ex header files
41 Summary(pl.UTF-8):      Pliki nagłówkowe Z80Ex
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for Z80Ex libraries.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe bibliotek Z80Ex.
50
51 %package static
52 Summary:        Static Z80Ex libraries
53 Summary(pl.UTF-8):      Biblioteki statyczne Z80Ex
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static Z80Ex libraries.
59
60 %description static -l pl.UTF-8
61 Biblioteki statyczne Z80Ex.
62
63 %prep
64 %setup -q
65
66 %build
67 install -d build
68 cd build
69 %cmake ..
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 %{__make} -C build install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc Changelog README TODO
91 %attr(755,root,root) %{_libdir}/libz80ex.so.1.1.21
92 %attr(755,root,root) %ghost %{_libdir}/libz80ex.so.1
93 %attr(755,root,root) %{_libdir}/libz80ex_dasm.so.1.1.21
94 %attr(755,root,root) %ghost %{_libdir}/libz80ex_dasm.so.1
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libz80ex.so
99 %attr(755,root,root) %{_libdir}/libz80ex_dasm.so
100 %{_includedir}/z80ex
101 %{_examplesdir}/%{name}-%{version}
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libz80ex.a
106 %{_libdir}/libz80ex_dasm.a
This page took 0.118706 seconds and 4 git commands to generate.