]> git.pld-linux.org Git - packages/yubioath-desktop.git/blob - yubioath-desktop.spec
411e097267d243a349a7c9e72f8dccffd5dcc88c
[packages/yubioath-desktop.git] / yubioath-desktop.spec
1 Summary:        Yubikey tool for generating OATH event-based HOTP and time-based TOTP codes
2 Name:           yubioath-desktop
3 Version:        3.1.0
4 Release:        1
5 License:        GPL v3+
6 Group:          X11/Applications
7 URL:            https://developers.yubico.com/yubioath-desktop/
8 Source0:        https://developers.yubico.com/yubioath-desktop/Releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  2b36482fc4ecd5edf8cc4d72716bdef4
10 BuildRequires:  asciidoc
11 BuildRequires:  desktop-file-utils
12 BuildRequires:  python-devel
13 Requires:       pcsc-driver-ccid
14 Requires:       python-PySide
15 Requires:       pythonegg(click)
16 Requires:       ykpers
17 Requires(post): desktop-file-utils
18 Requires(postun):       desktop-file-utils
19 BuildArch:      noarch
20
21 %description
22 The Yubico Authenticator is a graphical desktop tool and CLI for
23 generating Open AuTHentication (OATH) event-based HOTP and time-based
24 TOTP one-time password codes, with the help of a YubiKey that protects
25 the shared secrets.
26
27 %prep
28 %setup -q
29
30 %build
31 %{py_build}
32
33 for m in man/*.adoc; do
34         a2x -f manpage "$m"
35 done
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %{py_install}
40
41 # man pages
42 install -d $RPM_BUILD_ROOT%{_mandir}/man1
43 cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
44
45 # desktop file
46 desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} %{_builddir}/%{buildsubdir}/resources/yubioath.desktop
47
48 # icons
49 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
50 cp %{_builddir}/%{buildsubdir}/resources/yubioath.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
51 install -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps
52 cp %{_builddir}/%{buildsubdir}/resources/yubioath-desktop.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %update_icon_cache hicolor
59 %update_desktop_database
60
61 %postun
62 if [ $1 -eq 0 ] ; then
63         %update_icon_cache hicolor
64 fi
65 %update_desktop_database
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog NEWS README
70 %attr(755,root,root) %{_bindir}/yubioath
71 %attr(755,root,root) %{_bindir}/yubioath-gui
72 %{py_sitescriptdir}/yubioath
73 %{py_sitescriptdir}/yubioath_desktop*.egg-info
74 %{_desktopdir}/yubioath.desktop
75 %{_iconsdir}/hicolor/128x128/apps/yubioath-desktop.png
76 %{_pixmapsdir}/yubioath.xpm
77 %{_mandir}/man1/yubioath-gui.1*
78 %{_mandir}/man1/yubioath.1*
This page took 0.094416 seconds and 2 git commands to generate.