]> git.pld-linux.org Git - packages/yubico-piv-tool.git/blob - yubico-piv-tool.spec
- updated to 2.5.0
[packages/yubico-piv-tool.git] / yubico-piv-tool.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  tests           # unit tests
5
6 Summary:        Tool for interacting with the PIV applet on a YubiKey NEO
7 Summary(pl.UTF-8):      Narzędzie do komunikacji z apletem PIV na YubiKey NEO
8 Name:           yubico-piv-tool
9 Version:        2.5.0
10 Release:        1
11 License:        BSD
12 Group:          Applications
13 Source0:        https://developers.yubico.com/yubico-piv-tool/Releases/%{name}-%{version}.tar.gz
14 # Source0-md5:  106baecf9860ccb6f052ac9cc2b6ddd9
15 URL:            https://developers.yubico.com/yubico-piv-tool/
16 BuildRequires:  check-devel >= 0.9.6
17 BuildRequires:  cmake >= 3.5
18 BuildRequires:  gcc >= 6:4.7
19 BuildRequires:  gengetopt
20 BuildRequires:  help2man
21 BuildRequires:  openssl-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  pkgconfig
24 Requires:       %{name}-libs = %{version}-%{release}
25 Requires:       pcsc-driver-ccid
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Yubico PIV tool is used for interacting with the Privilege and
30 Identification Card (PIV) applet on a YubiKey NEO.
31
32 With it you may generate keys on the device, importing keys and
33 certificates, and create certificate requests, and other operations.
34
35 %description -l pl.UTF-8
36 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
37 (Privilege and Identification card) na urządzeniach YubiKey NEO.
38
39 Przy jego pomocy można generować klucze na urządzeniu, importować
40 klucze i certyfikaty, tworzyć żądania certyfikatów oraz wykonywać inne
41 operacje.
42
43 %package libs
44 Summary:        Yubico PIV shared libraries
45 Summary(pl.UTF-8):      Biblioteki współdzielone Yubico PIV
46 Group:          Libraries
47
48 %description libs
49 The Yubico PIV tool is used for interacting with the Privilege and
50 Identification Card (PIV) applet on a YubiKey NEO. This package
51 contains shared libraries for the tool.
52
53 %description libs -l pl.UTF-8
54 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
55 (Privilege and Identification card) na urządzeniach YubiKey NEO. Ten
56 pakiet zawiera biblioteki współdzielone wykorzystywane przez
57 narzędzie.
58
59 %package devel
60 Summary:        Header files for Yubico PIV libraries
61 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Yubico PIV
62 Group:          Development/Libraries
63 Requires:       %{name}-libs = %{version}-%{release}
64 Requires:       openssl-devel
65
66 %description devel
67 The Yubico PIV tool is used for interacting with the Privilege and
68 Identification Card (PIV) applet on a YubiKey NEO. This package
69 includes development files.
70
71 %description devel -l pl.UTF-8
72 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
73 (Privilege and Identification card) na urządzeniach YubiKey NEO. Ten
74 pakiet zawiera pliki programistyczne.
75
76 %package static
77 Summary:        Yubico PIV static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne Yubico PIV
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 The Yubico PIV tool is used for interacting with the Privilege and
84 Identification Card (PIV) applet on a YubiKey NEO. This package
85 includes static libraries.
86
87 %description static -l pl.UTF-8
88 Narzędzie Yubico PIV Tool służy do komunikacji z apletem PIV
89 (Privilege and Identification card) na urządzeniach YubiKey NEO. Ten
90 pakiet zawiera biblioteki statyczne.
91
92 %prep
93 %setup -q
94
95 %build
96 mkdir -p build
97 cd build
98 %cmake .. \
99         -DBACKEND="pcsc" \
100         %{!?with_tests:-DSKIP_TESTS:BOOL=ON}
101 %{__make}
102
103 %if %{with tests}
104 %{__make} test
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %{__make} -C build install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   libs -p /sbin/ldconfig
116 %postun libs -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc COPYING NEWS README doc/*.adoc
121 %attr(755,root,root) %{_bindir}/yubico-piv-tool
122 %{_mandir}/man1/yubico-piv-tool.1*
123
124 %files libs
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libykpiv.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libykpiv.so.2
128 %attr(755,root,root) %{_libdir}/libykcs11.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libykcs11.so.2
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libykpiv.so
134 %attr(755,root,root) %{_libdir}/libykcs11.so
135 %{_pkgconfigdir}/ykpiv.pc
136 %{_pkgconfigdir}/ykcs11.pc
137 %{_includedir}/ykpiv
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libykpiv.a
143 %{_libdir}/libykcs11.a
144 %endif
This page took 0.177037 seconds and 4 git commands to generate.