]> git.pld-linux.org Git - packages/yt-dlp.git/commitdiff
up to 2022.08.14 auto/th/yt-dlp-2022.08.14-1
authorJan Palus <atler@pld-linux.org>
Mon, 15 Aug 2022 09:25:18 +0000 (11:25 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 15 Aug 2022 09:25:18 +0000 (11:25 +0200)
- upstream patch to skip devscripts installation

no-install-devscripts.patch [new file with mode: 0644]
yt-dlp.spec

diff --git a/no-install-devscripts.patch b/no-install-devscripts.patch
new file mode 100644 (file)
index 0000000..3c7f65f
--- /dev/null
@@ -0,0 +1,37 @@
+From 460eb9c50e0970fdceb51485c5fe3268574c48e8 Mon Sep 17 00:00:00 2001
+From: Lesmiscore <nao20010128@gmail.com>
+Date: Mon, 15 Aug 2022 15:43:43 +0900
+Subject: [PATCH] [build] Exclude devscripts from installs
+
+Closes #4667
+---
+ pyinst.py | 2 +-
+ setup.py  | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pyinst.py b/pyinst.py
+index 9be5d896041..0b7c66a30fa 100644
+--- a/pyinst.py
++++ b/pyinst.py
+@@ -81,7 +81,7 @@ def version_to_list(version):
+ def dependency_options():
+     # Due to the current implementation, these are auto-detected, but explicitly add them just in case
+     dependencies = [pycryptodome_module(), 'mutagen', 'brotli', 'certifi', 'websockets']
+-    excluded_modules = ['test', 'ytdlp_plugins', 'youtube_dl', 'youtube_dlc']
++    excluded_modules = ('youtube_dl', 'youtube_dlc', 'test', 'ytdlp_plugins', 'devscripts')
+     yield from (f'--hidden-import={module}' for module in dependencies)
+     yield '--collect-submodules=websockets'
+diff --git a/setup.py b/setup.py
+index aebe1dead9f..e376a694a38 100644
+--- a/setup.py
++++ b/setup.py
+@@ -28,7 +28,7 @@
+ def packages():
+     if setuptools_available:
+-        return find_packages(exclude=('youtube_dl', 'youtube_dlc', 'test', 'ytdlp_plugins'))
++        return find_packages(exclude=('youtube_dl', 'youtube_dlc', 'test', 'ytdlp_plugins', 'devscripts'))
+     return [
+         'yt_dlp', 'yt_dlp.extractor', 'yt_dlp.downloader', 'yt_dlp.postprocessor', 'yt_dlp.compat',
index 022e7a571b2ba4c99b5c9a65361e672587ff9433..6a05f206addd39c3243002a884daa8b2189c9e8d 100644 (file)
@@ -1,11 +1,12 @@
 Summary:       A youtube-dl fork with additional features and fixes
 Name:          yt-dlp
-Version:       2022.08.08
+Version:       2022.08.14
 Release:       1
 License:       Public Domain
 Group:         Applications/System
 Source0:       https://github.com/yt-dlp/yt-dlp/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d3c14db4c81504702f0f61e03b6af595
+# Source0-md5: 405ecebddf10ca44ea6c6dedf00277a1
+Patch0:                no-install-devscripts.patch
 URL:           https://github.com/yt-dlp/yt-dlp
 BuildRequires: python3-modules >= 1:3.7
 BuildRequires: python3-setuptools
@@ -33,6 +34,7 @@ Python 3 video extraction utility for YouTube.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %py3_build
This page took 0.065894 seconds and 4 git commands to generate.