]> git.pld-linux.org Git - packages/yara.git/blob - yara.spec
- pl, enabled more modules (cuckoo, dex, macho, magic); release 2
[packages/yara.git] / yara.spec
1 # TODO
2 # - http://yara.readthedocs.org/en/latest/gettingstarted.html#compiling-and-installing-yara
3
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 %bcond_without  crypto          # OpenSSL crypto support (in PE module)
7
8 Summary:        The pattern matching swiss knife for malware researchers (and everyone else)
9 Summary(pl.UTF-8):      Narzędzie do dopasowywania wzorców dla wyszukujących złośliwe oprogramowanie (i nie tylko)
10 Name:           yara
11 Version:        4.3.2
12 Release:        2
13 License:        Apache v2.0
14 Group:          Libraries
15 Source0:        https://github.com/VirusTotal/yara/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  cace2a274542e9c611c90b92b406a188
17 Patch0:         cflags.patch
18 URL:            https://virustotal.github.io/yara/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  bison
22 BuildRequires:  flex
23 BuildRequires:  jansson-devel
24 BuildRequires:  libmagic-devel
25 BuildRequires:  libtool >= 2:2
26 %{?with_crypto:BuildRequires:   openssl-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 YARA is a tool aimed at (but not limited to) helping malware
33 researchers to identify and classify malware samples. With YARA you
34 can create descriptions of malware families (or whatever you want to
35 describe) based on textual or binary patterns. Each description, a.k.a
36 rule, consists of a set of strings and a boolean expression which
37 determine its logic.
38
39 %description -l pl.UTF-8
40 YARA to narzędzie, którego celem jest (głównie, ale nie tylko) pomoc
41 wyszukującym złośliwe oprogramowanie w identyfikacji i klasyfikacji
42 próbek takiego kodu. Przy użyciu YARA można tworzyć opisy rodzin
43 złośliwego oprogramowania (lub czegokolwiek innego) w oparciu o wzorce
44 tekstowe lub binarne. Każdy opis (reguła) składa się ze zbioru
45 łańcuchów i wyrażeń logicznych określających logikę.
46
47 %package devel
48 Summary:        Header files for yara library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki yara
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       jansson-devel
53 Requires:       libmagic-devel
54 %{?with_crypto:Requires:        openssl-devel}
55
56 %description devel
57 Header files for yara library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki yara.
61
62 %package static
63 Summary:        Static yara library
64 Summary(pl.UTF-8):      Statyczna biblioteka yara
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static yara library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka yara.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --disable-silent-rules \
85         %{__with_without crypto} \
86         --enable-cuckoo \
87         --enable-dex \
88         --enable-macho \
89         --enable-magic \
90         %{!?with_static_libs:--disable-static}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libyara.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README.md AUTHORS CONTRIBUTORS
111 %attr(755,root,root) %{_bindir}/yara
112 %attr(755,root,root) %{_bindir}/yarac
113 %attr(755,root,root) %{_libdir}/libyara.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libyara.so.10
115 %{_mandir}/man1/yara.1*
116 %{_mandir}/man1/yarac.1*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %{_includedir}/yara.h
121 %{_includedir}/yara
122 %{_libdir}/libyara.so
123 %{_pkgconfigdir}/yara.pc
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libyara.a
129 %endif
This page took 0.171502 seconds and 4 git commands to generate.