]> git.pld-linux.org Git - packages/yaml-cpp.git/commitdiff
- updated to 0.7.0 (new soname)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 Jul 2022 13:00:10 +0000 (15:00 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 Jul 2022 13:00:10 +0000 (15:00 +0200)
- updated gtest-no-install patch
- added cmake-config patch (fix missing link library name in cmake config file)

yaml-cpp-cmake-config.patch [new file with mode: 0644]
yaml-cpp-gtest-no-install.patch
yaml-cpp.spec

diff --git a/yaml-cpp-cmake-config.patch b/yaml-cpp-cmake-config.patch
new file mode 100644 (file)
index 0000000..4bdd926
--- /dev/null
@@ -0,0 +1,12 @@
+--- yaml-cpp-yaml-cpp-0.7.0/CMakeLists.txt.orig        2022-07-02 09:37:10.699581186 +0200
++++ yaml-cpp-yaml-cpp-0.7.0/CMakeLists.txt     2022-07-02 09:37:13.156234543 +0200
+@@ -127,6 +127,9 @@ set_target_properties(yaml-cpp PROPERTIE
+   PROJECT_LABEL "yaml-cpp ${yaml-cpp-label-postfix}"
+   DEBUG_POSTFIX "${CMAKE_DEBUG_POSTFIX}")
++# substituted in yaml-cpp-config.cmake
++set(EXPORT_TARGETS yaml-cpp CACHE INTERNAL "export targets")
++
+ configure_package_config_file(
+   "${PROJECT_SOURCE_DIR}/yaml-cpp-config.cmake.in"
+   "${PROJECT_BINARY_DIR}/yaml-cpp-config.cmake"
index 3711fb93e2320abc602d6df0bc1d84c4a0d36bea..57015ccc72b88eabba22ff81ae196544a00942c2 100644 (file)
@@ -1,26 +1,10 @@
---- yaml-cpp-yaml-cpp-0.6.2/test/gtest-1.8.0/googlemock/CMakeLists.txt.orig    2018-03-06 05:56:23.000000000 +0100
-+++ yaml-cpp-yaml-cpp-0.6.2/test/gtest-1.8.0/googlemock/CMakeLists.txt 2018-06-25 18:05:05.861189115 +0200
-@@ -103,10 +103,6 @@
- ########################################################################
- #
- # Install rules
--install(TARGETS gmock gmock_main
--  DESTINATION lib)
--install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
--  DESTINATION include)
+--- yaml-cpp-yaml-cpp-0.7.0/test/CMakeLists.txt.orig   2021-07-10 17:53:22.000000000 +0200
++++ yaml-cpp-yaml-cpp-0.7.0/test/CMakeLists.txt        2022-07-02 08:00:07.984458875 +0200
+@@ -2,6 +2,7 @@ find_package(Threads REQUIRED)
  
- ########################################################################
- #
---- yaml-cpp-yaml-cpp-0.6.2/test/gtest-1.8.0/googletest/CMakeLists.txt.orig    2018-03-06 05:56:23.000000000 +0100
-+++ yaml-cpp-yaml-cpp-0.6.2/test/gtest-1.8.0/googletest/CMakeLists.txt 2018-06-25 18:05:19.014522293 +0200
-@@ -102,10 +102,6 @@
- ########################################################################
- #
- # Install rules
--install(TARGETS gtest gtest_main
--  DESTINATION lib)
--install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
--  DESTINATION include)
+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+ set(BUILD_MOCK ON CACHE BOOL "" FORCE)
++set(INSTALL_GTEST OFF CACHE BOOL "" FORCE)
+ set(CMAKE_POLICY_DEFAULT_CMP0048 NEW)
  
- ########################################################################
- #
+ add_subdirectory(
index 3a769d2d74323fdccb1dfa88ee9a5e245b69f4d2..e37b86e33b3b709141a92754c2f8ca387c97abdf 100644 (file)
@@ -1,14 +1,15 @@
 Summary:       YAML parser and emitter for C++
 Summary(pl.UTF-8):     Biblioteka C++ analizująca i generująca YAML
 Name:          yaml-cpp
-Version:       0.6.2
+Version:       0.7.0
 Release:       1
 License:       MIT
 Group:         Libraries
 #Source0Download: https://github.com/jbeder/yaml-cpp/releases
 Source0:       https://github.com/jbeder/yaml-cpp/archive/%{name}-%{version}.tar.gz
-# Source0-md5: 5b943e9af0060d0811148b037449ef82
+# Source0-md5: 74d646a3cc1b5d519829441db96744f0
 Patch0:                %{name}-gtest-no-install.patch
+Patch1:                %{name}-cmake-config.patch
 URL:           https://github.com/jbeder/yaml-cpp/
 BuildRequires: cmake >= 2.6
 BuildRequires: libstdc++-devel >= 6:4.7
@@ -37,11 +38,17 @@ Pliki nagłówkowe biblioteki yaml-cpp.
 %prep
 %setup -q -n %{name}-%{name}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
 cd build
-%cmake ..
+# .pc file requires relative INCLUDEDIR, LIBDIR
+# DATADIR is used for arch-dependent .pc and cmake files
+%cmake .. \
+       -DCMAKE_INSTALL_INCLUDEDIR=include \
+       -DCMAKE_INSTALL_LIBDIR=%{_lib} \
+       -DCMAKE_INSTALL_DATADIR=%{_lib}
 %{__make}
 
 %install
@@ -60,7 +67,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc LICENSE README.md
 %attr(755,root,root) %{_libdir}/libyaml-cpp.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libyaml-cpp.so.0.6
+%attr(755,root,root) %ghost %{_libdir}/libyaml-cpp.so.0.7
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.14838 seconds and 4 git commands to generate.