]> git.pld-linux.org Git - packages/xz.git/blob - xz.spec
- rel .3
[packages/xz.git] / xz.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make check
4 #
5 %define snap    alpha
6 Summary:        LZMA Encoder/Decoder
7 Summary(pl.UTF-8):      Koder/Dekoder LZMA
8 Name:           lzma
9 Version:        4.999.5
10 Release:        0.%{snap}.3
11 Epoch:          1
12 License:        LGPL v2.1+, helper scripts on GPL v2+
13 Group:          Applications/Archiving
14 Source0:        http://tukaani.org/lzma/%{name}-%{version}%{snap}.tar.gz
15 # Source0-md5:  db736e080858a7c34357960254dda280
16 Patch0:         %{name}-memlimit.patch
17 URL:            http://tukaani.org/lzma/
18 BuildRequires:  rpmbuild(macros) >= 1.402
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 LZMA is default and general compression method of 7z format in 7-Zip
23 program. LZMA provides high compression ratio and very fast
24 decompression, so it is very suitable for embedded applications. For
25 example, it can be used for ROM (firmware) compressing.
26
27 LZMA features:
28
29 - Compressing speed: 500 KB/s on 1 GHz CPU
30 - Decompressing speed:
31   - 8-12 MB/s on 1 GHz Intel Pentium 3 or AMD Athlon.
32   - 500-1000 KB/s on 100 MHz ARM, MIPS, PowerPC or other simple RISC
33     CPU.
34 - Small memory requirements for decompressing: 8-32 KB + dictionary
35   size
36 - Small code size for decompressing: 2-8 KB (depending from speed
37   optimizations)
38
39 %description -l pl.UTF-8
40 LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
41 stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
42 bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
43 Przykładowo, może być użyty do kompresji ROM-u (firmware'u).
44
45 Cechy LZMA:
46
47 - Szybkość kompresowania: 500 KB/s na 1 GHz procesorze,
48 - Szybkość dekompresowania:
49   - 8-12 MB/s na 1 GHz Pentium 3 lub Athlonie,
50   - 500-1000 KB/s na 100 MHz procesorach ARM, MIPS, PowerPC lub innych
51     prostych RISC-ach,
52 - Mała ilość pamięci potrzebna do dekompresowania: 8-32 KB + rozmiar
53   słownika,
54 - Mały rozmiar kodu dekompresującego: 2-8 KB (w zależności od opcji
55   optymalizacji).
56
57 %package libs
58 Summary:        LZMA shared library
59 Summary(pl.UTF-8):      Biblioteka współdzielona LZMA
60 Group:          Libraries
61
62 %description libs
63 LZMA shared library.
64
65 %description libs -l pl.UTF-8
66 Biblioteka współdzielona LZMA.
67
68 %package devel
69 Summary:        Header file for LZMA library
70 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki LZMA
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73
74 %description devel
75 Header file for LZMA library.
76
77 %description devel -l pl.UTF-8
78 Plik nagłówkowy biblioteki LZMA.
79
80 %package static
81 Summary:        LZMA static library
82 Summary(pl.UTF-8):      Biblioteka statyczna LZMA
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
85
86 %description static
87 LZMA static library.
88
89 %description static -l pl.UTF-8
90 Biblioteka statyczna LZMA.
91
92 %prep
93 %setup -q -n %{name}-%{version}%{snap}
94 %patch0 -p1
95
96 %build
97 %configure
98
99 %{__make}
100
101 %{?with_tests:%{__make} check}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT/{etc/env.d,%{_lib}}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 mv -f $RPM_BUILD_ROOT%{_libdir}/liblzma.so.* $RPM_BUILD_ROOT/%{_lib}
111 ln -sf /%{_lib}/liblzma.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/liblzma.so
112
113 echo '#LZMA_OPT="--threads=2"' > $RPM_BUILD_ROOT/etc/env.d/LZMA_OPT
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   libs -p /sbin/ldconfig
121 %postun libs -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/LZMA_OPT
126 %attr(755,root,root) %{_bindir}/*lz*
127 %{_mandir}/man1/lz*.1*
128
129 %files libs -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS COPYING README THANKS TODO
132 %doc doc/{bugs,faq,file-format,history,lzma-intro}.txt
133 %attr(755,root,root) /%{_lib}/liblzma.so.*.*.*
134 %attr(755,root,root) %ghost /%{_lib}/liblzma.so.0
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc doc/liblzma-*.txt
139 %attr(755,root,root) %{_libdir}/liblzma.so
140 %{_libdir}/liblzma.la
141 %{_includedir}/lzma.h
142 %{_includedir}/lzma
143 %{_pkgconfigdir}/lzma.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/liblzma.a
This page took 0.094743 seconds and 4 git commands to generate.