]> git.pld-linux.org Git - packages/xz.git/blob - xz.spec
- rel 6; fix segfault and deadlock (from upstream)
[packages/xz.git] / xz.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make check
4 %bcond_without  asm     # ix86 asm optimizations
5
6 %ifnarch %{ix86}
7 # Speed-optimized CRC64 using slicing-by-four algorithm. This uses only i386
8 # instructions, but it is optimized for i686 and later (including e.g. Pentium
9 # II/III/IV, Athlon XP, and Core 2).
10 %undefine       with_asm
11 %endif
12
13 %if "%{pld_release}" == "ac"
14 %undefine       with_asm
15 %endif
16
17 Summary:        LZMA Encoder/Decoder
18 Summary(pl.UTF-8):      Koder/Dekoder LZMA
19 Name:           xz
20 Version:        5.1.1
21 Release:        6
22 Epoch:          1
23 License:        LGPL v2.1+, helper scripts on GPL v2+
24 Group:          Applications/Archiving
25 Source0:        http://tukaani.org/xz/%{name}-%{version}alpha.tar.gz
26 # Source0-md5:  bb24436fa12780808e1c142980484104
27 Patch0:         %{name}-parallel.patch
28 Patch1:         %{name}-git.patch
29 URL:            http://tukaani.org/xz/
30 %{?with_asm:BuildRequires:      gcc >= 5:3.4}
31 BuildRequires:  rpm >= 4.4.9-56
32 BuildRequires:  rpmbuild(macros) >= 1.402
33 BuildRequires:  sed >= 4.0
34 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
35 Suggests:       mktemp
36 Provides:       lzma = %{epoch}:%{version}-%{release}
37 Obsoletes:      lzma < 1:4.999.6
38 Conflicts:      rpm < 4.4.9
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 LZMA is default and general compression method of 7z format in 7-Zip
43 program. LZMA provides high compression ratio and very fast
44 decompression, so it is very suitable for embedded applications. For
45 example, it can be used for ROM (firmware) compressing.
46
47 LZMA features:
48
49 - Compressing speed: 500 KB/s on 1 GHz CPU
50 - Decompressing speed:
51   - 8-12 MB/s on 1 GHz Intel Pentium 3 or AMD Athlon.
52   - 500-1000 KB/s on 100 MHz ARM, MIPS, PowerPC or other simple RISC
53     CPU.
54 - Small memory requirements for decompressing: 8-32 KB + dictionary
55   size
56 - Small code size for decompressing: 2-8 KB (depending from speed
57   optimizations)
58
59 %description -l pl.UTF-8
60 LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
61 stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
62 bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
63 Przykładowo, może być użyty do kompresji ROM-u (firmware'u).
64
65 Cechy LZMA:
66
67 - Szybkość kompresowania: 500 KB/s na 1 GHz procesorze,
68 - Szybkość dekompresowania:
69   - 8-12 MB/s na 1 GHz Pentium 3 lub Athlonie,
70   - 500-1000 KB/s na 100 MHz procesorach ARM, MIPS, PowerPC lub innych
71     prostych RISC-ach,
72 - Mała ilość pamięci potrzebna do dekompresowania: 8-32 KB + rozmiar
73   słownika,
74 - Mały rozmiar kodu dekompresującego: 2-8 KB (w zależności od opcji
75   optymalizacji).
76
77 %package libs
78 Summary:        LZMA shared library
79 Summary(pl.UTF-8):      Biblioteka współdzielona LZMA
80 Group:          Libraries
81 Provides:       lzma-libs = %{epoch}:%{version}-%{release}
82 Obsoletes:      lzma-libs < 1:4.999.6
83
84 %description libs
85 LZMA shared library.
86
87 %description libs -l pl.UTF-8
88 Biblioteka współdzielona LZMA.
89
90 %package devel
91 Summary:        Header file for LZMA library
92 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki LZMA
93 Group:          Development/Libraries
94 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
95 Provides:       lzma-devel = %{epoch}:%{version}-%{release}
96 Obsoletes:      lzma-devel < 1:4.999.6
97
98 %description devel
99 Header file for LZMA library.
100
101 %description devel -l pl.UTF-8
102 Plik nagłówkowy biblioteki LZMA.
103
104 %package static
105 Summary:        LZMA static library
106 Summary(pl.UTF-8):      Biblioteka statyczna LZMA
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
109 Provides:       lzma-static = %{epoch}:%{version}-%{release}
110 Obsoletes:      lzma-static < 1:4.999.6
111
112 %description static
113 LZMA static library.
114
115 %description static -l pl.UTF-8
116 Biblioteka statyczna LZMA.
117
118 %prep
119 %setup -q -n %{name}-%{version}alpha
120 %patch0 -p1
121 %patch1 -p1
122
123 %build
124 %configure \
125         %{!?with_asm:--disable-assembler}
126 %{__make}
127
128 %{?with_tests:%{__make} check}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT/{etc/env.d,%{_lib}}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 mv -f $RPM_BUILD_ROOT%{_libdir}/liblzma.so.* $RPM_BUILD_ROOT/%{_lib}
138 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/liblzma.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/liblzma.so
139
140 echo '#XZ_OPT="--threads=2"' > $RPM_BUILD_ROOT/etc/env.d/XZ_OPT
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   libs -p /sbin/ldconfig
148 %postun libs -p /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/XZ_OPT
153 %attr(755,root,root) %{_bindir}/lz*
154 %attr(755,root,root) %{_bindir}/unlzma
155 %attr(755,root,root) %{_bindir}/unxz
156 %attr(755,root,root) %{_bindir}/xz*
157 %{_mandir}/man1/lz*.1*
158 %{_mandir}/man1/unlzma.1*
159 %{_mandir}/man1/unxz.1*
160 %{_mandir}/man1/xz*.1*
161
162 %files libs
163 %defattr(644,root,root,755)
164 %doc AUTHORS COPYING README THANKS
165 %doc doc/*.txt
166 %attr(755,root,root) /%{_lib}/liblzma.so.*.*.*
167 %attr(755,root,root) %ghost /%{_lib}/liblzma.so.5
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/liblzma.so
172 %{_libdir}/liblzma.la
173 %{_includedir}/lzma.h
174 %{_includedir}/lzma
175 %{_pkgconfigdir}/liblzma.pc
176
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/liblzma.a
This page took 0.352021 seconds and 4 git commands to generate.