]> git.pld-linux.org Git - packages/xqilla.git/commitdiff
- updated to 2.3.4 auto/th/xqilla-2.3.4-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 24 Nov 2020 20:16:28 +0000 (21:16 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 24 Nov 2020 20:16:28 +0000 (21:16 +0100)
- updated soname patch
- removed obsolete xerces patches

xqilla-soname.patch
xqilla-xerces-1.patch [deleted file]
xqilla-xerces-2.patch [deleted file]
xqilla.spec

index 7682eb499e1733f9804d8fcd72ea931711517a0b..6a24aedf726636fc5a40f5917dca1e1c104a9afc 100644 (file)
@@ -1,11 +1,11 @@
---- XQilla-2.3.3/Makefile.am.orig      2016-05-14 10:35:38.767625802 +0200
-+++ XQilla-2.3.3/Makefile.am   2016-05-14 10:36:21.874290660 +0200
+--- XQilla-2.3.4/Makefile.am.orig      2020-11-24 20:50:53.101771350 +0100
++++ XQilla-2.3.4/Makefile.am   2020-11-24 20:56:27.303294159 +0100
 @@ -17,7 +17,7 @@
  
  # Library version, see http://sourceware.org/autobook/autobook/autobook_91.html
  # -no-undefined for Cygwin (bug #1639669)
--libxqilla_la_LDFLAGS = -version-info 6:0:3 -no-undefined
-+libxqilla_la_LDFLAGS = -version-info 6:3:0 -no-undefined
+-libxqilla_la_LDFLAGS = -version-info 6:0:4 -no-undefined
++libxqilla_la_LDFLAGS = -version-info 6:4:0 -no-undefined
  
  libxqilla_la_SOURCES = \
  src/framework/ReferenceCounted.cpp \
diff --git a/xqilla-xerces-1.patch b/xqilla-xerces-1.patch
deleted file mode 100644 (file)
index 27839ca..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/dom-api/impl/XPathDocumentImpl.cpp.orig        2017-09-03 19:24:35 UTC
-+++ src/dom-api/impl/XPathDocumentImpl.cpp
-@@ -62,7 +62,11 @@ DOMNode *XPathDocumentImpl::insertBefore
-     if (thisNodeImpl->isReadOnly())
-         throw DOMException(DOMException::NO_MODIFICATION_ALLOWED_ERR, 0, getMemoryManager());
-+#if _XERCES_VERSION >= 30200
-+    DOMNode* thisNode = fParent.fContainingNode;
-+#else
-     DOMNode* thisNode = castToNode(&fParent);
-+#endif
-     if (newChild->getOwnerDocument() != thisNode)
-         throw DOMException(DOMException::WRONG_DOCUMENT_ERR, 0, getMemoryManager());
diff --git a/xqilla-xerces-2.patch b/xqilla-xerces-2.patch
deleted file mode 100644 (file)
index 041e925..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
---- src/dom-api/impl/XPathNamespaceImpl.cpp.orig       2017-09-03 20:26:37 UTC
-+++ src/dom-api/impl/XPathNamespaceImpl.cpp
-@@ -33,7 +33,11 @@ XERCES_CPP_NAMESPACE_USE;
- XPathNamespaceImpl::XPathNamespaceImpl(const XMLCh* const nsPrefix, 
-               const XMLCh* const nsUri, DOMElement *owner, DOMDocument *docOwner) 
-+#if _XERCES_VERSION >= 30200 
-+      : fNode(this, docOwner)
-+#else
-       : fNode(docOwner)
-+#endif
- {
-     DOMNodeImpl *argImpl = castToNodeImpl(this);
-@@ -54,7 +58,13 @@ XPathNamespaceImpl::XPathNamespaceImpl(c
- }
- XPathNamespaceImpl::XPathNamespaceImpl(const XPathNamespaceImpl &other) 
--      : fNode(other.fNode), uri(other.uri), prefix(other.prefix)
-+#if _XERCES_VERSION >= 30200 
-+      : fNode(this, other.fNode),
-+#else
-+      : fNode(other.fNode), 
-+
-+#endif
-+        uri(other.uri), prefix(other.prefix)
- {
- }
-@@ -196,7 +206,11 @@ short            XPathNamespaceImpl::com
-     //if it is a custom node and bigger than us we must ask it for the order
-     if(otherType > DOMXPathNamespace::XPATH_NAMESPACE_NODE) {
-+#if _XERCES_VERSION >= 30200 
-+        DOMNodeImpl tmp(const_cast<XPathNamespaceImpl *>(this), 0);
-+#else
-         DOMNodeImpl tmp(0);
-+#endif
- #if _XERCES_VERSION >= 30000
-         return tmp.reverseTreeOrderBitPattern(other->compareDocumentPosition(this));
- #else
index 7ab639cd02f9e059a81413f40f7bb92b642340cd..5d873c0ef10a42725261b82b8957253cb22fcf45 100644 (file)
@@ -5,19 +5,14 @@
 Summary:       XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
 Summary(pl.UTF-8):     XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
 Name:          xqilla
-Version:       2.3.3
-Release:       3
+Version:       2.3.4
+Release:       1
 License:       Apache v2.0
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
-# Source0-md5: 8ece20348687b6529bb934c17067803c
+# Source0-md5: 9b77644c8b0d0741d895d3ccfbfe0016
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-soname.patch
-# https://sourceforge.net/p/xqilla/bugs/48/
-# https://sourceforge.net/p/xqilla/bugs/48/attachment/patch-src_dom-api_impl_XPathDocumentImpl.cpp
-Patch2:                %{name}-xerces-1.patch
-# https://sourceforge.net/p/xqilla/bugs/48/attachment/patch-src_dom-api_impl_XPathNamespaceImpl.cpp
-Patch3:                %{name}-xerces-2.patch
 URL:           http://xqilla.sourceforge.net/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -25,6 +20,7 @@ BuildRequires:        faxpp-devel
 BuildRequires: flex
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:1.5
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: tidy-devel
 BuildRequires: xerces-c-devel >= 3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -68,9 +64,7 @@ Statyczna biblioteka XQilla.
 Summary:       XQilla API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki XQilla
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
+%{?noarchpackage}
 
 %description apidocs
 API and internal documentation for XQilla library.
@@ -82,12 +76,10 @@ Dokumentacja API biblioteki XQilla.
 %setup -q -n XQilla-%{version}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p0
-%patch3 -p0
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I autotools/m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
This page took 0.084675 seconds and 4 git commands to generate.